lokomotive f0 und Geschwindigkeit

lokomotive f0 und Geschwindigkeit

Postby Acmezger » 12.02.2018, 14:43

[fixed] Warum wenn ich f0 (lights) on oder off drucke, wird auch ein Befehl Geschwindigkeit 0 geschickt?

Anton
Last edited by Acmezger on 01.04.2018, 09:09, edited 1 time in total.
Acmezger
 

Re: lokomotive f0 und Geschwindigkeit

Postby rjversluis » 12.02.2018, 14:50

Anton,

das hängt vom verwendete Zentrale ab.
Aber welche du verwendest hast du nicht erwähnt. -o

http://wiki.rocrail.net/doku.php?id=issue-de
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: lokomotive f0 und Geschwindigkeit

Postby GeSchu » 12.02.2018, 14:58

Anton,
wo sind den Deine Dateien? Dein Plan z.Beispiel? Dort könnte man deine Konfiguiration finden. Vielleicht ist dort etwas nicht korrekt eingestellt?
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: lokomotive f0 und Geschwindigkeit

Postby Acmezger » 12.02.2018, 15:44

mein plan.xml habe ich jetzt noch zugefügt. Vielleicht habe ich eine Option vergessen. meine Zentrale ist ein Maerklin cs3.

gruss

Anton
You do not have the required permissions to view the files attached to this post.
Acmezger
 

Re: lokomotive f0 und Geschwindigkeit

Postby rjversluis » 12.02.2018, 15:51

Hi Anton,

wenn F0 über ein Rocrail Regler geschaltet wird dann werden auch Speed Kommandos versendet weil manche Zentrale F0 und Speed in ein Kommando zusammen gefasst haben.
Was stört dann?
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: lokomotive f0 und Geschwindigkeit

Postby Acmezger » 12.02.2018, 16:08

Es handelt sich immer noch um meine blöde Decoder, der sich nicht in signal mode versetzen lässt. Der spreche ich an mit f0,f1,f2 über die Lokadresse. Es hat mich nur gestört, dass ich geschwindigskeitbefehle sehe, auch wenn es wahrscheinlich nicht stört. Ich schicke aber den Befehl über ein xmlscript.

Gruss

Anton
Acmezger
 

Re: lokomotive f0 und Geschwindigkeit

Postby rjversluis » 12.02.2018, 16:11

Hallo Anton,

blöde Decoder landen bei mir immer ins runde Archiv.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: lokomotive f0 und Geschwindigkeit

Postby Acmezger » 12.02.2018, 16:27

hallo Rob

Du hast recht, aber zurzeit bin ich darauf angewiesen. also keine Möglichkeit f0 vom xmlscript ohne speed zu schicken?

Gruss

Anton
Acmezger
 

Re: lokomotive f0 und Geschwindigkeit

Postby rjversluis » 12.02.2018, 16:44

Hi Anton,

und wie sieht dein XMLScript dann aus?
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: lokomotive f0 und Geschwindigkeit

Postby Acmezger » 12.02.2018, 17:02

Drei xmlscripts (im Anhang) um rot, grün/gelb und grün zu schalten

Gruss

Anton
You do not have the required permissions to view the files attached to this post.
Acmezger
 

Re: lokomotive f0 und Geschwindigkeit

Postby rjversluis » 12.02.2018, 17:49

Hi Anton,

schon wie vorher geschrieben ist es bei viele Zentrale so das F0 mittels ein Fahrkommando übermittelt wird, also ist es zwangsweise so.
Aber Signale mittels Lok Kommandos setzen werde ich nicht unterstützen. Frage bei der Hersteller nach warum du diese Decoder nicht anders einstellen kann.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: lokomotive f0 und Geschwindigkeit

Postby Acmezger » 12.02.2018, 18:01

schon nachgefragt, aber kein zufriedenstellendes Antwort bekommen. Scheinbar sollte es nicht mit der cs3 initialisiert werden können.

Auf jedem Fall vielen Dank

Gruss

Anton
Acmezger
 

Re: lokomotive f0 und Geschwindigkeit

Postby rjversluis » 13.02.2018, 09:29

Moin Anton,

ich habe beim fn Kommando ein extra Attribute 'standalone' aufgenommen:
Code: Select all
<fn id="loco1" fnchanged="0" f0="true" standalone="false"/>

Dieses Attribute unterdrück ein extra V-Kommando bei f0.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 


Return to Märklin CS2/CS3/MS2/CC-Schnitte (DE)