[setupfehler] Rückmelder Status Rocrail Start nicht gelesen.

Re: Rückmelder Status beim Rocrail Start nicht gelesen. Waru

Postby rjversluis » 14.05.2018, 07:34

Moin,

ist die Version richtig eingestellt?
http://wiki.rocrail.net/doku.php?id=cs2:cs2-de#version
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Rückmelder Status beim Rocrail Start nicht gelesen. Waru

Postby Johnjeanb » 14.05.2018, 09:12

Gut Morgen Alle

JeanClaude wrote:hast du die Option 'Steuerung/Betriebsbeginn/Rückmelder abfragen' schon probiert? Dies kannst du nach dem Start von Rocrail einmal probieren.Die CS2 muss natürlich zu diesem Zeitpunkt auch betriebsbereit sein. Wäre interessant zu wissen ob die Status-Übertragung sämtlicher Rückmelder in diesem Fall klappt.


Jean Claude Das ist eine gute Idee Ich kann nicht sofort testen aber wahrscheinlich das ist mein Problem.

[quote="rjversluis"]
ist die Version richtig eingestellt?
Rob, Ja meine Version ist auf 3 eingestellt.

Vielen Dank für alle Ideen und Hilfe
Viele Grüsse

Jean
Johnjeanb
 

Re: Rückmelder Status beim Rocrail Start nicht gelesen. Waru

Postby Johnjeanb » 17.05.2018, 10:31

locofile.xml
BeauSoleil 11-05-18 Clean.zip
rocview.ini
rocrail.ini
Gut Morgen Rocrail Freunde

Gestern habe Ich getestet die Funktion Steuerung/Betriebesbegin/Rückmelderabfragen. Bei meine Anlage sind die Rückmelder nicht gelesen. Nur Rückmelderanderungen sind nach Rocrail übergetragt.
Ich betreibe Windows 10 version 1709, Rocrail 64 Bits 2.0 -13741. Rocrail ist durch ein crossover Kabel Direkt mit die CS2 verbunden. Die CS2 ist mit die letzte Version 4.2.1 (0)
Beim hochfahren, zeigt die CS2 alle richtige Rückmelderzustände

Alle andere Funktionnen sind OK und die Anlage ist mit Auto und "Fishbowl" Moden betreibt.
Die Rocrail war für erweiterte Plankonsistenz geprüft und gereinigt durch "Bereiningung Inkonsistenter Einträge
Was kann Ich tun Bitte? Hilfe :D
Viele Güsse

Jean
You do not have the required permissions to view the files attached to this post.
Johnjeanb
 

Re: Rückmelder Status beim Rocrail Start nicht gelesen. Waru

Postby rjversluis » 17.05.2018, 10:44

Moin,

dein Problem ist gefüllt schon über 100 mal hier im Forum diskutiert worden; Gibt es bei diese viele Beiträge kein Abhilfe für diese wunderbare Zentrale?

Um hier testen zu können habe ich diese Pickel Firma schon ein paar mal gefragt für ein Testgerät, aber die scheinen Emails nicht zu lesen oder sind so unhöflich Email/Post nicht zu beantworten.
Eine bessere Alternative wäre der RedBox von Tams.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Rückmelder Status beim Rocrail Start nicht gelesen. Waru

Postby ups60 » 17.05.2018, 12:12

Hi Jean,

Du hattest bisher nicht dazu geschrieben, daß Du ein S88Link an der CS2 einsetzt.

Versuche mal zuerst Rocrail zu starten, danach die CS2. Dann abwarten bis die CS2 hochgefahren ist, ein bis 2 Min warten, ob dann die RM's angezeigt werden.

mfg Uwe
Für Hilfestellung nicht vergessen: http://wiki.rocrail.net/doku.php?id=issue-de
Märklin H0 K-Gleis, CS3 60226 (V1.3.2(1)), Windows 10, Ubuntu 16.04, GCA_PI01, GCA_PI02, GBM-Boost + GBM-16T
ups60
 

Re: Rückmelder Status beim Rocrail Start nicht gelesen. Waru

Postby Johnjeanb » 17.05.2018, 12:40

Hi Rob

Sorry aber Ich habe wirklich über dieses Problem im Forum und im Wiki gesucht und .gelesen und keine Lösung gefunden.
Bei meine Rocrail Konfiguration wenn Ich startet RR, sofort sind Rückmelder gefragt wenn die CS2 hochgefahren ist aber Gleis ist noch Stromlos

Im Zentrale Feld (Unten Rechts) zeigen alle Rückmelder:
Query on cdevice 0 sensors from 0 to 100 für version >=2
sensor 0:1 state=0
......................
sensor 0:99 state=0


So die Rückmelder sind gelesen aber alle sind -für RR- frei eben wenn für die CS2 einigen sind betsetzt.
Viele Grüsse

Jean
Johnjeanb
 

Re: Rückmelder Status beim Rocrail Start nicht gelesen. Waru

Postby woodyboy » 17.05.2018, 12:51

Wenn Sie einen s88link mit einer Bus 0-Abfrage verwenden, sieht das für mich seltsam aus.
Regards,

Bert

Equipment: Roco WLANMaus, MS2, Gleisbox 2x(separated switch & rollingstock). Ubuntu 16. Edits booster. Arduino: S88 CANbus interface & Ethernet-CANbus gateway
woodyboy
 

Re: Rückmelder Status beim Rocrail Start nicht gelesen. Waru

Postby Johnjeanb » 17.05.2018, 13:20

ups60 wrote:Hi Jean,

Du hattest bisher nicht dazu geschrieben, daß Du ein S88Link an der CS2 einsetzt.

Versuche mal zuerst Rocrail zu starten, danach die CS2. Dann abwarten bis die CS2 hochgefahren ist, ein bis 2 Min warten, ob dann die RM's angezeigt werden.

mfg Uwe

Hi Uwe
Ja meine Anlage ist mit
- "alte Mode" S 88 direkt am CS2 angeschlossen von Adresse 0:0 bis 0:91
- ein L88 (60883) mit Direkt RM 1:0 bis 1:16, Bus 3 (flach Kabel) Adresse 1:3000 bis 1:3024,
- ein S88 (60881) am Bus 1 der L 88 Adresse 1:1000 bis 1:1016
Es kann sein das Ich ein Problem mit Feld "Rückmelder-Geräte-Kennung" im Eigenschaften der Zentrale (CS2) habe.
Vielen Dank für deine Hilfe. Ich werde noch mal probieren am Wochenende
Viele Grüsse

Jean
Johnjeanb
 

Re: Rückmelder Status beim Rocrail Start nicht gelesen. Waru

Postby woodyboy » 17.05.2018, 16:24

Hallo Jean,

Du kannst es also mit mgbox versuchen stat MCS2. Die Konfiguration ist in prinzip gleich, aber bitte version 4 bei Rückmelder-Konfiguration fur S88Link support. http://wiki.rocrail.net/doku.php?id=cs2:gbox-de

Wenn es nicht klappt, bitte logfile hochladen met Info und Byte level.

http://wiki.rocrail.net/doku.php%3Fid%3Drocrailini-trace-de
In Developer-Trace-Ebene bitte nur Byte und Info Ebenen. In User-Trace-Ebene nur Monitor. Anzahl Trace Dataeien auf 1.
Ein kurzer Trace von Start mit einigen Sensor-Events genügt. CS2 soll schon bereit sein bei Rocrail start.
Regards,

Bert

Equipment: Roco WLANMaus, MS2, Gleisbox 2x(separated switch & rollingstock). Ubuntu 16. Edits booster. Arduino: S88 CANbus interface & Ethernet-CANbus gateway
woodyboy
 

Re: Rückmelder Status beim Rocrail Start nicht gelesen. Waru

Postby ups60 » 17.05.2018, 16:50

Hi Bert,

kannst Du auch in Bezug auf CS3 helfen?
Ich benutze die MGBOX- Lib, seitdem ich jetzt eine CS3 (60226) in Verbindung mit LinkS88 habe funktioniert die Statusanzeige in Rocrail auch nicht mehr. Ist aber nur ein kosmetisches Problem, sobald die Melder einmal ausgelöst haben werden sie auch angezeigt.
Ich bekomme die Rückmelder auch angezeigt, wenn ich die Apps der CS3 neu starte, bei Rocrail-Server Neustart werden die Melder erstmal wieder nicht angezeigt. Es sieht so aus, daß die CS3 (wahrsch. die CS2 in Verb. mit LinkS88) beim Systemstart eine interne Abfrage macht die Rocrail auch mitbekommt, aber beim Start von Rocrail bei laufender CS3 (CS2) nicht abgefragt wird.
MGBox ist konfiguriert auf Vers 4, Rückmelder-Anzahl 13, Geräte-Kennung 2 (stimmt mit der CS3 überein.)
Außerdem bekomme ich mit der CS3 auch keine Stats über V und A mehr angezeigt, nur mal ganz kurz beim Rocview-Start. Dann direkt alles wieder 0,0V 0,00A.
Welche Traces brauchst Du dazu und wie?

mfg Uwe
Für Hilfestellung nicht vergessen: http://wiki.rocrail.net/doku.php?id=issue-de
Märklin H0 K-Gleis, CS3 60226 (V1.3.2(1)), Windows 10, Ubuntu 16.04, GCA_PI01, GCA_PI02, GBM-Boost + GBM-16T
ups60
 

Re: Rückmelder Status beim Rocrail Start nicht gelesen. Waru

Postby woodyboy » 17.05.2018, 17:09

Hallo Uwe,

Genau die selbe trace, bis zum 30 seconden nach komplett Meldung im Server Fenster.

Aber keine Garantie und ohne Gewähr :wink:
Regards,

Bert

Equipment: Roco WLANMaus, MS2, Gleisbox 2x(separated switch & rollingstock). Ubuntu 16. Edits booster. Arduino: S88 CANbus interface & Ethernet-CANbus gateway
woodyboy
 

Re: Rückmelder Status beim Rocrail Start nicht gelesen. Waru

Postby ups60 » 17.05.2018, 17:27

Hi Bert,

hier zwei Traces, jeweils Rocrail neu gestartet. Bei ohne CS3 Neustart habe ich eine Lok mal manuell kurz gefahren, damit sie ein paar Rückmelder auslöst. Melder wurden nicht angezeigt.

Bei mit CS3 Neustart habe ich die CS3-Apps nach Rocrail-Start neu gestartet, keine Lokbewegungen. Nach ein paar Sekunden werden die RM's in Rocrail angezeigt.

Ist das so für Dich ausreichend?

mfg Uwe
You do not have the required permissions to view the files attached to this post.
Für Hilfestellung nicht vergessen: http://wiki.rocrail.net/doku.php?id=issue-de
Märklin H0 K-Gleis, CS3 60226 (V1.3.2(1)), Windows 10, Ubuntu 16.04, GCA_PI01, GCA_PI02, GBM-Boost + GBM-16T
ups60
 

Re: Rückmelder Status beim Rocrail Start nicht gelesen. Waru

Postby rjversluis » 17.05.2018, 18:29

Moin,

Haupt Problem ist die CS3 PC-Protokoll Doku; Gibt es nicht...
Wahrscheinlich bekommen nur die Kommerzielle Software Anbieter die geschickt.
Letzte öffentliche CS2 Doku stammt aus 2012.
Eigentlich sind die Endbenutzer von CS2/3 gefragt um sich bei Märklin zu beklagen; Ich bekomme kein Antwort.
Um jetzt alles mühsam zu re-engineeren finde ich nicht der richtige weg.
:roll: :roll: :roll:
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Rückmelder Status beim Rocrail Start nicht gelesen. Waru

Postby Johnjeanb » 17.05.2018, 21:07

woodyboy wrote:Hallo Jean,

Du kannst es also mit mgbox versuchen stat MCS2. Die Konfiguration ist in prinzip gleich, aber bitte version 4 bei Rückmelder-Konfiguration fur S88Link support. http://wiki.rocrail.net/doku.php?id=cs2:gbox-de

Wenn es nicht klappt, bitte logfile hochladen met Info und Byte level.

http://wiki.rocrail.net/doku.php%3Fid%3Drocrailini-trace-de
In Developer-Trace-Ebene bitte nur Byte und Info Ebenen. In User-Trace-Ebene nur Monitor. Anzahl Trace Dataeien auf 1.
Ein kurzer Trace von Start mit einigen Sensor-Events genügt. CS2 soll schon bereit sein bei Rocrail start.

Hallo Bert

Ich verstehe meine Anlage ist kompliziert so habe Ich versucht mit eine CS2 und der Demoplan (wenn man eine neue RR Installation mit heute 64bit Windows version). Auch damit kann Ich die Rückmelder lesen (Steuerung/betriebsbeginn/Rückmelder abfragen) aber wie auf meine Anlage sind alle Rückmelder frei eben wenn Ich, auf die CS2 eine Besetzung simuliere.

NOTA: Auf Wiki (http://wiki.rocrail.net/doku.php?id=rocgui-menu-de) es sagt das:
Rückmelder abfragen
Alle Rückmelder-Adressen werden abgefragt und im Gleisbild aktualisiert.
Unterstützte Zentralen:

CBUS
LocoNet
Xpressnet
BiDiB

So soll Ich verstehen das es keine möglichkeit gibt (um Rückmelder zu abfragen)?

Ich habe auch die Zentrale (CS2-->mgbox) erstezt mit Version Feld auf 4 (anstatt3) aber die Rückmelder Zustande im CS2 sind nicht übertragen
Ich weiss nicht was tun.
Viele Grüsse

Jean
Johnjeanb
 

Re: Rückmelder Status beim Rocrail Start nicht gelesen. Waru

Postby ups60 » 17.05.2018, 21:22

Hi Jean,

ich habe nochmal in Deinen Plan geschaut. Du hast im Feld "Rückmelder" eine 0 (null) eingetragen, dort gehört die Anzahl der Rückmeldemodule hinein.
In das Feld "Rückmleder-Geräte-Kennung" gehört die Nummer rein, die in der CS2 für das L88 als Gerät definiert ist. (Ist jetzt von meiner CS3, sollte bei der CS2 ähnlich sein)

Links88.png


Außerdem muß die Anzahl der Module in der CS2 konfiguriert sein.

Links88-2.png


mfg Uwe
You do not have the required permissions to view the files attached to this post.
Für Hilfestellung nicht vergessen: http://wiki.rocrail.net/doku.php?id=issue-de
Märklin H0 K-Gleis, CS3 60226 (V1.3.2(1)), Windows 10, Ubuntu 16.04, GCA_PI01, GCA_PI02, GBM-Boost + GBM-16T
ups60
 

PreviousNext

Return to Märklin CS2/CS3/MS2/CC-Schnitte (DE)