CS2: Rückmelder werden beim Start nicht angezeigt

Re: CS2: Rückmelder werden beim Start nicht angezeigt

Postby Zikro » 19.05.2017, 15:26

Hallo Rocrailer,

Beim Link88 ist das Wort BUS vllt. etwas widersprüchlich gewählt. Der Link88 wird über den Märklin CAN Bus angeschlossen und hat 3 Anschlüsse sowie 16 integrierte rückmelder. In der CS2 wie auch der CS3 hat der Link88 eine sogenannte Geräte-Kennung (bei mir die " 1 ") Die Gerätekennung schreibe ich bei den Rückmeldern vorne bei Bus rein also in meinem Fall Bus 1. So nun zu den Rückmeldern. Die 16 integrierten Rückmelder im Link88 haben die Adresse 1-16 in meinem Fall also 1:1 bis 1:16. zudem kann man 2mal S88N an den Anschlüssen mit den Namen BUS1 und BUS 2 und einmal normale S88 an BUS3 anschließen. Diese hören auf die Adressen z.B. Angeschlossen an den Anschluss BUS1 der erste Rückmelder: 1:1001, an BUS2 1:2001 und an BUS3 1:3001. Ich habe mal versucht im Byte-Trace das einzufangen und euch zur verfügung zu stellen. Am start ruft die CS2 aktuell die rückmelder von der CS2 ab da bei mir hier aber garkeine angeschlossen sind da der Link88 schneller präziser dank S88N und 12V ist. wäre schön wenn man die Abfrage machen könnte ohne die CS2 abzufragen. Zur zeit helfe ich mir Indem ich beim Start die Stromspannung einmal aus und wieder einschalte dann läuft alles wunderbar. Empfinde ich aber auch nicht schlimm :)

Gruß aus Franken Sven

Edit:
Da bin ich dir wohl etwas zuvor gekommen hoedtie (wir reden uns hier normale mit vornamen an) :)

in seinem Fall wäre es übrigens z.B. bei Gerätekennung 19: 19:1001 oder 19:2057 ;)
You do not have the required permissions to view the files attached to this post.
[ - Märklin CS2 - ] = [ - Märklin S88DC über S88Link - ] = [ - Windows 10 - Ubuntu 16.04 - ] = [ - Spur N - DCC - ] = [ - RasberryPI 2B - ]
Zikro
 

Re: CS2: Rückmelder werden beim Start nicht angezeigt

Postby woodyboy » 19.05.2017, 18:59

Hallo Sven,

Dank für das Trace, das Byte-trace ist ok. Ich werde versuchen, ein Update für diese in der mgbox Bibliothek zu erstellen. Leider bin ich nicht so schnell wie Rob :shock: .
Regards,

Bert

Equipment: Edits booster, Gleisbox, Arduino Ethernet-CANbus gateway, MS2, Edits S88 with Arduino CANbus controller emulating CS2 event feedback. Switches: 2nd Gleisbox. Roco WLANMaus. RocRail (Ubuntu) mostly M-stock.
woodyboy
 

Re: CS2: Rückmelder werden beim Start nicht angezeigt

Postby Zikro » 19.05.2017, 19:38

Hallo Bert,

Keiner ist so schnell wie Rob ;)

Wenn du noch irgendwas brauchst oder ich etwas testen kann sag Bescheid!

Gruß Sven
[ - Märklin CS2 - ] = [ - Märklin S88DC über S88Link - ] = [ - Windows 10 - Ubuntu 16.04 - ] = [ - Spur N - DCC - ] = [ - RasberryPI 2B - ]
Zikro
 

Re: CS2: Rückmelder werden beim Start nicht angezeigt

Postby woodyboy » 23.05.2017, 18:26

Hallo Link S88 besitzer,

Von morgen an, Rückmeldung beim Start Rocrail mit dem Link S88 Einheiten und angeschlossenen S88 Einheiten konnte getestet worden. Combination von CS2 Rückmeldern und Link S88 ist möglich. Die Link-S88-Methode ist im MGBOX-Controller enthalten. MGBOX verwendet dieselben Einstellungen im Dialog wie der MCS2-Controller. Um das Link S88-Verfahren korrekt zu konfigurieren, füllen Sie das Rückmelder-Feld die Anzahl der 16 Kontakteinheiten in der längsten angehängten Kette aus. Wenn nur ein Link S88 angeschlossen ist, füllen Sie das Feld mit 1. Wenn einer der Busse z.B. 5 Einheiten angeschlossen hat und eine andere hat 2 Einheiten, füllen Sie bitte 5 im Rückmelder feld. Die Version muss auf 4 eingestellt sein.

Leider habe ich keine Link S88 zur verfügung. Implementierung ist laut Protokolldokument. Im Falle eines Fehlers bitte eine komplette Byte-Level-Trace der ersten 30 Sekunden hochladen nach start Rocrail.
Regards,

Bert

Equipment: Edits booster, Gleisbox, Arduino Ethernet-CANbus gateway, MS2, Edits S88 with Arduino CANbus controller emulating CS2 event feedback. Switches: 2nd Gleisbox. Roco WLANMaus. RocRail (Ubuntu) mostly M-stock.
woodyboy
 

Re: CS2: Rückmelder werden beim Start nicht angezeigt

Postby Zikro » 23.05.2017, 20:33

Hey Bert,

Ich bin bis Sonntag in der Schweiz dann kann ich gerne testen.

Gruß Sven
[ - Märklin CS2 - ] = [ - Märklin S88DC über S88Link - ] = [ - Windows 10 - Ubuntu 16.04 - ] = [ - Spur N - DCC - ] = [ - RasberryPI 2B - ]
Zikro
 

Re: CS2: Rückmelder werden beim Start nicht angezeigt

Postby BR 45 » 29.05.2017, 09:30

Das hört sich super an.

2 Fragen habe ich dann noch:
1. Woodyboy schreibt sinngemäß: nur der Link dann 1 eintragen. Wenn 5 Einheiten als längste Kette dann die 5. Warum dann nicht die 6 - entsprechend Link =1, plus 5 Einheiten =6.
2. funktioniert das mit MSC2 genauso?

Danke
Matthias
Märklin CS2 - LinkS88(15) - Win10PC
BR 45
 

Re: CS2: Rückmelder werden beim Start nicht angezeigt

Postby Zikro » 29.05.2017, 10:01

Hallo Matthias,

nein bisher ist das nur für mgbox da die von bert entwickelt wurde. Allerdings habe ich gestern abend kurz getestet und dort hat es bei mir leider auch nicht funktioniert. ich werde heute Abend nochmal testen und dann auch wieder traces online stellen.

gruß Sven
[ - Märklin CS2 - ] = [ - Märklin S88DC über S88Link - ] = [ - Windows 10 - Ubuntu 16.04 - ] = [ - Spur N - DCC - ] = [ - RasberryPI 2B - ]
Zikro
 

Re: CS2: Rückmelder werden beim Start nicht angezeigt

Postby woodyboy » 29.05.2017, 11:32

BR 45 wrote:1. Woodyboy schreibt sinngemäß: nur der Link dann 1 eintragen. Wenn 5 Einheiten als längste Kette dann die 5. Warum dann nicht die 6 - entsprechend Link =1, plus 5 Einheiten =6.


Wenn ein Link erkannt wird, dann ist die Kettenlänge des längsten Busses wichtig. Der Link selbst ist nicht Teil eines Busses.


Bitte machen Sie zwei separate Byte level Traces. Zuerst mit einer gestarteten CS2 / Link Konfiguration und nach einem kompletten Start des CS2 Start Rocrail.
Zweite. Starten Sie Rocrail und nachdem Rocrail läuft, schalten Sie den CS2 ein.
Letzteres soll den CS2 / Link-Dialog anhören.

Es ist in beiden Fällen wichtig, ein komplettes Protokoll von der Inbetriebnahme bis zur S88-Nachricht zu fangen.
Regards,

Bert

Equipment: Edits booster, Gleisbox, Arduino Ethernet-CANbus gateway, MS2, Edits S88 with Arduino CANbus controller emulating CS2 event feedback. Switches: 2nd Gleisbox. Roco WLANMaus. RocRail (Ubuntu) mostly M-stock.
woodyboy
 

Re: CS2: Rückmelder werden beim Start nicht angezeigt

Postby Zikro » 02.06.2017, 08:23

Hallo Bert,

bin heute erst wieder an die Anlage gekommen das Wetter war einfach zu gut um im Keller zu sitzen ;)

Wenn ich erst Rocrail starte und dann die CS2 funktioniert die Verbindung bei mir nicht! Ich bekomme keine Verbindung zur CS2.

gruß Sven
You do not have the required permissions to view the files attached to this post.
[ - Märklin CS2 - ] = [ - Märklin S88DC über S88Link - ] = [ - Windows 10 - Ubuntu 16.04 - ] = [ - Spur N - DCC - ] = [ - RasberryPI 2B - ]
Zikro
 

Re: CS2: Rückmelder werden beim Start nicht angezeigt

Postby woodyboy » 02.06.2017, 20:30

Hallo Sven,

Mit Pfingsten bin ich in Schleswig-Holstein. Nächtste Woche schaue ich mij dieTraces an.
Regards,

Bert

Equipment: Edits booster, Gleisbox, Arduino Ethernet-CANbus gateway, MS2, Edits S88 with Arduino CANbus controller emulating CS2 event feedback. Switches: 2nd Gleisbox. Roco WLANMaus. RocRail (Ubuntu) mostly M-stock.
woodyboy
 

Re: CS2: Rückmelder werden beim Start nicht angezeigt

Postby woodyboy » 02.06.2017, 22:42

Hallo Sven,

Diese Traces haben nur Byte level. Bitte Byte und Info Ebenen. Anzahl Trace Dataeien auf 1.
Regards,

Bert

Equipment: Edits booster, Gleisbox, Arduino Ethernet-CANbus gateway, MS2, Edits S88 with Arduino CANbus controller emulating CS2 event feedback. Switches: 2nd Gleisbox. Roco WLANMaus. RocRail (Ubuntu) mostly M-stock.
woodyboy
 

Re: CS2: Rückmelder werden beim Start nicht angezeigt

Postby Zikro » 06.06.2017, 14:21

Hi Bert,

ich hab ein Problem die Info so zu fangen! Wenn ich MGBOX als Zentrale nutze laufen bei mir ständig Meldungen über den Server und der Trace ist schneller voll als ich auch nur eine Rückmeldung fangen kann! Allerdings nur wenn die CS2 zuerst gestartet ist. Wenn ich zuerst rocrail starte bleiben die Meldungen ruhig und laufen nicht wild über den Bildschirm. Allerdings zeigt er mir damit unten beim Strom nur 10V und 0A an. Rückmelder werden aber nicht als Belegt erkannt. Erst nach einmal STOP-Taste dann geht es wie gewohnt.

Hoffe diesmal ist alles zu sehen im Trace.

Gruß Sven
You do not have the required permissions to view the files attached to this post.
[ - Märklin CS2 - ] = [ - Märklin S88DC über S88Link - ] = [ - Windows 10 - Ubuntu 16.04 - ] = [ - Spur N - DCC - ] = [ - RasberryPI 2B - ]
Zikro
 

Re: CS2: Rückmelder werden beim Start nicht angezeigt

Postby smitt48 » 06.06.2017, 14:58

Hi Sven,

Du kannst in Rocrail Eigenschaften - Trace die Anzahl Trace-Dateien auf eins setzen. Dann solltest du genug Melder Ereignisse behalten.

mfg Tom
Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.1.4) - WinXP as server, 10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 

Re: CS2: Rückmelder werden beim Start nicht angezeigt

Postby woodyboy » 06.06.2017, 16:02

Hallo Sven,

Diese Traces sehen ok aus. Ist der Link S88 mit dem Geräte Kenner Nummer 1 im CS2 konfiguriert?
Wenn 1 der definierte Geräte kenner ist, dann sehe ich wohl eine Lösung.
Ich werde die Werte für Spannung und Strom verbessern. Es scheint, dass die LinkS88 Antwortet :shock: auf diese Anfragen.
Regards,

Bert

Equipment: Edits booster, Gleisbox, Arduino Ethernet-CANbus gateway, MS2, Edits S88 with Arduino CANbus controller emulating CS2 event feedback. Switches: 2nd Gleisbox. Roco WLANMaus. RocRail (Ubuntu) mostly M-stock.
woodyboy
 

Re: CS2: Rückmelder werden beim Start nicht angezeigt

Postby Zikro » 06.06.2017, 19:18

Hi Bert,

Ja der Link 88 hat die Kennung 1

Gruß Sven
[ - Märklin CS2 - ] = [ - Märklin S88DC über S88Link - ] = [ - Windows 10 - Ubuntu 16.04 - ] = [ - Spur N - DCC - ] = [ - RasberryPI 2B - ]
Zikro
 

PreviousNext

Return to S88