(erl.)Problem beim Installieren

(erl.)Problem beim Installieren

Postby CBGlobetrotter » 12.05.2018, 20:52

Hallo zusammen,
Ich habe da ein kleines Problem.
Als Mechaniker findet man die Fehler eigentlich immer, sprich wo es klemmt ist der Fehler.
Nun habe ich mich durch dieses Forum verleiten lassen zum Raspberry und Arduino im Selbstversuch.
OHNE Kentnisse in Programmierung, Linux etc. ..... war wohl ein Fehler. :?

Nein ich Lese, versuche und schau wie weit ich komme.
Aber.... nun scheitere ich schon bei der Installation von RocRail auf einem Jungfreulichem Raspberry 3.
Laut gut Dokumentierter Anleitung vorgegangen http://wiki.rocrail.net/doku.php?id=use ... 3-de-short

Leider kommt bei der Paketinstallation folgende Meldung:

Instalation der Datei fehlgeschlagen
Es konnte kein Paket gefunden werden, das es erlaubt diesen Vorgang abzuschließen.
Weitere Informationen finden Sie im detaillierten Bericht.


Raspbian GNU/Linux 9 (stretch)
VERSION="9 (stretch)"
RocRail Version Aktuell 13962

Wo ist der Wurm drinn, versuche seit nun 7 Stunden nach dem Fehler. Finde auch diesen dedaillierten Bericht nicht.
Lese, Probiere und entäusche mich.

Vielleicht sollte ich doch bei der Mechanik bleiben, zumal mein Testaufbau mit dem PC ja funktioniert.

Gruß Jörg
Last edited by CBGlobetrotter on 15.05.2018, 15:19, edited 2 times in total.
Bedenke, das Licht am Ende des Tunnels, könnte auch ein Zug sein.

Windows10, DR5000 mit Z21-Loconet, Spur N Peco Code 55
CBGlobetrotter
 

Re: Problem beim Installieren

Postby ups60 » 12.05.2018, 21:00

Hi Jörg,

versuch zunächst mal in einer Console ein "sudo apt install -f", fehlende Programmteile (fehlende Abhängigkeiten) sollten dann nachinstalliert werden.

mfg Uwe
Für Hilfestellung nicht vergessen: http://wiki.rocrail.net/doku.php?id=issue-de
Märklin H0 K-Gleis, CS3 60226 (V1.3.2(1)), Windows 10, Ubuntu 16.04, GCA_PI01, GCA_PI02, GBM-Boost + GBM-16T
ups60
 

Re: Problem beim Installieren

Postby CBGlobetrotter » 12.05.2018, 21:07

Hallo Uwe,
hab ich auch schon probiert ohne Erfolg, Aktuell eben nochmals gemacht gibt folgendes zurück:

Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 1 nicht aktualisiert.

Gruß Jörg
Bedenke, das Licht am Ende des Tunnels, könnte auch ein Zug sein.

Windows10, DR5000 mit Z21-Loconet, Spur N Peco Code 55
CBGlobetrotter
 

Re: Problem beim Installieren

Postby ups60 » 12.05.2018, 21:09

Hi,

dan versuch jetzt noch ein "sudo apt dist-upgrade"

mfg Uwe
Für Hilfestellung nicht vergessen: http://wiki.rocrail.net/doku.php?id=issue-de
Märklin H0 K-Gleis, CS3 60226 (V1.3.2(1)), Windows 10, Ubuntu 16.04, GCA_PI01, GCA_PI02, GBM-Boost + GBM-16T
ups60
 

Re: Problem beim Installieren

Postby CBGlobetrotter » 12.05.2018, 21:10

Hallo Uwe

Hier das gleiche:

Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

Gruß Jörg
Bedenke, das Licht am Ende des Tunnels, könnte auch ein Zug sein.

Windows10, DR5000 mit Z21-Loconet, Spur N Peco Code 55
CBGlobetrotter
 

Re: Problem beim Installieren

Postby CBGlobetrotter » 12.05.2018, 22:55

Hallo Uwe

Danke für deine mühen.

Es soll nicht sein, also bleibe ich bei der Mechanik.

Hab das Ding nun wieder in seine Verpackung verbannt.
Vielleicht werde ich mich mal irgendwann wieder damit befassen. Ich brauch das Ding ja nicht wirklich.

Wollte ihnn eh nur zum Testen nutzen, in Verbindung RFID welches meine Tags die Zwar unter die Wagen passen aber nicht ausgelesen werden ausser bei direkter Auflage.

Gruß Jörg
Bedenke, das Licht am Ende des Tunnels, könnte auch ein Zug sein.

Windows10, DR5000 mit Z21-Loconet, Spur N Peco Code 55
CBGlobetrotter
 

Re: (beendet)Problem beim Installieren

Postby CBGlobetrotter » 13.05.2018, 19:18

Hallo zusammen

Habe heute nochmals alles versucht, leider ohne Erfolg.
Allerdings lässt sich auf dieses Ding gar nix installieren habe ich dabei festgestellt.

Gruß Jörg
Bedenke, das Licht am Ende des Tunnels, könnte auch ein Zug sein.

Windows10, DR5000 mit Z21-Loconet, Spur N Peco Code 55
CBGlobetrotter
 

Re: (beendet)Problem beim Installieren

Postby Pirat-Kapitan » 13.05.2018, 19:33

Moin Jörg,
da Du versucht hast, nach meiner Anleitung vorzugehen, interessiert mich natürlich etwas genauer, wo Du nun das Problem hast.
Welche Schritte meiner Anleitung bei der Erstinstallation von Rocrail haben noch geklappt bzw. wo bist Du hängengeblieben? "Paketinstallation" ist ein mehrschrittiger Begriff.
Du kannst mich auch gerne direkt anmorsen, ich kann Dir auch eine SD-Karte zum Ausprobieren bespielen.

Schöne Grüße
Johannes
Clearasilfahrer auf Spur G&H0m, Lenz LZV (3.6), ORD-20, Manhart-Funki und WLM, RS-Bus Rückmelder (Reedkontakte/GBM),
Rocrail auf RasPi mit mobilen Geräten (andRoc). Details auf http://wiki.rocrail.net/doku.php?id=use ... at-kapitan.
Pirat-Kapitan
 

Re: (beendet)Problem beim Installieren

Postby CBGlobetrotter » 13.05.2018, 20:06

Hallo Johannes
An deiner Anleitung liegt es nicht, es wird ja öfter auf diese verwiesen in verschiedenen Foren und bei denen fuktioniert alles.
Es haben alle Schritte funktioniert bis zur Paketinstallation.
Statt der Abfrage für das Passwort kommt die oben genannte Fehlermeldung.

Hatte mir das Ding zum Vatertag gekauft, zum Experimentieren mit RocRail oder als Jukebox.
Auch hier lässt sich Volumio, Fruitbox und Co. nicht installieren.

Bin gerade dabei die SD Karte die Vorkonfiguriert im Lieferumpfang war zu Formatieren.
Ob ich sie als Speichermedium für das Handy nutze oder in einem schwachen Moment nochmals im Raspi, weiß ich noch nicht.

Aber 3 Tage probieren und nur Frust, da leg ich das Ding lieber auf Eis.
Mal schauen im Winter....

Danke für dein Angebot, aber ich bin jetzt vorerst bedient von dem Ding.

Gruß Jörg
Bedenke, das Licht am Ende des Tunnels, könnte auch ein Zug sein.

Windows10, DR5000 mit Z21-Loconet, Spur N Peco Code 55
CBGlobetrotter
 

Re: (beendet)Problem beim Installieren

Postby Pirat-Kapitan » 13.05.2018, 21:22

CBGlobetrotter wrote:Bin gerade dabei die SD Karte die Vorkonfiguriert im Lieferumpfang war zu Formatieren.

Moin,
ich nehme nie die vorformatierten SD-karten sondern spiele mir das Betriebssystem-Image immer selbst auf.
ich würde Dich bitten, noch einen Versuch zu machen:
das Image wie in der Anleitung (Punkt 1) beschrieben aufspielen und dann der Anleitung folgen.

Wenn es dann wieder an der Stelle Passworteingabe zur Fehlermeldung kommt, teste ich das mit der aktuellen Betriebssystemversion auch mal bei mir.

Schöne Grüße
johannes
Clearasilfahrer auf Spur G&H0m, Lenz LZV (3.6), ORD-20, Manhart-Funki und WLM, RS-Bus Rückmelder (Reedkontakte/GBM),
Rocrail auf RasPi mit mobilen Geräten (andRoc). Details auf http://wiki.rocrail.net/doku.php?id=use ... at-kapitan.
Pirat-Kapitan
 

Re: (beendet)Problem beim Installieren

Postby CBGlobetrotter » 13.05.2018, 21:31

Hallo Johannes

Werde ich morgen mal Versuchen.
Heute nicht mehr a) zu genervt und b) um 4:30 Uhr geht der Wecker.

Gruß Jörg
Bedenke, das Licht am Ende des Tunnels, könnte auch ein Zug sein.

Windows10, DR5000 mit Z21-Loconet, Spur N Peco Code 55
CBGlobetrotter
 

Re: (beendet)Problem beim Installieren

Postby CBGlobetrotter » 14.05.2018, 23:30

Hallo Johannes
Hier mal die Rückmeldung...
Nach mehrfachem installieren von Rasbian strech ist es mir gelungen RocRail zu installieren. :thumb_up:
Beflügelt hiervon versuchte ich mich, mit einer gesonderten Karte und der Lite Version, die Fruitbox zu installieren.
Und da sind meine schwächen offensichtlich...
Keine Ahnung von Linux und kein Englisch.
Eine Kombination die zum scheitern verurteilt ist.

Also ist der Raspi für mich nichts. Kommt in die Rundablage(Tonne).

Gruß Jörg
Bedenke, das Licht am Ende des Tunnels, könnte auch ein Zug sein.

Windows10, DR5000 mit Z21-Loconet, Spur N Peco Code 55
CBGlobetrotter
 

Re: (beendet)Problem beim Installieren

Postby rjversluis » 15.05.2018, 07:01

Moin Jörg,
CBGlobetrotter wrote:Also ist der Raspi für mich nichts. Kommt in die Rundablage(Tonne).

ich würde es in ein gepolsterte Umschlag an Johannes schicken.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: (erl.)Problem beim Installieren

Postby CBGlobetrotter » 15.05.2018, 15:43

Hallo zusammen,

Hab mal den Titel geändert in erledigt, passt besser.
Im nachgang lag wohl das Problem an der vorkonfigurierten Karte, diese hab ich Formatiert und neu aufgesetzt, dies brachte den Erfolg das Rocrail nun läuft.
Wenn ich den Server starte, das sehe ich zwar nicht?? Aber bei Rocwiew sehe ich das er gestartet ist.
Somit ist der Post erledigt. Weil Funktioniert.

Das andere Problem betrifft nicht Rocrail, hat bei mir aber gestern doch zu erheblichen Frust gesorgt, in verbindung mit den Problemen der letzten Tage, man kann es ja lesen :cry:
Natürlich wird der Raspi nicht Illegal entsorgt oder zum elektroschrott gebracht. Der kann nix für.... :mrgreen:

Der Raspi und ich haben heute morgen nach nur 3 Stunden Schlaf :? , beschlossen nur auf der Spätschicht zusammen zu Basteln.
Anders kann ich mein wirken zur Zeit nicht besser beschreiben.

Sollten wir dann doch nicht zusammen finden, wird der ein oder andere, unerwartet Post bekommen :D

Gruß Jörg
Bedenke, das Licht am Ende des Tunnels, könnte auch ein Zug sein.

Windows10, DR5000 mit Z21-Loconet, Spur N Peco Code 55
CBGlobetrotter
 

Re: (erl.)Problem beim Installieren

Postby Pirat-Kapitan » 15.05.2018, 19:32

Moin Jörg,
wenn Du nach meiner Anleitung vorgehst, siehst Du nur die Rocview-Oberfläche, der Server wird durch den Aufruf des Arbeitsbereiches gestartet. Dass der Server läuft, siehst Du z.B. daran, dass Rocview mit "localhost" verbunden ist. Ohne Verbindung zum Server steht dort "offline".

Schöne Grüße
johannes
Clearasilfahrer auf Spur G&H0m, Lenz LZV (3.6), ORD-20, Manhart-Funki und WLM, RS-Bus Rückmelder (Reedkontakte/GBM),
Rocrail auf RasPi mit mobilen Geräten (andRoc). Details auf http://wiki.rocrail.net/doku.php?id=use ... at-kapitan.
Pirat-Kapitan
 


Return to Raspberry Pi (DE)