Abgebrochen. Probleme mit Aktionen Ext-Programm

Re: Probleme mit Aktionen Ext-Programm

Postby dgeffe » 16.02.2017, 19:35

Hi Gerd

Code: Select all
20170216.183056.667 r9999I tid0x767 OSystem  0334 system = "cvlc" --play-and-exit /home/pi/rocrail/sound/Erfurt/abfahren/erfurtG1.flac


Sieht nicht so aus als ob ich mich vertippt habe.
Das liegt bestimmt an den vielen Äderungen in Jessie die gesamte Struktur wurde geändert.

Gruß Dirk
[ Windows 10 ] [Raspberry 2 als Server ][GBMBoost] [2x GBM16T] [ Digikeijs DR4088xx, DR4018, DR4024 ] [ Qdecoder ]
dgeffe
 

Re: Probleme mit Aktionen Ext-Programm

Postby GeSchu » 16.02.2017, 19:46

Moin Dirk,
dgeffe wrote:Hi Gerd

Code: Select all
20170216.183056.667 r9999I tid0x767 OSystem  0334 system = "cvlc" --play-and-exit /home/pi/rocrail/sound/Erfurt/abfahren/erfurtG1.flac


Sieht nicht so aus als ob ich mich vertippt habe.
Das liegt bestimmt an den vielen Äderungen in Jessie die gesamte Struktur wurde geändert.

Gruß Dirk

Wenn es per Direktaufruf funktioniert, kann es nicht am System liegen, oder?
Also, ich bitte um die trc , plan und ini Files. Sprich . Baue einen Problemfall.
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian jessie; Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Probleme mit Aktionen Ext-Programm

Postby GeSchu » 16.02.2017, 20:48

Moin Dirk,
es liegt am VLC. Ändere mal bitte den Befehl in der aktion von cvlc auf nvlc um. Gerade auf meinem Raspi getestet. Geht einwandfrei

PS.: Obwohl: mit cvlc geht das auch einwandfrei.
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian jessie; Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Probleme mit Aktionen Ext-Programm

Postby dgeffe » 17.02.2017, 07:37

hi Gerd


nvlc geht zwar in einem terminal aber nicht auf der Kommando Zeile.

Da aber beides bei mir nicht funktioniert ( ich habe jessie auf meinem Raspi.)
Eröffne ich einen Problemfall .

Gruß und Danke Dirk
You do not have the required permissions to view the files attached to this post.
[ Windows 10 ] [Raspberry 2 als Server ][GBMBoost] [2x GBM16T] [ Digikeijs DR4088xx, DR4018, DR4024 ] [ Qdecoder ]
dgeffe
 

Re: Probleme mit Aktionen Ext-Programm

Postby GeSchu » 17.02.2017, 14:09

Moin Dirk,
moin zusammen,
ich habe das eigenartige Verhalten des VLC auf Dirk seinem Raspi mit debian jessie finden können. Allerdings habe ich noch keine Lösung. Der VLC kann und darf nicht als root ausgeführt werden. Wenn also rocrail wie gewöhnlich als Daemon beim Systemstart mit root Rechten gestartet wird, dann wird der VLC als rocrail Aktion nie starten.
Okay, machen wir einen Test:
Dirk, stoppe bitte auf dem Raspi den rocrailserver
Code: Select all
 sudo service rocraild stop
Geht das bei jessie überhaupt so?
Es müsste die Meldung "shuting down rocrail" kommen.
Jetzt startest Du rocrail mit der folgenden Zeile neu:
Code: Select all
 /opt/rocrail/rocrail.sh -w /home/pi/rocrail

Deine Konsole (shell) ist jetzt gesperrt. Macht nix.
Verbinde jetzt deinen rocview Client wie gewohnt mit dem rocrail server.
Schalte einmal strom, um zu sehen, obs geklappt hat.
Spiele einen Sound ab und berichte ....
Dann sehen wir weiter.
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian jessie; Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Probleme mit Aktionen Ext-Programm

Postby dgeffe » 17.02.2017, 15:29

Hi Gerd


cvlc not found , Über meine sh funktioniert es :roll:

Wo habe ich da die schraube falsch angesetzt. obwohl ich glaube das Jessie da seine Bytes im spiel hat.

Gruß Dirk
[ Windows 10 ] [Raspberry 2 als Server ][GBMBoost] [2x GBM16T] [ Digikeijs DR4088xx, DR4018, DR4024 ] [ Qdecoder ]
dgeffe
 

Re: Probleme mit Aktionen Ext-Programm

Postby GeSchu » 17.02.2017, 16:04

Moin Dirk,
dgeffe wrote:
cvlc not found ,

Wo genau steht steht diese Meldung?
........ das Jessie da seine Bytes im spiel hat. .........

Halte ich für sehr sehr unwahrscheinlich.
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian jessie; Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Probleme mit Aktionen Ext-Programm

Postby dgeffe » 17.02.2017, 16:09

Hi Gerd

Es steht im serverfenster.

Gruß Dirk
[ Windows 10 ] [Raspberry 2 als Server ][GBMBoost] [2x GBM16T] [ Digikeijs DR4088xx, DR4018, DR4024 ] [ Qdecoder ]
dgeffe
 

Re: Probleme mit Aktionen Ext-Programm

Postby GeSchu » 17.02.2017, 16:41

Moin zusammen,
dgeffe wrote:Hi Gerd

Es steht im serverfenster.

Gruß Dirk

frage an die LINUX bewanderten Mitleser: Auf meinem Raspi funktioniert das Ganze einwandfrei. Vorrausgesetzt, ich starte den rocrailserver als user (pi). Der startet eh ohne rootrechte durch einen Eintrag in der rc.local. Bei bedarf poste ich den String hier.
Ich weiß im Augenblick nicht, woran es auf Dirk seinem Raspi hapert. Wieso wird der cvlc von rocrail aus nicht gefunden? Kann bitte mal jemand per Aktion den cvlc starten und kurz mitteilen, was passiert?
Ach ja: Ich starte den cvlc ohne Script, wie weiter oben beschrieben. Halte ich in diesem Fall auch für nicht nötig.
Danke
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian jessie; Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Probleme mit Aktionen Ext-Programm

Postby GeSchu » 17.02.2017, 17:33

Moin Dirk,
schicke mir mal bitte den Trace, der zu dem Zeitpunkt entsteht, wenn die Meldung "cvlc not found" entsteht.
Danke
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian jessie; Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Probleme mit Aktionen Ext-Programm

Postby rjversluis » 17.02.2017, 19:35

root und user haben unterschiedliche Pfaden.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Probleme mit Aktionen Ext-Programm

Postby dgeffe » 17.02.2017, 19:53

Hi Gerd


Anbei das trace.

( Es ist ein orginal Jessie.img. )

Gruß Dirk
You do not have the required permissions to view the files attached to this post.
[ Windows 10 ] [Raspberry 2 als Server ][GBMBoost] [2x GBM16T] [ Digikeijs DR4088xx, DR4018, DR4024 ] [ Qdecoder ]
dgeffe
 

Re: Probleme mit Aktionen Ext-Programm

Postby GeSchu » 17.02.2017, 20:05

Moin Rob,
rjversluis wrote:root und user haben unterschiedliche Pfaden.

ich weis, nur verstehe ich das in Verbindung mit dem VLC nicht, was du meinst?
Gruß
Gerd(Geschu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian jessie; Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Probleme mit Aktionen Ext-Programm

Postby GeSchu » 17.02.2017, 20:11

Moin Dirk,
dgeffe wrote:Hi Gerd
Anbei das trace.

Ja, und jetzt verstehe ich erstmal gar nichts mehr, weil: Im trace steht nichts von "cvlc not found". Weder wenn er durch Dein Script, noch wenn er direkt aufgerufen wird.
Hmmmm ..........
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian jessie; Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Probleme mit Aktionen Ext-Programm

Postby dgeffe » 17.02.2017, 20:28

Hi Gerd

Das habe ich im rr-termial gesehen . Nicht alles steht immer im trace :!:
Mit dem Script funktioniert es ohne Meldung .
Ohne Script mit Fehler und kein Sound

Sorry .

Gruß Dirk
[ Windows 10 ] [Raspberry 2 als Server ][GBMBoost] [2x GBM16T] [ Digikeijs DR4088xx, DR4018, DR4024 ] [ Qdecoder ]
dgeffe
 

PreviousNext

Return to Raspberry Pi (DE)