Verzögerung beim Schalten von Weichen Topic is solved

Post Reply
rainynight65
Posts: 15
Joined: 16.05.2018, 22:45
Location: QLD, AU

Verzögerung beim Schalten von Weichen

Post by rainynight65 » 05.02.2019, 12:14

Guten Tag,

ich betreibe RocRail an einer DR5000. Meine Anlage befindet sich noch im Aufbau, und vor kurzem habe ich angefangen, Weichenantriebe einzubauen und in RR einzubinden.

Im Zuge dessen habe ich beim Schalten von Weichen unter bestimmten Umständen deutliche Verzögerungen bemerkt: zwischen dem Erteilen des Befehls in RR, und dem tatsächlichen Schalten der Weiche vergehen ca. 3 Sekunden.

Dies passiert bei mir mit der DR5000 und RR sowohl im LocoNet-Betrieb (Locobuffer/USB und LNTCP), als auch im Z21-Betrieb über's LAN.

Bei den fraglichen Weichenantrieben handelt es sich um den DCCConcepts Cobalt IP Digital mit eingebautem DCC-Decoder. Ich habe auch einen Cobalt SS mit externem Decoder verbaut, der hat das Problem nicht.

Ich beobachte dieses Verhalten nicht, wenn die Zentrale via XPressNet angesteuert wird (USB oder LAN).

Ich sehe diese Verzögerungen ebenfalls nicht, wenn die Weichen mit der DR5000-Software geschaltet werden. Auch mit einigen anderen Produkten sehe ich keine Verzögerungen, wobei ich die folgenden Kombinationen getestet habe:

DR5000 als Z21 mit der Z21 iPhone app
DR5000 als Z21 mit iTrain (LAN)
DR5000 als LocoNet mit TrainController (USB)

Rocrail ist die aktuelle Version (14987), 64bit unter Windows 10. Auf der DR5000 ist Firmware 1.5.2 installiert. Die Weichen sind FADA adressiert, die Zubehör-Box ist angehakt (wobei auch ein fehlender Haken keinen Unterschied macht).

Wie kann ich diese Verzögerungen eliminieren?

Ich danke im Voraus für jegliche Ratschläge.
You do not have the required permissions to view the files attached to this post.

rjversluis
Site Admin
Posts: 42360
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: Verzögerung beim Schalten von Weichen

Post by rjversluis » 05.02.2019, 16:49

Hallo,

am beste dieses Verhalten nachstellen mit ein bestimmte Weiche, und ein Issue erstellen.
Vorher bitte Trace Levels INFO, MONITOR und AUTOMAT dazu schalten.

rainynight65
Posts: 15
Joined: 16.05.2018, 22:45
Location: QLD, AU

Re: Verzögerung beim Schalten von Weichen

Post by rainynight65 » 06.02.2019, 07:46

Neues issue im Anhang.

Ich habe Weiche sw01 (Adresse 11) vier mal geschaltet. Hier vergehen etwa drei Sekunden zwischen Befehlserteilung und Schaltung.

Weiche sw08 (Adresse 18) ist der Cobalt SS, bei dem keine Probleme auftreten. Zweimal zum Vergleich geschaltet.

Danke

Alex
You do not have the required permissions to view the files attached to this post.

rjversluis
Site Admin
Posts: 42360
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: Verzögerung beim Schalten von Weichen

Post by rjversluis » 06.02.2019, 08:04

Hi Alex,

im Trace wird kein sw01 geschaltet.
Aber zB

Code: Select all

20190204.214230.087 r9999I tid0x4C0 OSwitch  1679 switch[W4] sync. delay 200ms
welche schon ein delay von 200ms verpasst wird.
Also, überlege die Weichen und FS Einstellungen.

rainynight65
Posts: 15
Joined: 16.05.2018, 22:45
Location: QLD, AU

Re: Verzögerung beim Schalten von Weichen

Post by rainynight65 » 06.02.2019, 08:10

Die aktuelle trace file im issue ist rocrail.009.trc. Die Funktion Issue erstellen in RR bündelt alle vorhandenen Dateien, ich nahm an, das soll so sein.

Code: Select all

20190206.164136.740 r9999c z21reade OZ21     1651 LAN_X_TURNOUT_INFO: addr=11 zz=01 (192.168.0.13)
20190206.164136.740 r9999a 00001DB4 OModel   5240 trying to match switch event: 0:11:0:0 type=0 uidname=[]
20190206.164136.740 r9999I 00001DB4 OSwitch  2035 switch [sw01] field event: state=straight(field:turnout) gatevalue=2 inv=1 fieldstate=turnout
20190206.164136.740 r9999a 00001DB4 OModel   3710 no more switches found by address [11,0]
20190206.164146.083 r9999I cmdr032E OSwitch  1364 Switch [sw01] will be set to [turnout,0,0]
20190206.164146.083 r9999c 00001478 OZ21     0536 dual gate(0) switch 10: straight port=ON
20190206.164146.083 r9999a cmdr032E OSwitch  1634 broadcasting switch[sw01] state [turnout]
20190206.164146.083 r9999I cmdr032E OSwitch  0178 CTC LED: m1=1 m2=0
20190206.164146.130 r9999c z21reade OZ21     1651 LAN_X_TURNOUT_INFO: addr=11 zz=02 (192.168.0.13)
20190206.164146.130 r9999a 00001DB4 OModel   5240 trying to match switch event: 0:11:0:0 type=0 uidname=[]
20190206.164146.130 r9999I 00001DB4 OSwitch  2035 switch [sw01] field event: state=turnout(field:straight) gatevalue=2 inv=1 fieldstate=straight
20190206.164146.145 r9999a 00001DB4 OModel   3710 no more switches found by address [11,0]
20190206.164158.051 r9999I cmdr032E OSwitch  1364 Switch [sw01] will be set to [straight,0,0]
20190206.164158.051 r9999c 00001478 OZ21     0536 dual gate(0) switch 10: turnout port=ON
20190206.164158.051 r9999a cmdr032E OSwitch  1634 broadcasting switch[sw01] state [straight]
20190206.164158.051 r9999I cmdr032E OSwitch  0178 CTC LED: m1=0 m2=0

rjversluis
Site Admin
Posts: 42360
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: Verzögerung beim Schalten von Weichen

Post by rjversluis » 06.02.2019, 08:15

Moin,

Kommando:

Code: Select all

20190206.164146.083 r9999I cmdr032E OSwitch  1364 Switch [sw01] will be set to [turnout,0,0]
20190206.164146.083 r9999c 00001478 OZ21     0536 dual gate(0) switch 10: straight port=ON
Rückmeldung Z21:

Code: Select all

20190206.164146.130 r9999c z21reade OZ21     1651 LAN_X_TURNOUT_INFO: addr=11 zz=02 (192.168.0.13)
47ms Verzögerung.

rainynight65
Posts: 15
Joined: 16.05.2018, 22:45
Location: QLD, AU

Re: Verzögerung beim Schalten von Weichen

Post by rainynight65 » 06.02.2019, 08:49

Das lese ich jetzt so, dass das trace keine hilfreichen Informationen enthält.

Ich weiß nicht, was ich sonst noch vorzeigen kann.

rjversluis
Site Admin
Posts: 42360
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: Verzögerung beim Schalten von Weichen

Post by rjversluis » 06.02.2019, 09:11

rainynight65 wrote:
06.02.2019, 08:49
Das lese ich jetzt so, dass das trace keine hilfreichen Informationen enthält.
der Trace besagt dass der Z21 der Weiche Befehlt nach ein paar ms bestätigt, also aus Sicht von Rocrail ist dann alles OK.
Ob der Z21 das DCC Befehl dann auch tatsächlich auf die Schiene gejagt hat sagt das nicht aus, aber das liegt außerhalb das Bereich von Rocrail.

rainynight65
Posts: 15
Joined: 16.05.2018, 22:45
Location: QLD, AU

Re: Verzögerung beim Schalten von Weichen

Post by rainynight65 » 18.04.2019, 03:53

Nur für den Fall, dass dies ausser mir noch jemanden interessiert: durch aktivieren der Schaltzeit-Einstellung unter Weichen - Schnittstelle für jede betroffene Weiche habe ich dieses Problem beheben können. Die Weichen schalten jetzt ohne Verzögerung.

Warum das nur bei einem von zwei Antriebstypen notwendig war, verstehe ich immer noch nicht ganz, aber zumindest weiss ich, wo ich in Zukunft nachschauen muss.

hermannk
Moderator
Posts: 1148
Joined: 06.07.2014, 12:32
Location: Kiel Germany

Re: Verzögerung beim Schalten von Weichen

Post by hermannk » 18.04.2019, 08:03

Moin Alex,
falls dieses Thema für dich positiv gelöst ist, machst du dann bitte einen grünen Haken dran - danke.
Gruß
Hermann

rainynight65
Posts: 15
Joined: 16.05.2018, 22:45
Location: QLD, AU

Re: Verzögerung beim Schalten von Weichen

Post by rainynight65 » 18.04.2019, 08:05

Hi Hermann,

Erledigt.

Gruß

Alex

Post Reply

Return to “Digikeijs (DE)”