(Solved) Update TamsMC to V2.0 failed

Post Reply
agre30
Posts: 874
Joined: 24.12.2011, 20:41
Location: Netherland
Contact:

(Solved) Update TamsMC to V2.0 failed

Post by agre30 » 29.09.2016, 16:53

Hi All,
I installed the latest version of CV-Navi, Java and rxtx on my Lubuntu laptop. Communication between CV-Navi and TamsMC is oké, I can read the configuration.
I downloaded the latest HEX V2.0 file from the Tams website and followed the instructions:
- Unplug the TamsMC from power and computer
- Press start-stop on the TamsMC and plug in the power
- Plug in de USB-cable
- Start CV-Navi

CV-Navi starts with the update screen, where I select the right port through which the TamsMC is connected en select the HEX file and then....nothing happens for a long time so I aborted the action.
How long does it take to update the TamsMC? Maybe I have to wait longer?

Or what did I do wrong?

Albert.
Last edited by agre30 on 30.09.2016, 09:47, edited 1 time in total.

cds
Moderator
Posts: 5235
Joined: 03.02.2012, 19:24
Location: Tullnerbach, Austria

Re: Update TamsMC to V2.0 failed

Post by cds » 29.09.2016, 17:03

Hello Albert!

It worked well with me a few days ago. The update takes about 30 s.

Sometimes I have to wait a while until CV Navi regocnizes the COM port.

agre30
Posts: 874
Joined: 24.12.2011, 20:41
Location: Netherland
Contact:

Re: Update TamsMC to V2.0 failed

Post by agre30 » 30.09.2016, 07:12

Hello Claus,

Do you also work with linux ubuntu or similar?
Which steps did you take to update de Tams?
Through USB or Serial cable?

Albert.

cds
Moderator
Posts: 5235
Joined: 03.02.2012, 19:24
Location: Tullnerbach, Austria

Re: Update TamsMC to V2.0 failed

Post by cds » 30.09.2016, 08:12

Hello Albert!

Win 7, USB.

- Establish cable connection
- Switch on MC and wait a little bit (COM port via USB needs some time)
- Start CV-Navi
- Make sure that there is a connection to the MC (no error message on CV-Navi shall appear!)
- Power up MC again whilst pressing start-stop (-> display shows "HexLoader ...")
- Get the hex-file
- Press "Update" or "Start" (I don't know the button by heart ...)
- The progress bar starts immediately running

agre30
Posts: 874
Joined: 24.12.2011, 20:41
Location: Netherland
Contact:

Re: Update TamsMC to V2.0 failed

Post by agre30 » 30.09.2016, 08:33

Hi Claus,
I followed your steps and it worked. I upgraded to version 2.0. Thanks.
At first I followed the instruction from the Tams website and it did not work. Strange. The way you describe it worked right away.

Thanks again.

Greetings from Holland.

Albert.

cds
Moderator
Posts: 5235
Joined: 03.02.2012, 19:24
Location: Tullnerbach, Austria

Re: Update TamsMC to V2.0 failed

Post by cds » 30.09.2016, 09:28

Hello Albert!

Great!

May I kindly ask you to mark your thread as "Closed" or "Solved"?

LDG
Site Admin
Posts: 2705
Joined: 18.10.2010, 00:03
Location: near Karlsruhe/Germany

Re: (Solved) Update TamsMC to V2.0 failed

Post by LDG » 30.09.2016, 11:19

Hi Albert,
agre30 wrote:I downloaded the latest HEX V2.0 file from the Tams website and followed the instructions:
- Unplug the TamsMC from power and computer
- Press start-stop on the TamsMC and plug in the power
- Plug in de USB-cable
- Start CV-Navi

CV-Navi starts with the update screen, where I select the right port through which the TamsMC is connected en select the HEX file and then....nothing happens for a long time so I aborted the action.
How long does it take to update the TamsMC? Maybe I have to wait longer?

Or what did I do wrong?
This should work. (Just did this last night on ubuntu to identify/verify a firmware bug in V2.0.0 :? ) Did you select the right connection used (below the hex file name selected) ? USB and RS-232 connections handle firmware updates slightly different "inside" the MC.

CV-Navi is developed on debian and/or ubuntu and tested on raspbian and windows. So it should work and almost every linux with up to date software.

Regards,
Lothar

rjversluis
Site Admin
Posts: 42360
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: (Solved) Update TamsMC to V2.0 failed

Post by rjversluis » 30.09.2016, 11:26

Hi Lothar,
LDG wrote:So it should work and almost every linux with up to date software.
is there a good reason not to support Java 1.6?
Signing andRoc with java > 1.6 will corrupt the byte code...

agre30
Posts: 874
Joined: 24.12.2011, 20:41
Location: Netherland
Contact:

Re: (Solved) Update TamsMC to V2.0 failed

Post by agre30 » 03.10.2016, 18:44

Hi Lothar,
I used the same settings in both situations. The way Claus discribed it works, the other way does not. No problem, I was able to upgrade.

Albert.

Post Reply

Return to “P50 and P50x”