ECoS create missing locos

Moderator: Moderators

ECoS create missing locos

Postby Siebenhaller » 18.03.2016, 13:37

Rob:
no, other way around. Rocrail will create a Loco in the Ecos if it does not exist.

Hallo Rob.
Is there any way to switch off this function?
I have the following problem:
Rocrail means that some locos are missing in the Ecos.
But they are allready in the Ecos.
And then it creates them, but: then they are all douplets of existing locos whit the
same DCC-Adress ...
Some time later the Ecos will crash whit many of this lcos in the list...
I do not now why this happends, but switching of the creating will stop this for seraching why...
hoping for a idee an best regard, Stefan
Siebenhaller
 

Re: ECoS create missing locos

Postby rjversluis » 18.03.2016, 14:44

Hi Stefan,

which Firmware version is installed?
Which Rocrail revision are you using?
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: ECoS create missing locos

Postby rjversluis » 18.03.2016, 15:10

Just tested it with following versions:
Code: Select all
ProtocolVersion=[0.5] ApplicationVersion=[4.1.2] HardwareVersion=[2.0]

But if the loco already exist it will not be created again.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: ECoS create missing locos

Postby Siebenhaller » 28.03.2016, 10:37

Hallo Rob,
The Rocrail version is the 11008 (new one).
But it was also in some older versions.
The ECoS is hardware 2.0 and Software 4.1.2
I have done a tracing in the rocrail-server.
But need some info, what is needed for find the problem,
because the tracing is very long...

best regard´s stefan
Siebenhaller
 

Re: ECoS create missing locos

Postby rjversluis » 28.03.2016, 10:52

just delete all server traces and start Rocrail.
Zip/Compress all server trace files after the problem has occurred and attach them in this thread.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: ECoS create missing locos

Postby Siebenhaller » 01.04.2016, 11:47

I have now done a update from rocrail to the newes version 11030
and then packed the tracing-file.
You do not have the required permissions to view the files attached to this post.
Siebenhaller
 

Re: ECoS create missing locos

Postby rjversluis » 01.04.2016, 11:57

Please disable byte level; Only activate it when a developer asked for it.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: ECoS create missing locos

Postby rjversluis » 01.04.2016, 12:13

Hi Stefan,

try revision 11.036+
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: ECoS create missing locos

Postby Siebenhaller » 02.04.2016, 09:43

Hallo Rob.
Have now disabled the byte-tracing.
And: The now tested Version 11040 seem´s to be OK.
Thank you for the fast response and fixing.
If there are some need for testing on the Ecos in the future,
feel free to give me a note.
last question: What must i do for switching the board-entry to "solved" ?
best regard´s Stefan
Siebenhaller
 

Re: ECoS create missing locos

Postby cds » 02.04.2016, 09:50

Hello!
last question: What must i do for switching the board-entry to "solved" ?
In your first posting click on "Change" (I don't know the right label because I'm working on German Forum) and edit the title, then "Save".
Beste Grüße/Kind regards
Claus

Mä H0 M, Zentrale: TAMS MC, Booster: TAMS B-2 & B-4, Schalten: TAMS WD-34 DCC, VIESSMANN 5211(1), Melden: LITTFINSKY & TAMS S88-3, Fahren: MM2, Decoder Mä & TAMS, Steuern: Win7 64, andRoc
cds
 

Re: ECoS create missing locos

Postby Besra » 02.04.2016, 10:05

Hi Stefan,

last question: What must i do for switching the board-entry to "solved" ?
See http://wiki.rocrail.net/doku.php?id=iss ... _as_solved

Regards
Besra
Maerklin H0, DCC and MM, Intellibox (I) via ULNI, Booster Tams B4, Throttle Digitrax UT4, LocoNet.
Loco decoders: Zimo, Uhlenbrock, Maerklin & ESU.
Rocweb, Win10 32bit & 64bit
Besra
 


Return to ECoS - Marklin CS1