ECoS controls are not seen by Rocview and andRoc

Moderator: Moderators

Re: ECoS controls are not seen by Rocview and andRoc

Postby rjversluis » 11.01.2015, 13:56

Tom,
smitt48 wrote:Could not create an incident file as Rocview blew away and after starting anew, new trace files would be created.

can you test with another computer please!?
Or open the box and remove the memory cards, clean the contacts and insert them again for at least 4 times. (Acer?)
Or ask for Easter a new computer. ;)
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: ECoS controls are not seen by Rocview and andRoc

Postby hclaassens » 11.01.2015, 14:30

Hi Rob,

I am sorry but it changes the speed of the wrong loc.

Changing V260 on the Ecos, changes V200 in Rocrail. See trace below of version 8421.

Code: Select all
20150111.142833.884 r0000B tid0x025 (null)   *trace dump( 0x3401CAA0: length=62 )
    offset:   00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F |ASCII...........|
    --------------------------------------------------------- |----------------|
    00000000: 3C 45 56 45 4E 54 20 31 30 30 32 3E 0D 0A 31 30 |<EVENT 1002>..10|
    00000010: 30 32 20 73 70 65 65 64 5B 31 5D 0D 0A 31 30 30 |02 speed[1]..100|
    00000020: 32 20 73 70 65 65 64 73 74 65 70 5B 31 5D 0D 0A |2 speedstep[1]..|
    00000030: 3C 45 4E 44 20 30 20 28 4F 4B 29 3E 0D 0A       |<END 0 (OK)>..  |
20150111.142833.925 r9999B tid0x025 OECoS    1982 <event rtype="1" oid="1002" rc="0" msg="OK)&gt;">
  <1002 speed="1" speedstep="1"/>
</event>

20150111.142833.977 r0000B tid0x025 (null)   *trace dump( 0x34072B70: length=62 )
    offset:   00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F |ASCII...........|
    --------------------------------------------------------- |----------------|
    00000000: 3C 45 56 45 4E 54 20 31 30 30 32 3E 0D 0A 31 30 |<EVENT 1002>..10|
    00000010: 30 32 20 73 70 65 65 64 5B 35 5D 0D 0A 31 30 30 |02 speed[5]..100|
    00000020: 32 20 73 70 65 65 64 73 74 65 70 5B 32 5D 0D 0A |2 speedstep[2]..|
    00000030: 3C 45 4E 44 20 30 20 28 4F 4B 29 3E 0D 0A       |<END 0 (OK)>..  |
20150111.142834.018 r9999B tid0x025 OECoS    1982 <event rtype="1" oid="1002" rc="0" msg="OK)&gt;">
  <1002 speed="5" speedstep="2"/>
</event>

20150111.142834.018 r9999a 5A37B700 OModel   3972 Loco/Car event: 0
20150111.142834.018 r9999a 5A37B700 OModel   3982 loco event for [V200]
20150111.142834.018 r9999a 5A37B700 OLoc     0688 event for loco V200: lc
20150111.142834.018 r9999I 5A37B700 OLoc     0766 lc=V200 V=4(1)
20150111.142834.018 r9999I 5A37B700 OLoc     0788 lc=V200 V_raw=5 V=4 fn=1 dir=Forwards throttleID=-



Hans
hclaassens
 

Re: ECoS controls are not seen by Rocview and andRoc

Postby rjversluis » 11.01.2015, 16:00

Hi Hans,

you are right.

I fixed that now.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: ECoS controls are not seen by Rocview and andRoc

Postby smitt48 » 11.01.2015, 17:06

Rob,

Sorry, was 8417!

Tom
Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.2.0) - WinXP as server, 10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 

[SOLVED]Re: ECoS controls are not seen by Rocview and andRoc

Postby hclaassens » 13.01.2015, 09:39

Hi Rob,

Tested and is working fine now :D :D :D :D


Thanks for the support,
Hans


rjversluis wrote:Hi Hans,

you are right.

I fixed that now.
hclaassens
 

Re: ECoS controls are not seen by Rocview and andRoc

Postby Hansbaer13 » 17.01.2015, 15:30

Was genau ist dann jetzt der Fehler?

Klappt die Rückmeldung der Lokgeschwindigkeit von der Ecos zu Rocrail bei euch?

Gruß Hans
Hansbaer13
 

Re: ECoS controls are not seen by Rocview and andRoc

Postby smitt48 » 18.01.2015, 17:35

Hi Hans,

Es stimmte ab Jan 13 bei mir and Hans Claasssens. Stimmt es noch nicht bei dich? Muss man die neue Daten anhaengen.

Gruesse Tom
Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.2.0) - WinXP as server, 10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 

Re: ECoS controls are not seen by Rocview and andRoc

Postby Hansbaer13 » 24.01.2015, 16:45

Oke Danke ich probiere es gleich einmal.

Und melde dann ob es nun klappt oder nicht.


Danke für euere bemühungen :)
Hansbaer13
 

Re: ECoS controls are not seen by Rocview and andRoc

Postby Hansbaer13 » 28.01.2015, 11:33

Mittlerweile funktioniert alles.

Danke für die Hilfe!
Hansbaer13
 

Previous

Return to ECoS - Marklin CS1