(SOLVED)NCE Version Problem

(SOLVED)NCE Version Problem

Postby PaulD » 07.08.2017, 13:26

Hi Rob,

This is a follow on from my 'pomwrite' problem. I downloaded the latest version and your pomwrite solution works great and I was able to do exactly what I needed to do. Thank you for responding so quickly. Unfortunately, the new version appears to be only talking and not listening i.e. I can send commands ok but it won't read my sensors.

I have an NCE Powercab. In the older version (11895) the led on the NCE usb interface board would constantly flash. With the new version it doesn't do anything. Luckily I created a Windows restore point before I installed the new version so I was able to go back to 11895 and things worked again as normal.

Do you have any ideas or is there anything I can post which might help give you a clue? (or am I missing something obvious....?)

Thanks
Paul
Last edited by PaulD on 08.08.2017, 22:40, edited 1 time in total.
PaulD
 

Re: NCE Version Problem

Postby rjversluis » 07.08.2017, 15:31

Hi Paul,

as always: Attach your files.

The last change of the nce library is 7 month ago.

11.895 is newer:
Code: Select all
11895 2017-01-22 16:25:53 +0100 tracedlg: trace level find added
...
11861 2017-01-12 19:46:13 +0100 nce: fix for evaluating AIU

11.861 is the last change in the nce library.

BTW: Update Rocrail on regular base.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: NCE Version Problem

Postby PaulD » 08.08.2017, 12:30

Hi Rob,

I have added trace files for both 11895 (which works) and 12520 (which doesn't work).

Hope this helps and please advise if you need something more. I appreciate your help.

Kind Regards
Paul
You do not have the required permissions to view the files attached to this post.
PaulD
 

Re: NCE Version Problem

Postby rjversluis » 08.08.2017, 13:39

Hi Paul,

what exactly does not work?
As I wrote before: Nothing has been changed in the nce lib.
You must be more precisely.

You must set fbpoll="false" to true for polling.
Did you read the Wiki?
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: NCE Version Problem

Postby PaulD » 08.08.2017, 22:39

Rob,

In 11895 I actually didn't need the 'poll' box selected for the sensors to work (I can show you a screenshot if you like) - so it wasn't something that I thought about when troubleshooting this. But I have now selected it in this version and the sensors work now. Thank you for you assistance.

Regards
Paul
PaulD
 


Return to General