Trains running erratic forwards and backwards

Trains running erratic forwards and backwards

Postby smitt48 » 12.01.2018, 17:14

Hi,

ECoS 2 Firmware 4.2.2
Rocrail version 13381
Backwards.PNG

Train Sweden DM3 is slotted to go counter clockwise, but goes clockwise instead clobereing Norway.
I am not sure if it my loco settings, therefore I added the picture. All my V__ settings are -0> or 0>, which is what is needed.

I am going to revert my ECoS firmware back to 4.2.0, but I am not sure if that is the culprit.
Trains in automode (6090 and mfx decoders) seem to be reversing direction, just about with each sensor activity. needless to say that is creating havoc!
I hope one can see something in this trace.

Thanks Tom
You do not have the required permissions to view the files attached to this post.
Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.2.2) - Win10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 

Re: Trains running erratic forwards and backwards

Postby smitt48 » 12.01.2018, 19:17

Hi,

I have reset the firmware on the ECoS2 back to 4.2.0, all the issues with backwards driving in automode went away. :shock:
Strangely enough manually running without Rocrail, and with 4.2.2 did not give any problems.
Can someone else with an ECoS install 4.2.2 an check for problems?

@Rob, What is the best way to track this? Verify the PC-interface log files that the ECoS generates?

Thanks Tom
Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.2.2) - Win10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 

Re: Trains running erratic forwards and backwards

Postby rjversluis » 12.01.2018, 19:45

Hi Tom,

for Ecos Firmware issues you must contact ESU, not me.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Trains running erratic forwards and backwards

Postby smitt48 » 12.01.2018, 19:56

Hi Rob,

:( Yes I know!
Many people, based on the ESU forum, have Firmware 4.2.2 installed. However I assume few Rocrail users.
On the other hand there is an log file from the ECoS that shows activity (what the contents is I don't know). I was hoping you had taken a look at in the past. In the Rocrail trc files I never saw a definitiv direction = rev from Rocrail. That is the reason I suspected the Firmware in the first place.
I'll just wait until an ECoS user indicates a problem.

Tom
Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.2.2) - Win10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 

Re: Trains running erratic forwards and backwards

Postby rjversluis » 12.01.2018, 19:59

Hi Tom,

maybe they integrated Alexa in the new release and you did not connect a microphone to your ecos.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Trains running erratic forwards and backwards

Postby smitt48 » 12.01.2018, 20:33

Hi Rob,

Maybe they did not.

Alexa who needs it. It took some work the first time, but I stopped Cortana on Win. Too stupid to answer all those dumb questions. "What do you want to do today"?
Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.2.2) - Win10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 

Re: Trains running erratic forwards and backwards

Postby smitt48 » 13.01.2018, 17:40

Hi Rob,

Can you check this logfile from the ECoS's PC-Interface. There are some weird messages in it and I don't understand them.
Unknown option???
8:22.840 Netclient 'get(26, state)' unknown option at 9 from 192.168.1.1:52955

Do you know what it is trying to do? S88n or switches or signals or even locos?

9:07.770 accessory off didn't match on (D12.2R->D10.1R)
9:08.004 accessory off didn't match on (D10.1R->D9.4R)
9:08.253 accessory off didn't match on (D9.4R->D10.4R)


Checking something that does not work!?
32:52.120 Netclient 'release(107156308, view)' integer out of range at 17 from 192.168.1.1:52955

145:50.508 Netclient 'release(11, view, viewswitch)' unknown option at 19 from 192.168.1.1:53436


This is the logfile with the "good" firmware 4.2.0. I would like to know what I am seeing?

I appreciate your help, Tom
You do not have the required permissions to view the files attached to this post.
Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.2.2) - Win10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 

Re: Trains running erratic forwards and backwards

Postby rjversluis » 13.01.2018, 17:46

Hi Tom,

I cannot interpret the ESU Logs; Ask ESU.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Trains running erratic forwards and backwards

Postby smitt48 » 13.01.2018, 19:15

Hi Rob.

I understand, I was hoping. :roll:

Tom
Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.2.2) - Win10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 


Return to General