(solved) svg SLIM issues

(solved) svg SLIM issues

Postby smitt48 » 16.10.2017, 13:33

Hi Rob,

Edit: version 12857.
I have some inconsistencies with SLIM, which I can't figure out.
This DKW (with one drive) shows like this every time I start Rocrail, only after "reset loc assignment" it changes to the SLIM format.
Slim C11.PNG


slimerr13.PNG

When running trains the switches still show in Spdr60 format.

Plan is attached.
The flashing is almost gone especially with the sensors, however there is an annoying flash (cursor?) in the zoom-box.

Thanks Tom
You do not have the required permissions to view the files attached to this post.
Last edited by smitt48 on 16.10.2017, 14:08, edited 1 time in total.
Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.2.0) - WinXP as server, 10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 

Re: svg SLIM issues

Postby LDG » 16.10.2017, 14:02

Hi Tom,

it is your personal Rocview themes configuration that contaisn too much symbol extensions !
If you want to use the theme "SLIM" then do not use one of the following themes: "SpDrS60", "SpDrS60-extra" or "User" !
If you need one (or more) of the svg symbols of the themes mentioned above then create your own "private" theme directory and copy only the (really) needed symbols into that theme. Use this "private" theme as the only extension to "SLIM" theme in Rocview.

Regards,
Lothar
LDG
Site Admin
 

Re: svg SLIM issues

Postby smitt48 » 16.10.2017, 14:08

Hi Lothar,

Thanks, I will do that. I need the regular Spdr60 Crossing symbol, as SLIM does not have one and the double turnout option generates too many routes, causing problems if you don't delete them every time.

Tom
Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.2.0) - WinXP as server, 10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 

Re: (solved) svg SLIM issues

Postby rjversluis » 16.10.2017, 14:36

Tom,

just remove the autogen from the unwanted routes and put those routes out of order.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: (solved) svg SLIM issues

Postby smitt48 » 16.10.2017, 15:57

Hi Rob,

Thanks! Done that.
In Themes I have Slim and Roads.
slimerr14.PNG


Still the issue that C11 is "Locked" it shows locked by 29163, which is not on the layout.
10:52:51 unlock switch [C11] for [-] Reset Loco removes the loco and switch is free.
Close Rocview and Rocrail.
Start Rocview, load workspace.
C11 is again locked by 29163.
Anyway to get rid of that?

Tom
You do not have the required permissions to view the files attached to this post.
Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.2.0) - WinXP as server, 10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 

Re: (solved) svg SLIM issues

Postby hermannk » 16.10.2017, 16:12

Hi Tom,
what about using an editor,
- open file "plan.xml",
- searching for the string "29163 Steam"
- replacing that string with an empty string "".
- saving the file "plan.xml" and
- run Rocrail again.
Should work.
Make a save copy of the file at first.
Kind regards
Hermann
[Spur N] [Mac OS X] [Raspberry Pi 2 B] [OpenDCC GBM-Master, GBM16T] [OneControl + BiDiBone] [Rocweb]
hermannk
 

Re: (solved) svg SLIM issues

Postby smitt48 » 16.10.2017, 21:25

Hi Hermann,

Thanks that worked!

Tom
Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.2.0) - WinXP as server, 10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 


Return to General