Trace questions in automatic mode

Trace questions in automatic mode

Postby smitt48 » 22.10.2017, 16:21

Hi,

I have some questions about my traces in automatic mode.
Everything seems to go OK, but I have
1. 289 "unhandled sensor" messages.
2. 3792 "no fbevent found by key" messages
3. Have some ghost trains in a block (primarily B1B) when the train is leaving.
4. Can't find it in the trace, but there is an irregular Windows "dong" sound. Have not yet been able to find a pattern.

Thanks for some insight, Tom
You do not have the required permissions to view the files attached to this post.
Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.2.0) - WinXP as server, 10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 

Re: Trace questions in automatic mode

Postby rjversluis » 22.10.2017, 16:24

Hi Tom,

just turn off the automatic trace level; Is only needed for debugging.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Trace questions in automatic mode

Postby rjversluis » 22.10.2017, 16:32

Hi Tom,

sensor F16 did trigger a Ghost in B10:
Code: Select all
20171022.102322.142 r9999a 0000B850 OFBack   0708 fb [F16](ON) code= val=0 count=1 call listener 0x0281339C...
20171022.102322.142 r9999a 0000B850 OBlock   0611 no fbevent found by key F16-
20171022.102322.142 r9999a 0000B850 OBlock   0626 Block [B10] no event found for fromBlockId [?], try to find one for all with key [F16-all-reverse]...
20171022.102322.142 r9999a 0000B850 OBlock   0632 Block[B10] id=F16 fbid=F16-all-reverse state=true code=[] fbfrom=all-reverse fbaction=in from=? byroute=? loco=
20171022.102322.142 r9999I 0000B850 OBlock   0690 locId not set in block B10
20171022.102322.142 r4202E 0000B850 OBlock   0534 Ghost train in block [B10], fbid=F16-all-reverse, code=
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Trace questions in automatic mode

Postby smitt48 » 22.10.2017, 16:39

Hi Rob,

Thanks.
F16 is in a closed block in which I have stored a train.
I decided to close it so no activity would take place.
Should I open the block and set the train in the block instead?

Please look at the VB1C block, it shows false instead off loc "Croc Brown". What does that mean?

Thanks Tom
Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.2.0) - WinXP as server, 10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 

Re: Trace questions in automatic mode

Postby peter&basti » 22.10.2017, 17:07

Hi Tom,

I have a mostly closed Block on my Layout, the maintenance track.
Usually when my 2-year old grandson is visiting, all the trains are Running in Automode and on the maintenance Track in Front of the Layout we are playing manually with all the sound locos together.
"Tüüüt" is the key to keep him smiling :wink:

No loco set in this Track.
No ghost at all.
Liebe Grüße / best regards
Peter


System: DCC 2-Leiter H0, Rocrail Win10 Pro 64
Traktion: GBMBoost & GBM16T, RailCom
Fahrweg: RocNetNode & GCA PI01/2/3, GCA41/Arduino RFID, GCA145 Drehscheibe, etc.
Lokdecoder: 99% Zimo
peter&basti
 


Return to General