Help? Config Tams HSI-s88 BIDIB

Moderator: Moderators

Help? Config Tams HSI-s88 BIDIB

Postby rvooyen » 22.01.2017, 12:20

Hi,

I have purchased and am trying to install a Tams HSI-s88 interface.

I have connected it to the usb of the PC and it is added as COM6 USB to Serial.

I have then connected the s88N cable to the middle RJ connector, there are 10 (16x) s88 modules attached. These all work via the s88 bus into the IB1. I also added the JP3 jumper so that the device uses the HSI not the BIDIB.

I have added a controller HSI-s88 from the list of controllers and attached this to COM6 in Rocrail properties.
I selected the RS232 option and added 10 modules to the middle s88 bus.
I then reconfigured some of the 150 feedbacks to use the HSI-s88 controller. (138,139,140,141 fbs)

I then restarted Rocrail. I then wanted to test the feedbacks. However I do not see anything happening!

I have tried various settings and also checked wiki and the forum and cant find anything that helps me.

Perhaps one of you has the golden tip I need to get the Tams HSI-s88 BIDIB to work.

Thanks in advance for some help. I attach the issue.zip for all the relevant files of my work.

Thanks Robert
You do not have the required permissions to view the files attached to this post.
Robert van Ooijen.
Building Rhineland2. 3 levels. CS=IB1-Loconet+HSI-s88, 70 blocks, 160 sensors, 4 boosters. M&K 3rail.
Goal: Scheduled Pass. trains, "OPS" with car cards etc.. Using andRoc and Rocweb/xs throttles.
Rocrail on WinXP.
rvooyen
 

Re: Help? Config Tams HSI-s88 BIDIB

Postby LDG » 22.01.2017, 12:39

Hi Robert,

the s88-BiDiB-Link has a different s88 bus connector layout.
Short: "Bus 1" (middle) is "left" in HSI88 command station config in Rocrail
Long:
  • fb modules connected to "Bus 1" (middle on tams) has to be configured as "s88 chain left"
  • fb modules connected to "Bus 2" has to be configured as "s88 chain middle"
  • fb modules connected to "Bus 3" has to be configured as "s88 chain right"
Regards,
Lothar
LDG
Site Admin
 

Re: Help? Config Tams HSI-s88 BIDIB

Postby Besra » 22.01.2017, 12:43

Hi Robert,

in addition to Lothar's comment in the trace you provided there seems to be no connection to COM6:
Code: Select all
20170122.120140.618 r9999E hsi88fb  OSerial  0445 Timeout on serial read[COM6] 0 of 1 read.[rc=0] tries=3

Are you sure, com6 is the correct com port? USB driver is / was installed?

Regards
Besra
Maerklin H0, DCC and MM, Intellibox (I) via ULNI, Booster Tams B4, Throttle Digitrax UT4, LocoNet.
Loco decoders: Zimo, Uhlenbrock, Maerklin & ESU.
Rocweb, Win10 32bit & 64bit
Besra
 

Re: Help? Config Tams HSI-s88 BIDIB

Postby LDG » 22.01.2017, 12:59

Hi,

@Besra: the hsi-s88-link is using the ftdi from Microsoft. No further installaiton required 8)
I get the same "read timeout" once at startup.

@Robert: please enable "info" trace level for next issue
You may use "Sensor monitor..." to check if sensor changes are reported.

Regards,
Lothar
LDG
Site Admin
 

Re: Help? Config Tams HSI-s88 BIDIB

Postby rvooyen » 22.01.2017, 13:20

LDG wrote:Hi Robert,

the s88-BiDiB-Link has a different s88 bus connector layout.
Short: "Bus 1" (middle) is "left" in HSI88 command station config in Rocrail
Long:
  • fb modules connected to "Bus 1" (middle on tams) has to be configured as "s88 chain left"
  • fb modules connected to "Bus 2" has to be configured as "s88 chain middle"
  • fb modules connected to "Bus 3" has to be configured as "s88 chain right"
Regards,
Lothar



YES!!!! The golden tip. ALl works now.

Thanks Lothar. Perhaps something in the WIki might help, ie middle is left?????

Robert
Robert van Ooijen.
Building Rhineland2. 3 levels. CS=IB1-Loconet+HSI-s88, 70 blocks, 160 sensors, 4 boosters. M&K 3rail.
Goal: Scheduled Pass. trains, "OPS" with car cards etc.. Using andRoc and Rocweb/xs throttles.
Rocrail on WinXP.
rvooyen
 

Re: Help? Config Tams HSI-s88 BIDIB

Postby smitt48 » 22.01.2017, 13:28

Hi Robert,

In your properties for HSI Controller you have RS232 instead of USB selected.
Is that OK? In your forum entry you talk about USB.
By the way not all your sensor entries contain HSI.

Tom
Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.2.3) - Win10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 

Re: Help? Config Tams HSI-s88 BIDIB

Postby Besra » 22.01.2017, 13:33

Maerklin H0, DCC and MM, Intellibox (I) via ULNI, Booster Tams B4, Throttle Digitrax UT4, LocoNet.
Loco decoders: Zimo, Uhlenbrock, Maerklin & ESU.
Rocweb, Win10 32bit & 64bit
Besra
 

Re: Help? Config Tams HSI-s88 BIDIB

Postby Besra » 22.01.2017, 13:35

Hi Tom,

In your properties for HSI Controller you have RS232 instead of USB selected
yes, the HSI serial protocol is used even though the device is connected through USB. Weird but true ;)

Regards
Besra
Maerklin H0, DCC and MM, Intellibox (I) via ULNI, Booster Tams B4, Throttle Digitrax UT4, LocoNet.
Loco decoders: Zimo, Uhlenbrock, Maerklin & ESU.
Rocweb, Win10 32bit & 64bit
Besra
 

Re: Help? Config Tams HSI-s88 BIDIB

Postby LDG » 22.01.2017, 14:42

Hi,
Besra wrote:
smitt48 wrote:In your properties for HSI Controller you have RS232 instead of USB selected
yes, the HSI serial protocol is used even though the device is connected through USB. Weird but true ;)
USB device with FTDI chipset and serial protocol makes this device useable on almost all platforms with "standard" device drivers (i.e. RasPi 8) )

HSI mode: compatible with "original" LDT protocol -> supported be every software that supports the "original" HSI device

BiDiB-mode (factory default): useable as BiDiB-interface with 3 S88 chains "onboard". Every 16port sensor module reported as BiDiB node. Additional BiDiB devices/nodes (up to 32) can be used on software that supports BiDiB (i.e. Rocrail 8) )

Regards,
Lothar
LDG
Site Admin
 


Return to HSI88