OC32 Decoder Module

Moderator: Moderators

OC32 Decoder Module

Postby mgxtreme » 20.10.2017, 16:21

Hi

Has anyone successfully setup RocRail to work with an OC32 module in order to control aspect signals. (http://www.dcctrainautomation.co.uk/oc3 ... ction.html)

Be interested in any lessons learnt and any screen shots of how a signal has been configured in RocRail to work with the OC32

Regards

Rob
Kind Regards

Rob
mgxtreme
 

Re: OC32 Decoder Module

Postby rjversluis » 20.10.2017, 17:04

Hi,

try the search function:
search.php?keywords=oc32

The OC32 is for the Netherlands only. ;)
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: OC32 Decoder Module

Postby mgxtreme » 20.10.2017, 17:48

Will give that ago.

The OC32 is available in the UK with English definitions :D

Regards

Rob
Kind Regards

Rob
mgxtreme
 

Re: OC32 Decoder Module

Postby rjversluis » 23.10.2017, 07:05

Hi,

did you read this:
http://wiki.rocrail.net/doku.php?id=dinamo-om32-en

There are other Forum members using this OC32, mainly in the Dutch part of the Forum.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: OC32 Decoder Module

Postby mgxtreme » 03.11.2017, 09:34

All

Thanks for the links and advice I finally got the OC32 to power on a signal via the OC32Config app which comes from the Dinamo, this felt like a significant milestone had been reached, but I must be really thick as I can't get RocRail to drive it.

I have a single OC32 with the board address set to 1 on the back of switches, and we also use an RS485 USB interface connected to the OC32. There is currently only one signal attached to the board with its respective colour wires connected to the 1st four output ports (1,2,3,4)

I have created a new controller in RocRail and set it to use the OM32 library as per the instructions with its com port set to that of the RS485 device. The baud rate is also set to 19200.

The information I can't seem to figure out is as follows
On the interface tab (have selected the OC32 controller from the drop down)
1.....What should the Bus address be set to?
2.....Should the protocol be set to Dinamo OM32 or Dinamo OC32 or other
3.....I assume the address for each colour would be 1 (as this is the board number as set by the switches on the board) and the port number is set to whichever port the wires are connected to
(as the ports are number 1 to 32 does RocRail match these numbers or do I need to offset them by -1)

On the wiring tab does any information here needed to be populated? If so how do I handle that this tab only offers up detail for 3 aspects and some of my signals have 4 aspects.

Sorry for be thick but I do really appreciate all the help this site has provided to me to date

Regards

Rob
Kind Regards

Rob
mgxtreme
 

Re: OC32 Decoder Module

Postby rjversluis » 03.11.2017, 09:39

Hi Rob,

just read the Wiki. On each dialog there is a Help button which opens the matching page.

On this page every question you wrote is answered.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: OC32 Decoder Module

Postby mgxtreme » 03.11.2017, 10:11

Thanks but I have read that page numerous times :D and I still can't get RocRail to control the signal.

as I said I must be thick !! :D

Will just have to keep trying different settings :)
Kind Regards

Rob
mgxtreme
 

Re: OC32 Decoder Module

Postby mgxtreme » 10.11.2017, 22:10

Hello all

Having now had some success with getting RocRail to communicate with my OC32 I now have a couple of strange problems.

The first problem is

I have added a signal track icon to the layout and set it as a 4 aspect signal by changing the value under the details tab to 4. The OC32 has the first 4 ports configured as Red, Green, Yellow Double Yellow thus equalling 1,2,3,4 however when you cycle through the colours by clicking on the icon on the first and last colours match the icon on the screen yet it is switching the Green and Yellow around.

Any ideas.

The next problem is when RocRail sets the signal to 1 (Red) the LED is static and constant however when RocRail cycles through the other colours the LED flashes. Now when you test each colour sequence with the OC32Config app used to program the board the LEDS are static. Having put an electrical voltage meter on the OC32 this also shows a stable and constant voltage when using the OC32Config app to test however on any port other than 1 the voltage can clearly be seen to spike up and down. Given the OC32Config app does not show the same symptoms I can only assume it must be how ROcRail is talking to the OC32.

Could this be because in RocRail you can set the baud rate and the flow control but you can't set the stop bits and parity for the Com Port the OC32 is connected to (RS485)

Any ideas?
Kind Regards

Rob
mgxtreme
 

Re: OC32 Decoder Module

Postby rjversluis » 10.11.2017, 22:14

Rob,

reading the Wiki you should setup the signal with aspects:
http://wiki.rocrail.net/doku.php?id=din ... en#signals
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: OC32 Decoder Module

Postby mgxtreme » 11.11.2017, 08:01

Thanks for the link but this still is not making any sense to me.

I have included two screen shots of the interface and details tabs. If I set the control to aspect numbers if I then monitor the control box for the commands being sent it only ever send 1-1 and I et nothing to the signal whereas if I set it to default you can see rocrail sending 1-1, 1-2 etc and I get some response at the signal, albeit the same issues that anything other than port 0 the power is not consistent and changes from 0v to 5v thus resulting in a flashing led.

It is so frustrating to feel so close to getting this to work properly yet feeling so far from achieving this.

Any points would be gratefully received
You do not have the required permissions to view the files attached to this post.
Kind Regards

Rob
mgxtreme
 

Re: OC32 Decoder Module

Postby rjversluis » 11.11.2017, 08:13

Hi,

did you read the link?

Signal Properties -> Interface -> Control -> Aspect numbers
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: OC32 Decoder Module

Postby mgxtreme » 11.11.2017, 08:29

Hi

Yes but not all of it makes sense. I am sorry for my lack of understanding and I appreciate all the help this site has provided to date.

I really like RocRail and think all it has to offer is fantastic and really want to understand more so I can get this working.
Kind Regards

Rob
mgxtreme
 

Re: OC32 Decoder Module

Postby rjversluis » 11.11.2017, 08:36

Moin,

just check the OC32 manual on how to configure Signals.
The OC32 has this Aspect Number support on board.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 


Return to Dinamo