GCA50 programming/reading issues

RocNet(RaspberryPi), mergCBUS and LocoNet based hardware developed by Peter Giling. (GCA)
Documentation: http://wiki.rocrail.net/doku.php?id=english#hardware
Order information: http://wiki.rocrail.net/doku.php?id=gca:gca-index-en/

GCA50 programming/reading issues

Postby Taigatrommel » 02.04.2017, 14:01

Hi all,

I'm starting out with Rocrail, trying some basic setups before moving onto anything large. My basic setup is USB-RS232 adaptor-Twin Center. I have Twin Centers running software v2 and v1.1.

On my home PC, a self made tower running windows 10, I can read and program the GCA50 without problems. However, on two laptops, an Acer Switch 10 and an HP 15-p158sa (both Windows 10), I cannot read back from the GCA 50 or seemingly make any changes - for instance, querying the address returns no results. Nor can I use the basic setup to change the purpose of ports (eg sensor or switch). Other functionaility, eg read back of the already programmed ports which are fed by current draw sensors and train control via Rocrail is just fine. I was wondering whether anyone could suggest a solution!

As far as settings go, baud rates on the Twin Centers, Rocrail and the USB/RS232 adaptors are all matches (19200 baud), the interfaces on the TCs are set to Loconet and SO6 is set to 255.

Any help appreciated,

Richard
Taigatrommel
 

Re: GCA50 programming/reading issues

Postby rjversluis » 02.04.2017, 14:27

Hi Richard,

I suspect you are using the GGCA101 for LocoNet communication.
This is UDP based and needs a rule in the firewall to allow it.

This is a common issue with Windows, also with other Command Stations using UDP like Märklin CS2.
Best Regards, Rob.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: GCA50 programming/reading issues

Postby Taigatrommel » 02.04.2017, 18:57

Hi Rob,

Thanks for your reply. I'm going straight from PC to Twin Center via a USB-RS232 adaptor.

My brother-in-law (Andi Dell, builder of Dagworth and Ravensclyff, using MRCC rather than Rocrail) actually found a solution while having a play; using the P50x interface without changing any settings on the Twin Center got communications to the GCA50 open. Quite how that works is beyond me, but I'll take the result for the time being! We had a couple of locos shuffling around on our test piece at the exhibition (Cheltenham, UK) we were demonstrating at this weekend. Even though we're both new to Rocrail, it generated some interest.

This also explains how it worked on my tower PC but not on the laptops; I'd initially used P50x settings on the tower before changing to Loconet, but I hadn't deleted the P50x controller from the Rocrail settings on the tower. Multiprotocol at the wrong end?!? :lol:
Taigatrommel
 


Return to GCA (Hardware by Peter Giling)