erl.Züge halten nicht mehr mit relativen FP im Block

erl.Züge halten nicht mehr mit relativen FP im Block

Postby dgeffe » 21.04.2017, 11:22

Hallo

Meine Züge halten nach Update auf 12208 im FB-Betrieb nicht mehr im Block. (ICE geschrottet :roll: )
Hier am Beispiel FB Erfurt-Gera ICE 2 mit dem ICE_2

Gruß Dirk

Gruß Dirk
You do not have the required permissions to view the files attached to this post.
Last edited by dgeffe on 24.04.2017, 09:19, edited 4 times in total.
[ Windows 10 ] [Raspberry 2 als Server ][GBMBoost] [2x GBM16T] [ Digikeijs DR4088xx, DR4018, DR4024 ] [ Qdecoder ]
dgeffe
 

Re: Züge halten nicht mehr im FB im Block

Postby lordbrummi » 21.04.2017, 11:33

Hi Dirk,

da gabs glaub neulich ne Änderung, hab ich aber auch nur so halb mitgelesen, da ich keine Fahrpläne benutze.
Guck mal hier:
viewtopic.php?f=46&t=13714
viewtopic.php?f=46&t=13720

Grüße Dieter
TamsMC, Servodecoder und Magnetartikeldecoder, S88 Rückmeldung, OpenCar und 3-Leiter Bahn, Win10 64bit
lordbrummi
 

Re: Züge halten nicht mehr im FB im Block

Postby rjversluis » 21.04.2017, 11:39

Hi Dirk,

auch nach diese von Dieter erwähnte Änderung können keine Kollisionen entstehen weil das normale reservieren von Blöcke und Fahrstrassen greift natürlich immer.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Züge halten nicht mehr im FB im Block

Postby dgeffe » 21.04.2017, 11:39

Hallo Dieter

Bringt mich nicht wirklich weider. Habe in den Blöcken warten aktiviert. Aber meine Züge fahren überall durch.
Wenn dann ist es ein sehr krasse Änderung.

Gruß Dirk
[ Windows 10 ] [Raspberry 2 als Server ][GBMBoost] [2x GBM16T] [ Digikeijs DR4088xx, DR4018, DR4024 ] [ Qdecoder ]
dgeffe
 

Re: Züge halten nicht mehr im FB im Block

Postby dgeffe » 21.04.2017, 11:44

Hi Rob

Wenn ein Zug in einem Block nicht zum stehen kommt und mit 200 in die kurve raucht schon.

Aber egal. Warum und welche Änderungen wurden gemacht. Bei mir ist die Option warten im Block aktiviert.
Im FB ist warten aktiviert Zug fährt durch.
Blicke hier nicht mehr durch ! :roll:

Gruß Dirk
[ Windows 10 ] [Raspberry 2 als Server ][GBMBoost] [2x GBM16T] [ Digikeijs DR4088xx, DR4018, DR4024 ] [ Qdecoder ]
dgeffe
 

Re: Züge halten nicht mehr im FB im Block

Postby dgeffe » 21.04.2017, 12:08

Hallo


Ich kann einstellen was geschrieben steht es hält kein Zug im Block . ( relativer FB )
Wenn warten im Block im FB aktiviert ist wo kann ich dann die Wartezeit im Block einstellen ?
Was ist dann mit Aktionen die vom Blockzeitgeber abhängig sind ?

Gruß Dirk
[ Windows 10 ] [Raspberry 2 als Server ][GBMBoost] [2x GBM16T] [ Digikeijs DR4088xx, DR4018, DR4024 ] [ Qdecoder ]
dgeffe
 

Re: Züge halten nicht mehr im FB im Block

Postby peter&basti » 21.04.2017, 12:09

Hi Dirk, Rob,

der betreffende FP ist relativ, hat in allen 4 Einträgen einen Halt eingetragen, die Uhrzeit ist aber bei allen 4 Einträgen 00:00

Kann sein das diese (spezielle) Variante jetzt nicht mehr läuft?
Rob, kannst Du nachsehen, was bei Uhrzeit 00:00 passiert?
Liebe Grüße / best regards
Peter


System: DCC 2-Leiter H0, Rocrail Win10 Pro 64
Traktion: GBMBoost & GBM16T, RailCom
Fahrweg: RocNetNode & GCA PI01/2/3, GCA41/Arduino RFID, GCA145 Drehscheibe, etc.
Lokdecoder: 99% Zimo
peter&basti
 

Re: Züge halten nicht mehr mit relativen FB im Block

Postby dgeffe » 21.04.2017, 12:30

Hi Peter


Mit Uhrzeit das gleiche.
Stelle ich um auf Absolut funktionieren meine FP in Blöcken wo kein halt angegeben ist wird auch gehalten.

Bitte um Änderung auf den alten Zustand bis diese massive Änderung auch wirklich funktioniert.
Bitte auch um Ergänzung um die Spalte Warten im der FB-Tabelle.
Was ist mit den Block Zeitgebern ? Greifen die von den Block-Eigenschaften ?

Gruß Dirk
[ Windows 10 ] [Raspberry 2 als Server ][GBMBoost] [2x GBM16T] [ Digikeijs DR4088xx, DR4018, DR4024 ] [ Qdecoder ]
dgeffe
 

Re: Züge halten nicht mehr im FB im Block

Postby rjversluis » 21.04.2017, 12:57

peter&basti wrote:Hi Dirk, Rob,

der betreffende FP ist relativ, hat in allen 4 Einträgen einen Halt eingetragen, die Uhrzeit ist aber bei allen 4 Einträgen 00:00

Kann sein das diese (spezielle) Variante jetzt nicht mehr läuft?
Rob, kannst Du nachsehen, was bei Uhrzeit 00:00 passiert?

das widerspricht sich...
Ich könnte da höchstens 00:01 automatisch eintragen weil sonnst wird der Ablauf chaotisch.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Züge halten nicht mehr mit relativen FP im Block

Postby rjversluis » 21.04.2017, 15:53

Rob, kannst Du nachsehen, was bei Uhrzeit 00:00 passiert?

dann wird nicht angehalten weil Null ist Null.

Am besten noch eine neue Option: "Ignore block wait for schedules"
Was dann default auf False steht und das ganze wieder Kompatibel mit vorhandene FPs macht...

Oder verknüpfen mit
http://wiki.rocrail.net/doku.php?id=loc ... rture_time
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Züge halten nicht mehr mit relativen FP im Block

Postby rjversluis » 21.04.2017, 16:02

Also,

ich habe es jetzt so geändert das "Use schedule time" für das neue Verhalten gesetzt sein muss.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Züge halten nicht mehr mit relativen FP im Block

Postby peter&basti » 21.04.2017, 17:53

Hallo Dirk,

Relativer Fahrplan mit Abfahrtszeiten hat bei mir heute morgen funktioniert.
Getestet mit 12.208
Liebe Grüße / best regards
Peter


System: DCC 2-Leiter H0, Rocrail Win10 Pro 64
Traktion: GBMBoost & GBM16T, RailCom
Fahrweg: RocNetNode & GCA PI01/2/3, GCA41/Arduino RFID, GCA145 Drehscheibe, etc.
Lokdecoder: 99% Zimo
peter&basti
 

Re: Züge halten nicht mehr mit relativen FP im Block

Postby dgeffe » 21.04.2017, 18:10

Hi Peter

Das schöne mit relativen FP war das man keine Zeiten gebraucht hat.

Aber auch wenn ich Zeiten eingebe fährt mein Zug ohne halt seine Runden.
Ändere ich den FP auf Absolut und lasse die Zeit auf 0:00 Stoppt mein Zug in allen Blöcken . Auch in jenen die nicht auf Haltepunkt gestellt sind.
Hier versucht sich die Katze in den Schwanz zu beißen !

Wie oben geschrieben verwende ich Version 12208 / 12210 .


Gruß Dirk
[ Windows 10 ] [Raspberry 2 als Server ][GBMBoost] [2x GBM16T] [ Digikeijs DR4088xx, DR4018, DR4024 ] [ Qdecoder ]
dgeffe
 

Re: Züge halten nicht mehr mit relativen FP im Block

Postby peter&basti » 21.04.2017, 22:38

Hi Rob, Dirk,

Aber auch wenn ich Zeiten eingebe fährt mein Zug ohne halt seine Runden.

Kann ich nicht bestätigen. Abfahrtszeiten werden eingehalten, der Zug stoppt im Block und wartet bis die Abfahrtszeit eintritt (relativer Fahrplan)

ich habe jetzt mit 12.208 und dem Plan von Stefan nochmals nachgetestet. Wenn ich dort im relativen FP überall 00:00 eintrage, bleibt der Zug tatsächlich nicht stehen.
Sehe ich in meiner Denke aber nicht unbedingt als Fehler. Wozu stehenbleiben, wenn die Abfahrtszeit längst überschritten (größer 00:00)?

Ein Fahrplan ist ein Fahrplan und dieser hat für mich (analog zur realen Bahn) auch geplante Abfahrtszeiten, relativ, absolut, stündlich, wie auch immer.
Wozu sonst sollte er sonst gut sein, für mich der wesentliche Grund überhaupt Fahrpläne einzurichten, bis zu durchaus aufwändigen Taktfahrplänen. Ich wäre nie auf die Idee gekommen, hier keine Zeiten einzutragen. Gerrit rechnet in seinem Fahrplananzeiger Script sogar die allfälligen Verspätungen heraus...

Aber wahrscheinlich habe ich einen anderen Zugang zum Thema Fahrplan.

Ich hatte schon in der Anfrage meine Sorge auf mögliche Kompatibilitätsprobleme formuliert, jetzt haben wir dank Dirk welche gefunden ...
Jetzt (morgen) gibt es eine Conditio dazu, hoffentlich laufen jetzt auch wieder die Fahrpläne ohne Fahrplan :wink: und alles ist gut...
Liebe Grüße / best regards
Peter


System: DCC 2-Leiter H0, Rocrail Win10 Pro 64
Traktion: GBMBoost & GBM16T, RailCom
Fahrweg: RocNetNode & GCA PI01/2/3, GCA41/Arduino RFID, GCA145 Drehscheibe, etc.
Lokdecoder: 99% Zimo
peter&basti
 

Re: Züge halten nicht mehr mit relativen FP im Block

Postby StefanF. » 22.04.2017, 06:26

Hallo Peter,
wofür wird die Option Haltepunkt im Register Ziele noch gebraucht, wenn die Züge jetzt bei der Wartezeit 00:00 nicht mehr anhalten?
Kann doch dann weg. Eine Option weniger = weniger Verwirrung.
Beste Grüße
Stefan
=========================
Booster: ORD-1 + Delta6604
Loconet MGV85, 50, 93,76,77,136
Server: DDX, Kubuntu14.04 auf PIII (2GB-RAM)
Client: Kubuntu14.04 auf 2*Core i3 (3Monitore)
=========================
StefanF.
 

Next

Return to Automatikbetrieb (DE)