Weiche stellt sich nicht immer

Re: Weiche stellt sich nicht immer

Postby rjversluis » 10.10.2017, 18:33

Moin,

im Automatik Modus kommen die schalt Befehle schnell hinten ein ander.
Viel DCC Decodern verkraften das nicht und deswegen muss man die Pausen zwischen den Befehle erhöhen.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Weiche stellt sich nicht immer

Postby Mobahner66 » 10.10.2017, 18:56

rjversluis wrote:Moin,

im Automatik Modus kommen die schalt Befehle schnell hinten ein ander.
Viel DCC Decodern verkraften das nicht und deswegen muss man die Pausen zwischen den Befehle erhöhen.


Wo kann ich diese Pause denn einstellen?

Lg Roman
Mobahner66
 

Re: Weiche stellt sich nicht immer

Postby UZi » 10.10.2017, 19:00

Hallo, Roman,

guckst du hier.

Liebe Grüße
Ulf!
UZi
 

Re: Weiche stellt sich nicht immer

Postby peters » 10.10.2017, 19:08

Hallo zusammen,

nun drehen wir uns aber im Kreis, das hatten wir ganz am Anfang schon ausreichend besprochen und Roman hat die "Schaltzeit für Fahrstraßen" schon bis zu 1500 ms hochgedreht :roll:
Last edited by peters on 12.10.2017, 14:48, edited 1 time in total.
Viele Grüße
Stefan

2 Leiter DCC, z21, Multimaus, WlanMaus, 10764 als Booster an B-Bus, Rückmeldung LDT GBM 8/DR4088CS via S88N an DR4088RB-CS an R-Bus, analoger Anlagenteil, Roco Standard Gleis und Piko A-Gleis, Rocrail
peters
 

Re: Weiche stellt sich nicht immer

Postby Mobahner66 » 10.10.2017, 19:55

peters wrote:Hallo zusammen,

nun drehen wir uns aber im Kreis, das hatten wir ganz am Anfang schon ausreichend besprochen und Roman hat die "Schaltzeit für Fahrstraßen" schon bis zu 1500 ms hochgedreht :roll:

Viele Grüße
Stefan


Hallo, ja stimmt. Aber diese Einstellung habe ich noch nicht verändert. Ich habe die "Schaltzeit" auf 1500ms gestellt und die "Schaltzeit für Fahrstrasse" höher gestellt. Sowie unter Weiche (Reiter:Schnittstelle) die Schaltzeit auf 350ms und 550ms gestellt. Auch unter "Zentrale, z21) die Schaltzeit auf 750ms gestellt. Aber noch nicht die Pause bei Weicheninitialisierung.

Der Wahnsinn für mich als Laien ist, dass man unter dreit oder vier verschiedenen Stellen die "SCHALTZEIT" einstellen kann.
Mobahner66
 

Re: Weiche stellt sich nicht immer

Postby RainerK » 10.10.2017, 20:40

Hallo Roman,

die SCHALTZEIT ist eben nicht immer und überall die Schaltzeit.
Die "Schaltzeit für Fahrstraße" ist nämlich gar keine Schaltzeit.
Das ist der Zeitabstand zwischen den einzelnen Befehlen an die Objekte,
für die in der Fahrstraßen-Registerkarte ein Befehl definiert ist.
Die "Schaltzeit für Fahrstraße" ist also:
Beginn der Weichenschaltzeit + Pause bis zum Beginn der nächsten Weichenschaltzeit
Best Regards, es grüßt RainerK

DCC++ with Arduino Uno / Motor shield and LocoNet GCA85, 50, 93 and 136. Special interests: DIY electronic assemblies. http://www.rainermoba.blogspot.com
RainerK
 

Re: Weiche stellt sich nicht immer

Postby Mobahner66 » 12.10.2017, 09:14

RainerK wrote:Hallo Roman,

die SCHALTZEIT ist eben nicht immer und überall die Schaltzeit.
Die "Schaltzeit für Fahrstraße" ist nämlich gar keine Schaltzeit.
Das ist der Zeitabstand zwischen den einzelnen Befehlen an die Objekte,
für die in der Fahrstraßen-Registerkarte ein Befehl definiert ist.
Die ist also:
Beginn der Weichenschaltzeit + Pause bis zum Beginn der nächsten Weichenschaltzeit



Verstehe, danke!

Also ich habe die "Schaltzeit für Fahrstraße" jetzt auf 2000, 3000 und sogar 5000 erhöht. Auch die "Pausen bei Weicheninitialisierung" habe ich diesem Wert angepasst. So wie es in der Beschreibung steht. Ich habe auch die Funktion "Synchronisierte Fahrstraße" und die zugehörige "Zeitüberschreitung bei synchronisierten Fahrstraßen" auf 500 und 1000 hochgestellt. Also so dass wirklich immer nur EINE Fahrstrasse und diese auch extrem langsam gestellt wird. Züge warteten somit auch immer im vorigen Block bis die weitere Fahrstraße für sie gestellt wurde. Aber, egal was ich auch einstelle und egal wie langsam die Kommandos hintereinander folgen, es wird immer wieder vom Switchpilot eine Weiche vergessen zu stellen. Fatal wenn es sich eben um eine Einfahrtsweiche des Schattenbhfs handelt ---> Zugcrash.

Sämtliche "Schaltzeiten" (unter Zentrale "z21" auf 550ms, unter "Automatik" 350 und 550ms, unter "Weichen" 350, 550ms) zu erhöhen brachte ebenfalls keinen Erfolg.

Ich habe auch schon den gesamten Fuhrpark (wegen ev störender Decoder) auf der Anlage ausgetauscht.

Ich weiß nicht mehr weiter.
Mobahner66
 

Re: Weiche stellt sich nicht immer

Postby peters » 12.10.2017, 10:21

Hallo Roman,

wir können nun feststellen, dass sämtliche Schaltzeiten und auch Pausen zwischen den Schaltzeiten lang genug eingestellt wurden von dir, daran kann es nun nicht mehr liegen. Du willst ja auch nicht den Ablauf auf der Anlage extrem verzögern. Auch die z21 vergisst normalerweise keine Signale, dies kann ich dir versichern denn ich habe 2 Stück davon im Einsatz.

Wenn du nur DCC in der z21 benötigst, würde ich mal das MM Protokoll im Maintenance Tool ausschalten, das minimiert die Befehle am Gleis. Weiterhin kannst du dort auch Railcom ausschalten, wenn du es nicht verwendest. All dies minimiert Einflüsse auf das Gleissignal, sofern du diese Funktionen nicht brauchst dann lieber ausschalten.

Leider kenne ich mich mit den Switchpiloten Servo nicht weiter aus, würde aber testweise ein temporäres zweipoliges Kabel direkt von der z21 an zumindest einen dieser Teile legen um sicher zu stellen, dass der Befehl auch wirlich da ankommt und das Signal nicht verfälscht wird. Wenn das etwas bringt, dann muss für die Schaltdecoder eine extra Leitung gelegt werden (eventuell extra Booster), wie dies vielfach vorgeschlagen wird.

Du kannst auch einen anderen Servodecoder versuchen, eventuell den von Digikeijs (DR4024), dieser ist recht preisgünstig.
Last edited by peters on 12.10.2017, 14:48, edited 1 time in total.
Viele Grüße
Stefan

2 Leiter DCC, z21, Multimaus, WlanMaus, 10764 als Booster an B-Bus, Rückmeldung LDT GBM 8/DR4088CS via S88N an DR4088RB-CS an R-Bus, analoger Anlagenteil, Roco Standard Gleis und Piko A-Gleis, Rocrail
peters
 

Re: Weiche stellt sich nicht immer

Postby RainerK » 12.10.2017, 14:29

Hallo Roman,

IMHO gibt es noch Möglichkeiten, die hier - wenn ich richtig mitgelesen habe - noch nicht erwähnt wurden.
1. Die Reihenfolge der Weichen-Befehle in der Registerkarte Fahrstraßen-Befehle ändern.
2. Den Befehl für die Problem-Weiche mehrmals (z.B. am Anfang und am Ende der Befehle) eintragen.
3. Die Option http://wiki.rocrail.net/doku.php?id=roc ... eichenlage deaktivieren.
Best Regards, es grüßt RainerK

DCC++ with Arduino Uno / Motor shield and LocoNet GCA85, 50, 93 and 136. Special interests: DIY electronic assemblies. http://www.rainermoba.blogspot.com
RainerK
 

Re: Weiche stellt sich nicht immer

Postby Mobahner66 » 12.10.2017, 18:03

peters wrote:Hallo Roman,

Wenn du nur DCC in der z21 benötigst, würde ich mal das MM Protokoll im Maintenance Tool ausschalten, das minimiert die Befehle am Gleis. Weiterhin kannst du dort auch Railcom ausschalten, wenn du es nicht verwendest. All dies minimiert Einflüsse auf das Gleissignal, sofern du diese Funktionen nicht brauchst dann lieber ausschalten.



BINGO! Ich will es nicht verschreien, aber das könnte es gewesen sein, bzw geholfen haben! Ich habe mit dem Maintenance Tool das MM Protokoll deaktiviert, sowie Railcom ausgeschaltet. Was mir plötzlich auch gleich auffiel, das Gleisbild flackert nun nicht mehr. Also es war seither so, dass im Automatikbetrieb zeitweise das Gleisbild flackerte. Dies tritt nun plötzlich auch nicht mehr auf. UND ich habe nun bereit 2 sehr lange Probebetriebe durchgeführt, jeweils bis zu 30-40 Minuten und das Problem trat tatsächlich derweilen nicht mehr auf. Ich hoffe es so sehr, dass ich nun von dem verschont bleibe.

Herzlichen Dank an alle die mir immer wieder versuchten zu helfen.
Mobahner66
 

Re: Weiche stellt sich nicht immer

Postby Mobahner66 » 12.10.2017, 18:04

RainerK wrote:Hallo Roman,

IMHO gibt es noch Möglichkeiten, die hier - wenn ich richtig mitgelesen habe - noch nicht erwähnt wurden.
1. Die Reihenfolge der Weichen-Befehle in der Registerkarte Fahrstraßen-Befehle ändern.
2. Den Befehl für die Problem-Weiche mehrmals (z.B. am Anfang und am Ende der Befehle) eintragen.
3. Die Option http://wiki.rocrail.net/doku.php?id=roc ... eichenlage deaktivieren.


Danke Rainer, die könnte ich mir dann auch noch ansehen. Wenn es doch noch Probleme gibt.

Lg Roman
Mobahner66
 

Re: Weiche stellt sich nicht immer

Postby peters » 13.10.2017, 10:25

Hallo Roman,

dann hoffe auch ich, dass nun die Weichenschaltung immer klappt. Zur Sicherheit hier noch die Frage ob deine Firmware auf der z21 aktuell ist (mindestens v1.29, es gibt sogar schon v1.30)? Kann man auch mit dem Maintenance Tool upgraden und schadet normalerweise nicht, hast du jedoch bestimmt bereits erledigt.
Viele Grüße
Stefan

2 Leiter DCC, z21, Multimaus, WlanMaus, 10764 als Booster an B-Bus, Rückmeldung LDT GBM 8/DR4088CS via S88N an DR4088RB-CS an R-Bus, analoger Anlagenteil, Roco Standard Gleis und Piko A-Gleis, Rocrail
peters
 

Re: Weiche stellt sich nicht immer

Postby Mobahner66 » 13.10.2017, 17:45

Hallo!

Zu früh gefreut. Es passiert nach wie vor. Die Häufigkeit hat sich verringert. Manchmal schaffte ich es 30 Minuten lang den Automatikbetrieb laufen zu lassen, ohne dass es auftrat. Dann passiert es aber manchmal auch bereits nach wenigen Runden schon.

Ja habe die 1.29er Version auf der z21.

Vielleicht veruche ich mal den Tipp mit den Weichenschaltfolgen.

lg
Mobahner66
 

Re: Weiche stellt sich nicht immer

Postby Mobahner66 » 16.10.2017, 09:20

Nun ja, nach weiteren unzähligen Testfahrten: Es nimmt kein Ende. Manchmal funktionierts eine halbe Stunde lang, dann wieder bereits bei der ersten Fahrt...Weiche vergessen zu stellen, bumm...Crash.
Habe die Weichenabfolge in den Fahrtrassen geändert und die Problemweichen doppelt dort eingetragen. Bringt nix.

Im Anhang noch mal eine Issue Dateit, vl fällt ja noch irgendwem was ein.
You do not have the required permissions to view the files attached to this post.
Mobahner66
 

Re: Weiche stellt sich nicht immer

Postby peter&basti » 16.10.2017, 09:50

Hallo Roman,

wir können meiner Meinung nach davon ausgehen, dass Rocrail den Stellbefehl für die Weiche richtig aussendet. Sonst wäre Dei Problem ein generelles Problem :wink:
Das Thema Stellzeit und Abstand zwischen den Stellbefehlen wurde schon ausführlich besprochen.

DIe Rocrail traces werden daher vermutlich nicht viel zu einer Lösung beitragen.

Das DCC Signal kommt in diesem Fall direkt von der Zentrale. Hängt an einem Verteiler...von dem dann auch weiter zu den Gleisen und zu den Viessmann WeichenDecodern sowie zu den Frog Juicern gegangen wird.


Wurde die Verkabelung schon betrachtet?

- Welche Kabel verwendest Du?
- wie lange sind die Kabel zu den Weichendecodern?
- liegen andere Kabel parallel?

Ich habe noch einen Verdacht:

Initialisierst Du Deine Anlage bei Betriebsbeginn?
http://wiki.rocrail.net/doku.php?id=roc ... iebsbeginn

Bei diesem Vorgang werden alle Weichen zweimal gestellt und es ist sicher gestellt, dass alle Weichen so stehen wie in RR angezeigt.
Falls nicht, dann meint RR, dass eine Weiche richtig steht (physikalisch aber eben nicht) und diese nicht schaltet.
Auch dies kann früher oder später zu einem Crash führen - je nachdem, wann die Automatik erstmals eine Fahrstraße über diese Weiche wählt.

Nachbemerkung: ich verwende für das Stellen der Weichen eine gesonderte Zentrale / einen gesonderten Weg. Früher Loconet, jetzt RocNet.
Eine nicht gestellte Weiche ist in den letzten 5 Jahren nie passiert.
Liebe Grüße / best regards
Peter


System: DCC 2-Leiter H0, Rocrail Win10 Pro 64
Traktion: GBMBoost & GBM16T, RailCom
Fahrweg: RocNetNode & GCA PI01/2/3, GCA41/Arduino RFID, GCA145 Drehscheibe, etc.
Lokdecoder: 99% Zimo
peter&basti
 

PreviousNext

Return to Automatikbetrieb (DE)