[Erl.] Kritischer Abschnitt geht nicht mit Aufstellblock

[Erl.] Kritischer Abschnitt geht nicht mit Aufstellblock

Postby habbi2002 » 04.01.2018, 18:54

Moin.

Ich würde gerne einen "kritischen Abschnitt" definieren deren "Freie Blöcke" ein Aufstellblock ist. Meine Versuche haben gezeigt das dies nicht geht. Obwohl der Aufstellblock leer ist, wird der kritische Abschnitt nicht zum Befahren freigegeben. Geht das grundsätzlich nicht oder muss man irgendwas besonders berücksichtigen? Danke.

LG
Wolfgang
Last edited by habbi2002 on 13.01.2018, 17:14, edited 1 time in total.
[Win10,andRoc] [H0,3L,K-Gleis] [IB1,USB-loconet,HSI88,Arduino:MM][Weichen:MM, Loks&Signale:DCC]
habbi2002
 

Re: Kritischer Abschnitt geht nicht mit Aufstellblock

Postby habbi2002 » 10.01.2018, 20:49

Hallo,

hat jemand eine Idee wie das geht?

Danke

LG Wolfgang
[Win10,andRoc] [H0,3L,K-Gleis] [IB1,USB-loconet,HSI88,Arduino:MM][Weichen:MM, Loks&Signale:DCC]
habbi2002
 

Re: Kritischer Abschnitt geht nicht mit Aufstellblock

Postby GeSchu » 11.01.2018, 07:13

Moin Wolfgang,
habbi2002 wrote:Ich würde gerne einen "kritischen Abschnitt" definieren deren "Freie Blöcke" ein Aufstellblock ist. Meine Versuche haben gezeigt das dies nicht geht. Obwohl der Aufstellblock leer ist, wird der kritische Abschnitt nicht zum Befahren freigegeben. Geht das grundsätzlich nicht oder muss man irgendwas besonders berücksichtigen?

Ein Aufstellblock kann nur in einer Richtung befahren werden. Hier kann sich also nichts festfahren.
Zum kritischen Abschnitt steht im WIKI:
Code: Select all
Ein kritischer Abschnitt bewahrt zwei Lokomotiven vor einem gegenseitigen Blockieren, wenn sie versuchen von gegenüber liegenden Enden in eine eingleisige Hauptstrecke einzufahren.
Das ist in einem Aufstellblock nicht möglich.
Jetzt meine Frage dazu: Warum sollte dein Vorhaben also funktionieren?
Stelle doch bitte mal Deinen Plan hier ein, oder besser: Erstelle ein Minimalbeispiel und stelle uns dieses zur Verfügung. Schildere genau Dein Vorhaben. Vielleicht findet sich eine Lösung dafür.
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian jessie; Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Kritischer Abschnitt geht nicht mit Aufstellblock

Postby habbi2002 » 11.01.2018, 17:07

Hallo Gerd,

vielen Dank für die Antwort. Du hast recht wenn der Aufstellblock Teil des kritischen Abschnitt seien sollte. Das ist aber nicht mein Ziel. Sonder um in die Blockgruppe (als kritscher Abschnitt markiert) einfahren zu können, sollte ein Aufstellblock NACH dem Abschnitt frei sein. Dies sind in Rocrail -> Blockgruppen -> Bedingungen die "Freien Blöcke", für die man "Reservieren" markieren muss.
"Freie Blöcke" : Eine komma-getrennte Liste von Blöcken. Einer dieser Blöcke muss frei sein, um zu ermöglichen, dass die Blockgruppe reserviert werden kann.

Und genau das klappt für Aufstellblöcke bei mir nicht.

Ich hoffe es nun etwas verständlicher beschrieben zu haben. Ansonsten lege ich mal meinen Plan bei (gearde nicht zu Hand).

LG
Wolfgang
[Win10,andRoc] [H0,3L,K-Gleis] [IB1,USB-loconet,HSI88,Arduino:MM][Weichen:MM, Loks&Signale:DCC]
habbi2002
 

Re: Kritischer Abschnitt geht nicht mit Aufstellblock

Postby rjversluis » 11.01.2018, 17:14

Hallo Wolfgang,

ist dann der AB schon komplett belegt?
Hänge doch mal ein minimal Beispiel an womit man dein anliegen nachstellen kann.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Kritischer Abschnitt geht nicht mit Aufstellblock

Postby RedTrain » 11.01.2018, 18:34

Hallo allerseits

Ich hatte mal einen ShBf mit 6 AB Gleisen, je 3 in die eine Richtung und 3 in die andere Richtung. Da hat in den Zufahrten "kritischer Abschnitt plus Bedingung 1 freies AB-Gleis in dieser Richtung" funktioniert. (In der Zwischenzeit habe ich umkonfiguriert und verwende alle 6 AB-Gleise in die gleiche Richtung).
Allerdings, ich weiss nicht mehr wie das läuft, wenn alle AB-Gleise teilweise belegt sind, aber für den Zug noch genügend lange freie Abschnitte in einem AB-Gleis vorhanden wären.
Vielleicht ist das der Punkt?
Beste Grüsse / kind regards - Carlo

[H0m 2L DCC] Layout "Rhaetian Flyer" Proto-Freelance Swiss Meter Gauge RhB, FO, zB; 6% complete
Rocrail W10, Ubuntu 16.04, Rocweb, andRoc; CANbus GC1e, GC3, GC2, ORD-3, Servo-Arduino, ESU; Peco, Bemo
RedTrain
 

Re: Kritischer Abschnitt geht nicht mit Aufstellblock

Postby halakerk » 11.01.2018, 22:25

Hallo Zusammen,

ich habe folgende Konfiguration: Ein Streckenblock, in dem kein Zug halten soll, anschließend 3 parallele Aufstellblöcke im Schattenbahnhof. Der Streckenblock ist der kritische Abschnitt, die Aufstellblöcke (nicht die Abschnitte) sind unter "muss frei sein" eingetragen. Rocrail berücksichtigt dann die freien Abschnitte automatisch entsprechend den Zuglängen. Sogar die Option "wähle kürzesten Block" funktioniert. Hier berücksichtigt Rocrail anscheinend auch die Länge der freien Abschnitte.

Grüße vom Niederrhein
Hartmut
Spur N, 2x GBMBoost, 4xGBM16T, 2xKuehn WD10, 2xDigikeijs DR4018, Digikeijs DR4024, 2x Raspi3, Rocrail, Multimaus, WLanmaus
halakerk
 

Re: Kritischer Abschnitt geht nicht mit Aufstellblock

Postby habbi2002 » 12.01.2018, 19:48

Hallo

und vielen Dank für die Antworten.

@Rob: Es stehen 4 Aufstellblöcke zur Verfügung, einer ist komplett leer und der Zug fährt hinein wenn kein kritischer Abschnitt defniert ist.
@Hartmut: genau das klappt bei mir nicht :( :(

Habe mal den issue file angehängt.

Zur Orientierung:
- kritischer Abschnitt sind die Blöck kfs0 und kfs0a.
- Lok E460 kommt von Block kfs1
- Ziel sind die Aufstellblöcke s01,s02,s03 und s04. s03 ist komplett leer und länger als der Zug. s01,s02,s03,s04 sind im kritschen Abschnitt eingetragen
- Automatik mode ohne Aktionen! Lok starten
- Ergebnis: "20180112.193629.409 r4205W 00001168 OLcDrive 0150 could not lock blockgroup [kfs0-kfs0a] for [E460]". :shock:

Was mache ich falsch? :?:

LG Wolfgang

-
You do not have the required permissions to view the files attached to this post.
[Win10,andRoc] [H0,3L,K-Gleis] [IB1,USB-loconet,HSI88,Arduino:MM][Weichen:MM, Loks&Signale:DCC]
habbi2002
 

Re: Kritischer Abschnitt geht nicht mit Aufstellblock

Postby cds » 12.01.2018, 20:00

Hallo!

Bitte mal updaten, du benutzt 13184, aktuell ist 13390.

Bei Blockgruppen gab es in letzter Zeit Korrekturen.
Beste Grüße/Kind regards
Claus

M* H0 M
HW: TAMS MC, B-2 & B-4, WD-34, VIESSMANN 5211(1), LITTFINSKY & TAMS S88-3
Decoder: Mä & TAMS (MM2)
SW: Win7 64, RR 64, andRoc
cds
 

Re: Kritischer Abschnitt geht nicht mit Aufstellblock

Postby habbi2002 » 13.01.2018, 17:14

Hallo.

Die Korrekturen in der letzter Zeit waren super. Mit 13395 klappt es. Danke.

:beer:

LG Wolfgang
[Win10,andRoc] [H0,3L,K-Gleis] [IB1,USB-loconet,HSI88,Arduino:MM][Weichen:MM, Loks&Signale:DCC]
habbi2002
 

Re: [Erl.] Kritischer Abschnitt geht nicht mit Aufstellblock

Postby rjversluis » 13.01.2018, 17:30

Hi Wolfgang,

schön das es jetzt klappt. :beer:

Aber bitte beim nächste Problem erst Rocrail aktualisieren.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 


Return to Automatikbetrieb (DE)