p50: Verzögert Rocrail sehr lange wenn CTS nicht da ist...

p50: Verzögert Rocrail sehr lange wenn CTS nicht da ist...

Postby Maxima » 22.01.2018, 09:32

plan.xml
rocrail_4_nachp50.ini
rocrail.002.trc
rocrail.004.trc
rocrail_2_in den Eigenschaften_ohne Aenderung hinaus.ini
Hallo,
folgendes Problem:
Ich arbeite seit längerem mit dem Built 11783 vom 22.12.2016. Nun wollte ich das Ganze mal auf eine aktuelle Version updaten, hierzu wurde Built 13416 vom 16.1.2018 installiert.
Nun habe ich das Problem, daß die Software hängen bleibt in dem Moment in dem von Rocview der Arbeitsbereich aufgerufen wird und der Server startet.
Ich habe nun die ganzen Rocrail.ini und Rocrail.trc herausgelöscht. Daraufhin startet der Plan und der Server.
Versuche ich nun aber in den Rocrail Eigenschaften die Zentrale einzustellen (ich habe eine Märklin 6021, dh ich wähle wie bisher p50 aus), speichere das und starte die Software neu, bleibt er wieder nach dem Aufruf des Arbeitsbereich hängen.
Ich habe das getestet auf meinem Eisenbahnrechner mit Win XP sowie auf einem neuen Laptop mit Win 10, das Verhalten ist identisch.

Ich hoffe ihr könnt mir helfen.
Vielen Dank.
Gruß
You do not have the required permissions to view the files attached to this post.
Maxima
 

Re: Umstieg Rocrail Built 22.12.2016 auf 16.1.2018 klappt ni

Postby rjversluis » 22.01.2018, 09:40

Moin,

ich kann das Problem mit deine Dateien nicht nachstellen, ich habe auch kein p50 Zentrale zum testen.

In die beide traces wird der Rocrail Server normal beendet, und da gibt es kein p50 Zentrale.

Wenn du der Rocrail Server manuell startest, klappt dann der Verbindung mit Rocview?

BTW: Warte nicht so lange mit Rocrail updaten.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Umstieg Rocrail Built 22.12.2016 auf 16.1.2018 klappt ni

Postby Maxima » 11.02.2018, 18:17

Hallo,
ich habe nun etwas herumprobiert.
Du brauchst keine p50 Zentrale zum testen, es reicht wenn du sie in Rocrail einrichtest (siehe Anlage p50.jpg und Anlage p50-2.jpg).
Wenn du den Arbeitsbereich mit dem Plan aufrufst dann funktioniert das toll mit der virtuellen Zentrale, mit ecos oder hsi-1, wenn du dann p50 als Standard wählst dann bleibt Rocview hängen.
Wenn ich nun aus der plan-Datei die Signale (sg-list) in der xml-Datei herauslösche dann funktioniert alles auch mit p50 (aber halt ohne Signale).

Daraufhin dachte ich, ich lösche die Signale aus der xml Datei heraus und vervollständige dann in Rocview alles wieder --> gleiches Ergebnis Rocview bleibt wieder hängen.

Irgendetwas verträgt sich hier in der Kombination p50, neuer bulit , Signale nicht.

Ich habe keine Idee was ich sonst noch machen könnte.

PS ich habe auch probiert den Server zuerst zu starten, das ändert aber nichts Rocview bleibt auch dann hängen wenn p50 und Signale zusammen sind.
You do not have the required permissions to view the files attached to this post.
Maxima
 

Re: Umstieg Rocrail Built 22.12.2016 auf 16.1.2018 klappt ni

Postby Schorse » 11.02.2018, 18:34

Hallo Maxima,

in Deiner geposten Rocrail.ini sind zwei Zentralen eingetragen, eine "6021" und eine"NEW", beide sollen über com1 kommunizieren. Das geht nicht. Bitte mal das Chaos aufräumen. :)
Viele Grüße Gerd
Schorse
 

Re: Umstieg Rocrail Built 22.12.2016 auf 16.1.2018 klappt ni

Postby Maxima » 11.02.2018, 20:00

Hallo,
Du hast recht, das war etwas durcheinander.
Hier die Rocrail.ini die nur die p50 beinhaltet.
Das Problem ist das gleiche, ich habe hier alle möglchen Varianten probiert.
Gruß
Markus
You do not have the required permissions to view the files attached to this post.
Maxima
 

Re: Umstieg Rocrail Built 22.12.2016 auf 16.1.2018 klappt ni

Postby Schorse » 12.02.2018, 22:11

Hallo Maxima,

ich finde "Maxima" ist ein schöner Name für eine Lok, aber für ein Forumsmitglied? :)
Hast Du Rocview schon mal als Administrator (oder besser gesagt mit Administratorrechten) gestartet :?:
Viele Grüße Gerd
Schorse
 

Re: Umstieg Rocrail Built 22.12.2016 auf 16.1.2018 klappt ni

Postby rjversluis » 13.02.2018, 08:15

Moin Markus,

ich habe mal mit deine Dateien getestet, aber hier bleibt nicht hängen.
Es kommen wie erwartet Timeout Meldungen weil ich keine p50 Zentrale habe.

Du hast auch bist jetzt kein Trace angehängt wo ein P50 Zentrale drin ist...

Und beim initialisieren von Signalen kommt es zum Stau wenn der Zentrale Timeouts hat.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: p50, 6051, Hängt Rocrail auf.

Postby rjversluis » 13.02.2018, 10:47

Hi,

jetzt kann ich das Problem nachstellen wenn am COM Port nichts dran hängt...
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: p50, 6051, Hängt Rocrail auf.

Postby rjversluis » 13.02.2018, 11:02

Versuche es mit 13.547+.
Oder setze ctsretry auf 5 oder 10:

Code: Select all
<digint lib="p50" ctsretry="5" ...


Aber das Grundliegende Problem ist deine Zentrale welche nicht mehr Kommuniziert.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: p50, 6051, Hängt Rocrail auf.

Postby cds » 13.02.2018, 11:07

Hallo Rob!

Betrifft dies auch die p50x library?
Beste Grüße/Kind regards
Claus

M* H0 M
HW: TAMS MC, B-2 & B-4, WD-34, VIESSMANN 5211(1), LITTFINSKY & TAMS S88-3
Decoder: Mä & TAMS (MM2)
SW: Win7 64, RR 64, andRoc
cds
 

Re: p50, 6051, Hängt Rocrail auf.

Postby rjversluis » 13.02.2018, 11:19

Moin Claus,

nein, der p50x Library ist davon nicht betroffen.

Eigentlich sollte diese p50 Unterstützung mal entsorgt werden. Das so viele sich da noch mit herumschlagen muss man nicht verstehen.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: p50: Verzögert Rocrail sehr lange wenn CTS nicht da ist.

Postby Maxima » 13.02.2018, 20:30

Hallo,
also ich habe das getestet. Wenn der Com port belegt ist, ist es wichtig bevor man den Arbeitsbereich öffnet die Anlage über das Steuerpult manuell einzuschalten, so daß der Com port auch Strom hat, dann funktioniert das ohne Probleme.
Ich habe auch ctsretry="5" getestet. Dies funktioniert prinzipiell auch (da muß die Anlge nicht vorher angeschaltet werden), es produziert aber dauernd CTS failures und da weiß ich nicht welche Auswirkungen das hat. Beim kurzen Testen ist die Lok gefahren und alles hat geschalten.

Soweit also recht herzlichen Dank!!!

Nun zum Thema:
"Eigentlich sollte diese p50 Unterstützung mal entsorgt werden. Das so viele sich da noch mit herumschlagen muss man nicht verstehen."
Meine Frage: Habe ich eine andere Möglichkeit die 6021/6050 anzusteuern als mit p50?

Danke.

Gruß

PS: Den Namen "Maxima" habe ich deswegen gewählt, weil ich beruflich mit der Entwicklung der Lok zu tun hatte!
Maxima
 

Re: p50: Verzögert Rocrail sehr lange wenn CTS nicht da ist.

Postby rjversluis » 13.02.2018, 21:19

Maxima wrote:Nun zum Thema:
"Eigentlich sollte diese p50 Unterstützung mal entsorgt werden. Das so viele sich da noch mit herumschlagen muss man nicht verstehen."
Meine Frage: Habe ich eine andere Möglichkeit die 6021/6050 anzusteuern als mit p50?

nein, 6050 kann nur p50.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: p50: Verzögert Rocrail sehr lange wenn CTS nicht da ist.

Postby Maxima » 14.02.2018, 09:47

Ok, ich habe verstanden, daß die Lösung mit 6051/6021 und p50 ist nicht wirklich zukunftsfähig ist.

Was wäre eine zukunftsfähige und günstige Lösung die 6051/6021 zu ersetzen, ich verwende die 6021/6051 mit 3 Boostern und 3 Trafos sowie 6 Rückmeldemodulen.
Ich möchte natürlich nicht sinnlos Geld für eine CS2 oder CS3 ausgeben, da ich ja deren Funktionen nicht brauche.

Danke.
Gruß
Markus
Maxima
 

Re: p50: Verzögert Rocrail sehr lange wenn CTS nicht da ist.

Postby rjversluis » 14.02.2018, 10:03

Moin Markus,

ich will dir kein neues System aufdrängen, aber für Märklin käme zB der Tams RedBox im Frage. (Teilweise auch Unterstützung/Anbindung für ältere Märklin Geräte)
Ein CS2/3 würde ich auch nicht kaufen; Viel zu teuer und man braucht es nicht.

Es gibt jetzt doch ein Lösung für das Problem, also wenn du zufrieden mit dein Zentrale bist...
Das größte Problem bei p50 ist das es kein Richtungsangabe für Loks gibt, nur umschalten was undefiniert ist.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Next

Return to Zentralen (DE)

cron