Rocrail und Z21 Adressierung

Rocrail und Z21 Adressierung

Postby Rheingold1964 » 03.08.2014, 14:43

Hallo zunächst einmal. Nach langer Zeit der Abstinenz von der Modelleisenbahn ist mir nun beim Aufräumen des Dachbodens meine Eisenbahn wieder über den Weg gelaufen. Ergebnis: Mich hat wieder voll der "Virus" erwischt. :lol: Zu alle dem hab ich auch noch ne schwarze Z21 geschenkt bekommen. :D
Meine Frage nun: Durch stundenlanges Rumprobieren mit den Adressen für den DR4018 und des Nichtfunktionierenwollens bin ich darauf gekommen, das die in der Z21 programmierten Adressen für den DR4018 in Rocrail so nicht funktionieren. D. h. wenn der Decoder auf 250 liegt muss ich in Rocrail 249 eintragen. Also immer vergebene Adresse -1. Muss das so sein?
Oder hab ich da was übersehen/überlesen?
Rheingold1964
 

Re: Rocrail und Z21 und Digikeijs DR4018

Postby rjversluis » 03.08.2014, 18:33

Hallo,

ich habe deine Frage an den Roco Entwickler weiter geleitet.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Rocrail und Z21 und Digikeijs DR4018

Postby rjversluis » 04.08.2014, 10:54

Rheingold1964 wrote:D. h. wenn der Decoder auf 250 liegt muss ich in Rocrail 249 eintragen. Also immer vergebene Adresse -1. Muss das so sein?
Oder hab ich da was übersehen/überlesen?

Das ist in der Z21 Rocrail Unterstützung vergessen worden. Wenn ich das jetzt noch anpasse schreien alle andere Z21 Benutzer... :(
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Rocrail und Z21 und Digikeijs DR4018

Postby apolze » 20.09.2014, 21:16

rjversluis wrote:
Rheingold1964 wrote:D. h. wenn der Decoder auf 250 liegt muss ich in Rocrail 249 eintragen. Also immer vergebene Adresse -1. Muss das so sein?
Oder hab ich da was übersehen/überlesen?

Das ist in der Z21 Rocrail Unterstützung vergessen worden. Wenn ich das jetzt noch anpasse schreien alle andere Z21 Benutzer... :(


Hallo Rob,

Wie wär's mit einer Option für die Zentrale z21?
Das Problem ist ein Weichendekoder mit Adresse 1.
Trägt man in Rocrail für diesen Decoder Adresse 0 ein, so scheint zunächst alles zu funktionieren.
Allerdings ändern nun in Rocview alle Weichensymbole ihren Zustand wenn man Weiche 0 betätigt und die Bildschirmdarstellung wird inkonsistent.
(die Weichen selbst stellen sich zum Glück nicht)

Ärgerlich, wenn man Weichen auch über andere Geräte (route control, etc.) stellen will und dort Adressen mit 1 beginnend verwendet hat.

Viele Grüße,
Andreas.
apolze
 

Re: Rocrail und Z21 und Digikeijs DR4018

Postby rjversluis » 21.09.2014, 05:46

Moin Andreas,

ab 8006 kannst du im Feld Version > 0 setzen und damit wird die Accessory Addressing None-Zero-Based.
(Server muss neu gestartet werden.)
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Rocrail und Z21 Adressierung

Postby rjversluis » 21.09.2014, 05:52

An alle Z21 Benutzer:

Bitte alle umstellen auf "Nicht Null" basierte adressierung sodass es standard gemacht werden kann.
http://wiki.rocrail.net/doku.php?id=roc ... en#version
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Rocrail und Z21 Adressierung

Postby apolze » 26.09.2014, 20:58

rjversluis wrote:Moin Andreas,

ab 8006 kannst du im Feld Version > 0 setzen und damit wird die Accessory Addressing None-Zero-Based.
(Server muss neu gestartet werden.)


Hallo Rob,

sehr super!
(Schaut man mal ein paar Tage nicht hin...)

Nun habe ich nur noch einen Wunsch: kannst Du bitte mal wieder eine neue Version für OS X 10.5.8 (Leopard (Intel)) bauen?
Dort steht nur die 7945 zum Herunterladen bereit.

Einen schönen Abend,
Andreas.
apolze
 

Re: Rocrail und Z21 Adressierung

Postby rjversluis » 26.09.2014, 21:02

apolze wrote:Nun habe ich nur noch einen Wunsch: kannst Du bitte mal wieder eine neue Version für OS X 10.5.8 (Leopard (Intel)) bauen?

Leopard ist schon Jahren aus der Wartung; Mache mal ein Update auf Mavericks.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Rocrail und Z21 Adressierung

Postby apolze » 26.09.2014, 21:20

rjversluis wrote:
apolze wrote:Nun habe ich nur noch einen Wunsch: kannst Du bitte mal wieder eine neue Version für OS X 10.5.8 (Leopard (Intel)) bauen?

Leopard ist schon Jahren aus der Wartung; Mache mal ein Update auf Mavericks.


Na ja, alter Rechner, dann habe ich noch einen PPC mit 10.5.8 und gemeinsamer iPhoto-Bibliothek, etc.
Und: "Nicht in laufende Maschinen greifen" - im Augenblick ist die Welt auf dem Rechner ja in Ordnung :)

Viele Grüße,
Andreas.
apolze
 

Re: Rocrail und Z21 Adressierung

Postby DorSachse » 12.02.2015, 23:05

..darf ich mich hier mal einklinken?

Bisher hat unser Rocrail-Server auf RaspPi in Kombination mit einer Multimauszentrale und einem LI-USB-Interface gewerkelt. Nun haben wir auf z21 (die Schwarze) und Netzwerkkopplung umgestellt. Seither kann ich keine Weichen mehr schalten, was mit der Multimauszentrale noch perfekt klappte. Wir haben über 40 Weichen im Betrieb und ich hoffe, dass ich das alles nicht neu programmieren muß, oder doch?

Gruß, Torsten
DorSachse
 

Re: Rocrail und Z21 Adressierung

Postby rjversluis » 13.02.2015, 12:34

Hallo Torsten,
DorSachse wrote:ich hoffe, dass ich das alles nicht neu programmieren muß, oder doch?

Nein. Aber es kann nur sein das du die Weichen Adressierung anpassen muss in Rocrail.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Rocrail und Z21 Adressierung

Postby DorSachse » 13.02.2015, 13:21

rjversluis wrote:...Nein. Aber es kann nur sein das du die Weichen Adressierung anpassen muss in Rocrail.


Hallo Rob,
kannst Du mir sagen, was da zu tun ist? Umstellung von "Default" auf NMRA-DCC oder bin ich da auf der falschen Spur?
DorSachse
 

Re: Rocrail und Z21 Adressierung

Postby rjversluis » 13.02.2015, 14:06

DorSachse wrote:kannst Du mir sagen, was da zu tun ist? Umstellung von "Default" auf NMRA-DCC oder bin ich da auf der falschen Spur?

Hier steht es:
http://wiki.rocrail.net/doku.php?id=roc ... ressierung
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Rocrail und Z21 Adressierung

Postby wz2000 » 22.01.2016, 22:50

Aufbauend auf dieses Thema habe ich auch ein Adressierungsproblem - und komme nach stundenlangem Probieren leider zu keiner Lösung.
Ich bin von Lokmaus 2 auf z21 umgestiegen. Loks funktionieren einwandfrei.
Nur die Signale (Decoder Littfinski LS-DEC-ÖBB im DCC-Mode) funktionieren nicht mehr (Weichen stelle ich mit Selectrix, also kann ich das nicht testen...).

Entweder liegt es an der Adressierung oder an sonstigen z21-Einstellungen in Rocrail:

** Adressierung: lt. http://wiki.rocrail.net/doku.php?id=addressing-de muss für z21 ja FADA verwendet werden.
Der Decoder hat z.B. die Adresse 73 programmiert.
LT. FADA ergeben sich dafür 576 bis 583, richtig? Wie sind die bei der Signaleinstellung/Schnittstelle einzugeben? (4-begriffiges Signal)
Rot: 576
Grün: 578
Gelb: 580
Weiß: 582
- Eingabe der Werte bei Adresse, Port überall 0 (lt. http://wiki.rocrail.net/doku.php?id=roco:roco-z21-de)

** sonstige Einstellungen
- Version (bei Einstellungen Zentrale): 1 (also größer 0)
- was gehört bei der Signaleinstellung ins Feld "Bus": 1 ? (lt. http://wiki.rocrail.net/doku.php?id=roco:roco-z21-de) - in diesem Thread steht zu lesen dass es dann mit der Port-Einstellung 21105 im Feld Bus funktionierte !?!? (bei mir auch nicht)

Ich habe ehrlich gesagt keine Idee mehr, bin für jede Hilfe dankbar.
Danke, wz2000
wz2000
 

Re: Rocrail und Z21 Adressierung

Postby Besra » 22.01.2016, 23:31

wz2000 wrote:Der Decoder hat z.B. die Adresse 73 programmiert.
LT. FADA ergeben sich dafür 576 bis 583, richtig?

Hallo,

ich glaube nicht, würde es mit 289 bis 296 versuchen. (Nach meiner - rudimentären - Kenntnis des z21/Z21-Adress-Schemas wird nach PADA-Art adressiert, aber im Adress-Feld wie bei BiDiB; "flache" Adressierung, aber eigentlich nicht FADA). Näheres zur Adressierung von Zubehördekodern hier und zur Signaleinrichtung hier.

Grüße
Besra
Maerklin H0, DCC and MM, Intellibox (I) via ULNI, Booster Tams B4, Throttle Digitrax UT4, LocoNet.
Loco decoders: Zimo, Uhlenbrock, Maerklin & ESU.
Rocweb, Win10 32bit & 64bit
Besra
 

Next

Return to Zentralen (DE)