[Issue] OCC not saving loc position (every other time)

Moderators: dadolphs, Moderators

[Issue] OCC not saving loc position (every other time)

Postby rvooyen » 11.10.2017, 11:30

Hi,

I report an issue I have now seen for a year or more, but it is so minor I have not bothered reporting it.

The issue is that Rocrail is not saving one of my loc positions in OCC so that on restarting Rocrail it does not show and I have to add it to the block again manually.

It is loc Mat46 that is stored in block 66 in the plan.
It seems that every second time I start Rocrail the loc position is not saved.

So, I set the loc Mat46 in block 66 and save the plan and then exit Rocrail. I check OCC and it is saved.
I now start up Rocrail and the Mat46 is in block 66 as saved.
I now exit Rocrail and on checking OCC I see the Mat46 is NOT saved anymore.

I attach the two OCC files.
OCC1 is the file as saved first, showing the Mat46 in block 66.
OCC2 is the file after restarting Rocrail and the Mat46 has been removed/not stored in the file.

I have had this issue for perhaps a year or so. It is minor but a little annoying to manually have to replace the Mat46.

Regards,

Robert
You do not have the required permissions to view the files attached to this post.
Robert van Ooijen.
Building Rhineland2. 3 levels. CS=IB1-Loconet+HSI-s88, 70 blocks, 160 sensors, 4 boosters. M&K 3rail.
Goal: Scheduled Pass. trains, "OPS" with car cards etc.. Using andRoc and Rocweb/xs throttles.
Rocrail on WinXP.
rvooyen
 

Re: [Issue] OCC not saving loc position (every other time)

Postby rjversluis » 11.10.2017, 12:06

Hi Robert,

is this only this MAT46 train?
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: [Issue] OCC not saving loc position (every other time)

Postby rvooyen » 11.10.2017, 14:17

Rob,

I checked more closely and it also happens to other locs.

The locs that were assigned to a block prior to closing Rocrail, but had not yet run in auto are not being saved on the second startup of Rocrail if they had still not run.

Besides the Mat46 I saw two other locs not being saved that were assigned to yard trains.
In fact if I think about it, all these (non-saved) locs are in TERMINAL blocks!

It appears that any loc manually assigned to a terminal block is not saved on starting Rocrail for a second time, if they have not run.

Hope this localises the issue.

Robert
Robert van Ooijen.
Building Rhineland2. 3 levels. CS=IB1-Loconet+HSI-s88, 70 blocks, 160 sensors, 4 boosters. M&K 3rail.
Goal: Scheduled Pass. trains, "OPS" with car cards etc.. Using andRoc and Rocweb/xs throttles.
Rocrail on WinXP.
rvooyen
 

Re: [Issue] OCC not saving loc position (every other time)

Postby rjversluis » 11.10.2017, 14:22

Robert,

sorry, I cannot confirm your observation.
Besides the loco block occupancy is also saved in the block properties in the plan.xml.
The occ.xml only overwrites the plan.xml occupancy in case of differences.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: [Issue] OCC not saving loc position (every other time)

Postby rvooyen » 11.10.2017, 15:31

It is a repeatable issue, at least on my plan.
Locs in a terminal block that have been manually assigned are not saved on the second Rocrail startup.

I have lived with this a long time, is a minor issue.

Greets

Robert
Robert van Ooijen.
Building Rhineland2. 3 levels. CS=IB1-Loconet+HSI-s88, 70 blocks, 160 sensors, 4 boosters. M&K 3rail.
Goal: Scheduled Pass. trains, "OPS" with car cards etc.. Using andRoc and Rocweb/xs throttles.
Rocrail on WinXP.
rvooyen
 

Re: [Issue] OCC not saving loc position (every other time)

Postby rjversluis » 12.10.2017, 13:57

Hi Robert,

I did some more testing, but with my small terminal-demo plan I cannot reproduce it.

Maybe you can create a small plan in which you can reproduce it?
That would be easier for me to fix it.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: [Issue] OCC not saving loc position (every other time)

Postby rvooyen » 12.10.2017, 17:58

I cannot reproduce the issue in virtual mode on my laptop with the same plan.

I will look further eg check path OCC etc.
Think it may have to do with loconet (guess) since that is the only difference with virtual.

Will check everything again later.

Robert
Robert van Ooijen.
Building Rhineland2. 3 levels. CS=IB1-Loconet+HSI-s88, 70 blocks, 160 sensors, 4 boosters. M&K 3rail.
Goal: Scheduled Pass. trains, "OPS" with car cards etc.. Using andRoc and Rocweb/xs throttles.
Rocrail on WinXP.
rvooyen
 

Re: [Issue] OCC not saving loc position (every other time)

Postby rvooyen » 12.10.2017, 21:42

OK some more info.

I have just started up Rocrail. I see that the three locs in the terminal blocks are showing on the plan correctly.
Mat46, NS 1117 and DB 232-100.

HOWEVER I see in the OCC already that these locs are not saved and have already been removed - right at startup.
I have immediately made an issue file at this point.

So on the FIRST startup the locs are shown in the plan correctly but are already removed from the OCC.
On the second startup OCC is checked and the locs are removed from the plan.

Hope this helps. If needed I will try a small plan.

Robert
You do not have the required permissions to view the files attached to this post.
Robert van Ooijen.
Building Rhineland2. 3 levels. CS=IB1-Loconet+HSI-s88, 70 blocks, 160 sensors, 4 boosters. M&K 3rail.
Goal: Scheduled Pass. trains, "OPS" with car cards etc.. Using andRoc and Rocweb/xs throttles.
Rocrail on WinXP.
rvooyen
 

Re: [Issue] OCC not saving loc position (every other time)

Postby smitt48 » 12.10.2017, 23:55

Hi Robert,

If you delete the occ file and do not define it in Rocrail properties, it should work. It will store it in the plan, you can check if that works!

Tom
Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.2.0) - WinXP as server, 10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 

Re: [Issue] OCC not saving loc position (every other time)

Postby rjversluis » 13.10.2017, 06:22

Robert,

thanks for the trace file, but the tracelevel is so low that there is no information left which could be used.
Can you activate tracelevel INFO and AUTOMATIC too and repeat this test?
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: [Issue] OCC not saving loc position (every other time)

Postby rvooyen » 13.10.2017, 12:17

Here is the same situation with trace on INFO and AUTO.

The plan shows the locs in the terminal blocks, but OCC has already removed them.

Robert
You do not have the required permissions to view the files attached to this post.
Robert van Ooijen.
Building Rhineland2. 3 levels. CS=IB1-Loconet+HSI-s88, 70 blocks, 160 sensors, 4 boosters. M&K 3rail.
Goal: Scheduled Pass. trains, "OPS" with car cards etc.. Using andRoc and Rocweb/xs throttles.
Rocrail on WinXP.
rvooyen
 

Re: [Issue] OCC not saving loc position (every other time)

Postby rjversluis » 13.10.2017, 16:54

Robert,

the traces shows that mat46 is set in block 66 but further on not removed...
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: [Issue] OCC not saving loc position (every other time)

Postby rvooyen » 13.10.2017, 17:23

YES it shows in the plan but the MAT46 or the 232-100, are not shown in the occ anymore (they have been removed by rocrail at some point), so when rocrail is started up again the locs are not shown anymore.

Robert
Robert van Ooijen.
Building Rhineland2. 3 levels. CS=IB1-Loconet+HSI-s88, 70 blocks, 160 sensors, 4 boosters. M&K 3rail.
Goal: Scheduled Pass. trains, "OPS" with car cards etc.. Using andRoc and Rocweb/xs throttles.
Rocrail on WinXP.
rvooyen
 

Re: [Issue] OCC not saving loc position (every other time)

Postby rjversluis » 13.10.2017, 17:36

Hi Robert,

I know the story. I only wanted to write that in the Rocrail trace this issue is not visible.

I added some more traces; Please make the same test tomorrow incl. trace level Automatic and attach the new trace.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: [Issue] OCC not saving loc position (every other time)

Postby rvooyen » 14.10.2017, 09:52

OK. I ran with 12852. Trace on Auto and INFO.

It still happens. Look for:

Loc NS Mat46 in block 66.
Loc DB 232-100 in block 75-VnloA.D.
Loc NS 1117 in block 46-Kijf-AD.

All three are terminal blocks, all three locs disappear on restarting after this start. The locs in OCC have been removed during the startup that has been recorded by the trc.

Robert
You do not have the required permissions to view the files attached to this post.
Robert van Ooijen.
Building Rhineland2. 3 levels. CS=IB1-Loconet+HSI-s88, 70 blocks, 160 sensors, 4 boosters. M&K 3rail.
Goal: Scheduled Pass. trains, "OPS" with car cards etc.. Using andRoc and Rocweb/xs throttles.
Rocrail on WinXP.
rvooyen
 

Next

Return to Basic topics