[solved] Route commands "disappearing"

Moderator: Moderators

[solved] Route commands "disappearing"

Postby DeepPurple » 15.04.2018, 10:19

Hello,

For a few days, I have an annoying issue. Route commands disappear after a few minutes of automatic mode.

For example, I have those routes Dorsale1-HalteHerregaud2, Dorsale1-HalteHerregaud1, Dorsale1-HalteHerregaud3 that are well defined, with all switches and signal commands :

Code: Select all
<st id="Dorsale1-HalteHerregaud2" desc="" autogen="false" bka="Dorsale1" bkb="HalteHerregaud2" bkaside="false" bkbside="false" show="false" x="0" y="0" prev_id="Dorsale1-HalteHerregaud2" nr="0" bkc="" modid="" sga="0" sgb="0" speed="none" speedWait="none" countcars="no" polarizationA="0" polarizationB="0" reduceV="true" whiteaspect="false" reduceaspect="white" maxkmh="0" maxkmhWait="0" speedpercentWait="80" swappost="false" crossingblocksignals="false" showid="true" manual="false" preferred="0" status="0" thrownswitches="false" routespeedatenter="false" generated="false" typeperm="" class="" era="0" maxlen="0" minlen="0" commuter="false" nocommuter="false" placing="0" automatic="0" includeconditions="true" ctciid1="" ctciid2="" ctciid3="" ctcuid1="" ctcuid2="" ctcuid3="" ctcbus1="0" ctcbus2="0" ctcbus3="0" ctcaddr1="0" ctcaddr2="0" ctcaddr3="0" ctcoutput1="" ctcoutput2="" ctcoutput3="">
      <swcmd id="SW0509" type="sw" cmd="turnout"/>
      <swcmd id="SW0502" type="sw" cmd="turnout"/>
      <swcmd id="SW0508" type="sw" cmd="turnout"/>
      <swcmd id="SW0408" type="sw" cmd="turnout"/>
      <swcmd id="SW0409" type="sw" cmd="straight"/>
      <swcmd id="SW0405" type="sw" cmd="straight"/>
      <swcmd id="SG0504" type="sg" cmd="green" lock="false" protect="false" reduceV="true" atfree="false" mode="0"/>
      <swcmd id="SG0412" type="sg" cmd="green" lock="false" protect="false" reduceV="true" atfree="false" mode="0"/>
      <swcmd id="SG0412" type="sg" cmd="red" lock="false" protect="false" reduceV="true" atfree="true" mode="0"/>
      <swcmd id="SG0504" type="sg" cmd="red" lock="false" protect="false" reduceV="true" atfree="true" mode="0"/>
    </st>
    <st id="Dorsale1-HalteHerregaud1" desc="" autogen="false" bka="Dorsale1" bkb="HalteHerregaud1" bkaside="false" bkbside="false" show="false" x="0" y="0" prev_id="Dorsale1-HalteHerregaud1" nr="0" bkc="" modid="" sga="0" sgb="0" speed="none" speedWait="none" countcars="no" polarizationA="0" polarizationB="0" reduceV="true" whiteaspect="false" reduceaspect="white" maxkmh="0" maxkmhWait="0" speedpercentWait="80" swappost="false" crossingblocksignals="false" showid="true" manual="false" preferred="0" status="0" thrownswitches="false" routespeedatenter="false" generated="false" typeperm="" class="" era="0" maxlen="0" minlen="0" commuter="false" nocommuter="false" placing="0" automatic="0" includeconditions="true" ctciid1="" ctciid2="" ctciid3="" ctcuid1="" ctcuid2="" ctcuid3="" ctcbus1="0" ctcbus2="0" ctcbus3="0" ctcaddr1="0" ctcaddr2="0" ctcaddr3="0" ctcoutput1="" ctcoutput2="" ctcoutput3="">
      <swcmd id="SW0509" type="sw" cmd="turnout"/>
      <swcmd id="SW0502" type="sw" cmd="turnout"/>
      <swcmd id="SW0508" type="sw" cmd="turnout"/>
      <swcmd id="SW0408" type="sw" cmd="turnout"/>
      <swcmd id="SW0409" type="sw" cmd="straight"/>
      <swcmd id="SW0405" type="sw" cmd="turnout"/>
      <swcmd id="SG0504" type="sg" cmd="green" lock="false" protect="false" reduceV="true" atfree="false" mode="0"/>
      <swcmd id="SG0411" type="sg" cmd="green" lock="false" protect="false" reduceV="true" atfree="false" mode="0"/>
      <swcmd id="SG0411" type="sg" cmd="red" lock="false" protect="false" reduceV="true" atfree="true" mode="0"/>
      <swcmd id="SG0504" type="sg" cmd="red" lock="false" protect="false" reduceV="true" atfree="true" mode="0"/>
    </st>
    <st id="Dorsale1-HalteHerregaud3" desc="" autogen="false" bka="Dorsale1" bkb="HalteHerregaud3" bkaside="false" bkbside="false" show="false" x="0" y="0" prev_id="Dorsale1-HalteHerregaud3" nr="0" bkc="" modid="" sga="0" sgb="0" speed="none" speedWait="none" countcars="no" polarizationA="0" polarizationB="0" reduceV="true" whiteaspect="false" reduceaspect="white" maxkmh="0" maxkmhWait="0" speedpercentWait="80" swappost="false" crossingblocksignals="false" showid="true" manual="false" preferred="0" status="0" thrownswitches="false" routespeedatenter="false" generated="false" typeperm="" class="" era="0" maxlen="0" minlen="0" commuter="false" nocommuter="false" placing="0" automatic="0" includeconditions="true" ctciid1="" ctciid2="" ctciid3="" ctcuid1="" ctcuid2="" ctcuid3="" ctcbus1="0" ctcbus2="0" ctcbus3="0" ctcaddr1="0" ctcaddr2="0" ctcaddr3="0" ctcoutput1="" ctcoutput2="" ctcoutput3="">
      <swcmd id="SW0509" type="sw" cmd="turnout"/>
      <swcmd id="SW0502" type="sw" cmd="turnout"/>
      <swcmd id="SW0508" type="sw" cmd="turnout"/>
      <swcmd id="SW0408" type="sw" cmd="turnout"/>
      <swcmd id="SW0409" type="sw" cmd="turnout"/>
      <swcmd id="SW0406" type="sw" cmd="turnout"/>
      <swcmd id="SG0504" type="sg" cmd="green" lock="false" protect="false" reduceV="true" atfree="false" mode="0"/>
      <swcmd id="SG0413" type="sg" cmd="green" lock="false" protect="false" reduceV="true" atfree="false" mode="0"/>
      <swcmd id="SG0413" type="sg" cmd="red" lock="false" protect="false" reduceV="true" atfree="true" mode="0"/>
      <swcmd id="SG0504" type="sg" cmd="red" lock="false" protect="false" reduceV="true" atfree="true" mode="0"/>
    </st>


And after a few schedule movements, the commands disappear from some of the routes :

Code: Select all
 <st id="Dorsale1-HalteHerregaud2" desc="" autogen="false" bka="Dorsale1" bkb="HalteHerregaud2" bkaside="false" bkbside="false" show="false" x="0" y="0" prev_id="Dorsale1-HalteHerregaud2" nr="0" bkc="" modid="" sga="0" sgb="0" speed="none" speedWait="none" countcars="no" polarizationA="0" polarizationB="0" reduceV="true" whiteaspect="false" reduceaspect="white" maxkmh="0" maxkmhWait="0" speedpercentWait="80" swappost="false" crossingblocksignals="false" showid="true" manual="false" preferred="0" status="0" thrownswitches="false" routespeedatenter="false" generated="false" typeperm="" class="" era="0" maxlen="0" minlen="0" commuter="false" nocommuter="false" placing="0" automatic="0" includeconditions="true" ctciid1="" ctciid2="" ctciid3="" ctcuid1="" ctcuid2="" ctcuid3="" ctcbus1="0" ctcbus2="0" ctcbus3="0" ctcaddr1="0" ctcaddr2="0" ctcaddr3="0" ctcoutput1="" ctcoutput2="" ctcoutput3="" locid="DB614O"/>
    <st id="Dorsale1-HalteHerregaud1" desc="" autogen="false" bka="Dorsale1" bkb="HalteHerregaud1" bkaside="false" bkbside="false" show="false" x="0" y="0" prev_id="Dorsale1-HalteHerregaud1" nr="0" bkc="" modid="" sga="0" sgb="0" speed="none" speedWait="none" countcars="no" polarizationA="0" polarizationB="0" reduceV="true" whiteaspect="false" reduceaspect="white" maxkmh="0" maxkmhWait="0" speedpercentWait="80" swappost="false" crossingblocksignals="false" showid="true" manual="false" preferred="0" status="0" thrownswitches="false" routespeedatenter="false" generated="false" typeperm="" class="" era="0" maxlen="0" minlen="0" commuter="false" nocommuter="false" placing="0" automatic="0" includeconditions="true" ctciid1="" ctciid2="" ctciid3="" ctcuid1="" ctcuid2="" ctcuid3="" ctcbus1="0" ctcbus2="0" ctcbus3="0" ctcaddr1="0" ctcaddr2="0" ctcaddr3="0" ctcoutput1="" ctcoutput2="" ctcoutput3="" locid="DB614O"/>
    <st id="Dorsale1-HalteHerregaud3" desc="" autogen="false" bka="Dorsale1" bkb="HalteHerregaud3" bkaside="false" bkbside="false" show="false" x="0" y="0" prev_id="Dorsale1-HalteHerregaud3" nr="0" bkc="" modid="" sga="0" sgb="0" speed="none" speedWait="none" countcars="no" polarizationA="0" polarizationB="0" reduceV="true" whiteaspect="false" reduceaspect="white" maxkmh="0" maxkmhWait="0" speedpercentWait="80" swappost="false" crossingblocksignals="false" showid="true" manual="false" preferred="0" status="0" thrownswitches="false" routespeedatenter="false" generated="false" typeperm="" class="" era="0" maxlen="0" minlen="0" commuter="false" nocommuter="false" placing="0" automatic="0" includeconditions="true" ctciid1="" ctciid2="" ctciid3="" ctcuid1="" ctcuid2="" ctcuid3="" ctcbus1="0" ctcbus2="0" ctcbus3="0" ctcaddr1="0" ctcaddr2="0" ctcaddr3="0" ctcoutput1="" ctcoutput2="" ctcoutput3="">
      <swcmd id="SW0509" type="sw" cmd="turnout"/>
      <swcmd id="SW0502" type="sw" cmd="turnout"/>
      <swcmd id="SW0508" type="sw" cmd="turnout"/>
      <swcmd id="SW0408" type="sw" cmd="turnout"/>
      <swcmd id="SW0409" type="sw" cmd="turnout"/>
      <swcmd id="SW0406" type="sw" cmd="turnout"/>
      <swcmd id="SG0504" type="sg" cmd="green" lock="false" protect="false" reduceV="true" atfree="false" mode="0"/>
      <swcmd id="SG0413" type="sg" cmd="green" lock="false" protect="false" reduceV="true" atfree="false" mode="0"/>
      <swcmd id="SG0413" type="sg" cmd="red" lock="false" protect="false" reduceV="true" atfree="true" mode="0"/>
      <swcmd id="SG0504" type="sg" cmd="red" lock="false" protect="false" reduceV="true" atfree="true" mode="0"/>
    </st>


I have rebuilt the routes several times already, and have refreshed the Rocrail program version, but I still have the issue...

What do you suggest ?

Philippe.
You do not have the required permissions to view the files attached to this post.
Last edited by DeepPurple on 15.04.2018, 15:09, edited 1 time in total.
Philippe - Brussels (FR - NL - EN)
N layout with Digikeijs command station
DeepPurple
 

Re: Route commands "disappearing"

Postby cds » 15.04.2018, 10:26

Hello Phillppe!

You are using 13786 from 31.03.2018 though the actual version is 13860.
I would give it a try ...
Beste Grüße/Kind regards
Claus

M* H0 M
HW: TAMS MC, B-2 & B-4, WD-34, VIESSMANN 5211(1), LITTFINSKY & TAMS S88-3
Decoder: Mä & TAMS (MM2)
SW: Win7 64, RR 64, andRoc
cds
 

[SOLVED] Route commands "disappearing"

Postby DeepPurple » 15.04.2018, 15:08

Indeed, I can't reproduce the issue anymore with the last version. Hoping it is definitively solved. Thank you for the tip. :beer:

:rr_for_ever:
Philippe - Brussels (FR - NL - EN)
N layout with Digikeijs command station
DeepPurple
 


Return to Automatic mode