Pianificazione

Pianificazione

Postby michele » 20.02.2014, 18:47

Ciao a tutti, mi chiamo Michele e sto facendo il mio piccolo plastico, io uso la Ecos 50200. Dopo aver cablato tutto con gli S-88 di LDT ho creato i sensori e tutto il resto. Le loco funzionano anche bene da blocco a blocco però dopo che ho creato le pianificazioni certe loco non vanno e non riesco a capire perché. Quando vado con il modo automatico e imposto la pianificazione, certe loco vanno senza problemi e fanno tutto il loro giro, mentre in alcune altre viene fuori il messaggio: "No destination find for......" e non si muovono.
Poi mi sembra che girino solo nel verso anti-orario, cioè se io pianifico blocco 4-3-2-1 tutto ok (con certe loco) se invece provo blocco 1-2-3-4 niente sempre il solito messaggio "No destination find for......" questo con tutte le loco.
Eppure mi sembra che gli itinerari esistano ho controllato, non credo che i treni, in modalità automatica, possano girare solo in un verso o no?
Qualcuno per caso mi può aiutare?
Grazie.
michele
 

Re: Pianificazione

Postby sergio » 22.02.2014, 09:42

Michele ciao, :beer:
io proverei a fare cosi':
- semplificare il tracciato il piu' possibile in modo da focalizzarsi sui pochi blocchi e comandi in esame
- avviare Rocrail ed evidenziare le finestre "Rocrail server" e pure nel Rocview tenere ben in evidenza le due finestre "Server" e " Controller"
- poi prendere una loco che dici comportarsi bene ed avviarla
- segnarti tutti i messaggi che compaiono nelle finestre senza dimenticarti di controllare in ogni blocco il "verso" cioe' quella piccola freccettina che indica la direzione di uscita dal blocco.
fatto questo bisogna ripetere il tutto con una loco che non parte e vedere cosa c' e' di dissimile
Probabilmente questa loco e' impostata in direzione opposta e quindi non parte
Potresti vedere se apri (tasto destro) un blocco cosa succede se agisci su:
- swap block enter side
oppure su
- swap placing (cioe' dire al software che la loco deve andare in direzione opposta)
riprovare e notare cosa e' cambiato nei messaggi in tutte le finestre sopracitate.
Questa metodologia dovrebbe portare a capire e fissare i settaggi (impostazioni) di ogni loco.
Se tutto questo non dovesse bastare :coding: allora bisogna passare(anzi tornare) dopo aver preso un :coffee: a verificare come sono state generate le "routes".
per semplificarti la vita dovresti farti aiutare nel generarle dall' automatismo (che le genera tutte eguali dal punto di vista del verso) e poi procedere.
ciao - sergio
Why busy with Rocrail?? Because not too young to play trains, nor too old to learn something new.
http://www.amc-chiaravalle.org
sergio
 

Re: Pianificazione

Postby cds » 23.02.2014, 20:26

Ciao Michele,

mi dispiace, mi italiano non e buono quindi continuerò con inglese:
If you still have problems please provide your plan file.
Beste Grüße/Kind regards
Claus

M* H0 M
HW: TAMS MC, B-2 & B-4, WD-34, VIESSMANN 5211(1), LITTFINSKY & TAMS S88-3
Decoder: Mä & TAMS (MM2)
SW: Win7 64, RR 64, andRoc
cds
 

Re: Pianificazione

Postby michele » 24.02.2014, 13:12

Ciao Sergio, anche per me è un piacere conoscerti :beer: , intanto ti ringrazio tanto per le indicazioni, avevo già provato a invertire il senso di entrata del blocco e anche quello della locomotiva ma nada; ho anche provato a invertire proprio i blocchi cioè da nord a sud per esempio per capirci (non so neanche se è una cosa che si può fare) ma comunque niente lo stesso. Adesso voglio provare, come dici tu, a evidenziare la finestra server e vedere i messaggi che da con una loco che funziona e poi con una che non parte, poi ti faccio sapere.
Ciao grazie,
Michele
michele
 

Re: Pianificazione

Postby michele » 24.02.2014, 13:19

Hi Claus, thank you very much for your reply, I'll be very happy to send you my file plan.
I have a question: which file do you need, the .xml only or also the .ini?
Regards,
Michele
michele
 

Re: Pianificazione

Postby cds » 24.02.2014, 13:39

Ciao Michele,

as it seems to be a configuration problem the .xml file is sufficient.
Grazie!
Beste Grüße/Kind regards
Claus

M* H0 M
HW: TAMS MC, B-2 & B-4, WD-34, VIESSMANN 5211(1), LITTFINSKY & TAMS S88-3
Decoder: Mä & TAMS (MM2)
SW: Win7 64, RR 64, andRoc
cds
 

Re: Pianificazione

Postby michele » 24.02.2014, 15:19

Ciao Claus,
here it is the files.
Ciao grazie,
Michele

Guarda che il tuo italiano non è male, sicuramente meglio del mio tedesco!!! :D
You do not have the required permissions to view the files attached to this post.
michele
 

Re: Pianificazione

Postby cds » 24.02.2014, 16:16

Ciao Michele!

Did you have the routes generated by the analyzer tool?
I am asking because I've noticed a general problem with routes in your plan SNazario.xml. E. g. check route "autogen-[BL-2+]-[BL-1-]" in the routes table. It says "go from the + side in block BL-2 to the - side in block BL-1". This route would go via BL-5 and BL-6 to BL-1!!! That's why your loco goes to the left even if the direction arrow in block BL-2 shows to the right (and vice versa)!!!

When the loco shall go the route from BL-2 to BL-1 to the left via point 1 (= the shortest way), the route configuration must be changed in the "General" tab of your route configuration according this:
From block: BL-2, "+" NOT selected
To block: BL-1, "+" selected
The point in tab "Commands" is correct.
The ID would go right like this: autogen-[BL-2-]-[BL-1+]

I was wondering if you would like to check your route definitions on your own? Alternatively I could repair your route definitions.

Other problems I've not checked so far.
Beste Grüße/Kind regards
Claus

M* H0 M
HW: TAMS MC, B-2 & B-4, WD-34, VIESSMANN 5211(1), LITTFINSKY & TAMS S88-3
Decoder: Mä & TAMS (MM2)
SW: Win7 64, RR 64, andRoc
cds
 

Re: Pianificazione

Postby cds » 24.02.2014, 16:50

Ciao Michele!

One low priority remark :wink:
You should think upgrading your RR. Your are working with 6718, the actual version is 6853 ...
Beste Grüße/Kind regards
Claus

M* H0 M
HW: TAMS MC, B-2 & B-4, WD-34, VIESSMANN 5211(1), LITTFINSKY & TAMS S88-3
Decoder: Mä & TAMS (MM2)
SW: Win7 64, RR 64, andRoc
cds
 

Re: Pianificazione

Postby michele » 24.02.2014, 23:26

Ciao Claus,

Yes the routes are generate with the analyzer tool, I try to do it by myself but it doesn't work well.
I've  seen what you wrote about my plan and I think you know very well this program  :thumb_up: , I could try to follow your instruction but I'll prefer if you repair the route definitions.it is very kind of you.

Ciao grazie,
Michele
michele
 

Re: Pianificazione

Postby cds » 25.02.2014, 08:56

Ciao Michele,

I'll prefer if you repair the route definitions
Volentieri!
The corrected plan is attached. It is zipped in order to save file space.

Maybe you are interested in what I've corrected:
*) I've modified around 14 routes according my previous posting.
*) I've selected in all blocks the checkbox "Electrified". You configured BR151 to be "Electric" -> "Electric" locos need "Electrified" blocks mandatoryly otherwise they are not able to run (like in reality :wink: ).
*) (No mistake) I've deselected all permissions in all blocks because it is not necessary. To select all locos in the "Include" section means the same as to not select them all.
*) I've configured blocks BL-13, BL-15 and BL-16 to be "Terminal stations". Otherwise the locos would not swap the direction automatically and would find no destination.

Now all locos are running in both directions without errors. I made the tests with VCS (virtual command station), RR version 6845 and "Run all locos virtual". (Attention: It is possible that two locos get stuck in this mode :wink: ). I didn't check the correct behaviour of signals.
Beste Grüße/Kind regards
Claus

M* H0 M
HW: TAMS MC, B-2 & B-4, WD-34, VIESSMANN 5211(1), LITTFINSKY & TAMS S88-3
Decoder: Mä & TAMS (MM2)
SW: Win7 64, RR 64, andRoc
cds
 

Re: Pianificazione

Postby michele » 25.02.2014, 10:21

Ciao Claus,

you are super! I have just upgrade Rocrail, now I have to go out but after I try what you have done and let you know all. For the moment Thank you very much :D

Ciao,
Michele
michele
 

Re: Pianificazione

Postby cds » 25.02.2014, 13:29

Ciao Michele,

ho anche provato a invertire proprio i blocchi cioè da nord a sud per esempio per capirci
This is dangerous and might have been the cause of your troubles! If you do so you also have to modify all routes to and from an inverted block.
Beste Grüße/Kind regards
Claus

M* H0 M
HW: TAMS MC, B-2 & B-4, WD-34, VIESSMANN 5211(1), LITTFINSKY & TAMS S88-3
Decoder: Mä & TAMS (MM2)
SW: Win7 64, RR 64, andRoc
cds
 

Re: Pianificazione

Postby michele » 25.02.2014, 20:23

Ciao Claus,

now also the electric loco goes :wink: , I understand the problem now, but there is always the problem that the loco goes in one way (anti-orario), if I planned a route in the orary direction they don't go. I have try to look the server window and there were this message:

20140225.192512.623 r9999I ESU BR 1 OModel 4369 Try to find a route to block "
BL-9".
20140225.192512.623 r9999I ESU BR 1 OModel 4381 route[autogen-[BL-7+]-[BL-9-]]
found but it is not in the same direction: reject.
20140225.192512.623 r9999I ESU BR 1 OModel 4300 last entry[5] in schedule [st-
9-10-11-st] is reached.

Do you know why?
The loco is ready with the light in the right direction.

Ciao,
Michele
michele
 

Re: Pianificazione

Postby cds » 25.02.2014, 20:31

Ciao Michele,

I will check it tomorrow.
Beste Grüße/Kind regards
Claus

M* H0 M
HW: TAMS MC, B-2 & B-4, WD-34, VIESSMANN 5211(1), LITTFINSKY & TAMS S88-3
Decoder: Mä & TAMS (MM2)
SW: Win7 64, RR 64, andRoc
cds
 

Next

Return to Modalità automatica (IT)

cron