Marklin CS2

Märklin Central Station 2

Marklin CS2

Postby plane2257 » 24.02.2010, 01:07

If I connect the CS2 directly to the computer via ethernet, how do I set this up exactly (as far as getting rocrail to recognize)? I don't know what to do because the directions on the site are confusing for me. I have no idea how to configure or find the IP and what not. any help will be much appreciated !
plane2257
 

Postby ron&bram » 24.02.2010, 10:20

Hi Eric,

I'll answer via the forum, rather then sending you a reply to your message, that way others can learn from it also. BTW, I do not have a cs2, I have a twincenter aka intellibox classic.

You have run into the hardest problem of the cs2, setting up the communication. There is a special page for that in the wiki: http://wiki.rocrail.net/doku.php?id=cs2:cs2-en#network_settings.
You need some basic knowledge of how tcp/ip works to do it right.
First of all, I think you need a cross-over cable for a direct connection between pc and cs2, rather then a one-to-one straight network cable. Since network cables are cheap, you may get one of each and try them both.
Both the cs2 and the ethernet card in your pc have a tcp/ip address. These addresses have to be in the same range in order to communicate. This range is determined by the settings of the parameter subnetmask. The subnetmask also determines the broadcast address of your local network.
Now you know the theory, so get cracking :wink: .

There are some ranges of ip addresses reserved for private use, one of which is the range 192.168.xxx.xxx. We will use that one.
First, on your pc, you need to access the properties of your network card. You have not mentioned your OS, but lets assume that it is windows xp (when not, you need to consult the help of your os). From the configuration screen, go to network connections, select your network card and press properties. In the next window, select the tcp/ip protocol and again press properties. Here, select "use the following tcp/ip address", now the grey areas for defining ip addres and subnetmask become available. Use as ip address 192.168.0.10 and as subnetmask 255.255.255.0, you can leave the rest empty. Confirm by clicking ok several times.
Now, in the cs2 you need to do the same. You have to set the cs2 ip address, use 192.168.1.20 (this address you must set in Rocrail for the cs2), the subnetmask 255.255.255.0 and the broadcast address (destination address) 192.168.1.255, that is it.
I have heard reports that sometimes the cs2 all by itself can change the set ip address, so when it suddenly does not work, check it.

Best rgeards, Ronald
Best regards, Viele Grüsse, vriendelijke groeten, Ronald :rr_cap:
GCA85/50/93/145/146/153 Loconet, Twincenter+booster for locs, seperate booster for accessory decoders, dedicated laptop with XP and Ubuntu for Rocrail, AndRoc, LGB indoor OTF layout
ron&bram
 

Postby TRUKO » 24.02.2010, 17:11

Hello Eric,

Don't forget the tick on the "Gateway" in the CS2.

If German is not a problem for you, the team has written a good guide:
http://www.eusis.com/images/Rocail-CS2- ... t_Doku.pdf

Look into page 4.

Good luck,
Regards,
Rutger
TRUKO
 

Postby plane2257 » 24.02.2010, 20:22

Thank you for taking the time to help me with my problem. First I want to explain my set up. I have a Belkin G Wireless router that was just sitting in my closet so I decided to try and connect the CS to that and broadcast it. So this router I am using is not connected to the internet, it is just to broadcast the CS. Behind the router, I have plugged in a network cable from the CS to LINE 1 for wired. The modem plug, where you would usually connect your high speed line through, is left unused. I am currently using windows vista but I was able to get to the network properties as you have explained. I tried two things in the network properties: First I tried all the IP setting you described through my LAN network card (because I tried a direct connection between CS and PC using a yellow ethernet data cable) and also the settings in the Belkin with your instructions. In the CS, I typed in all of the different IP addresses and what not and tried checking and un-checking (at different tries of course) the Gateway button in the CS settings. After I followed your instructions, I opened up Rocrail and Rocrail Viewer. I went to the CS properties in Rocrail and changed it to the IP address you stated, and then shut down and restarted both Rocrail and the CS. I checked to make sure that the IP addresses were still the same, because you stated that sometimes it will reset. After this, I reopened Rocrail and Rocview and tried to turn 'on' and 'off' the track with the lightbulb button on rocview. I also tried by going to Control ->Power On. It still didnt work. Also to note, that on the bottom left side of the Rocview it says "cannot connect to Rocrail.net" and "cannot connect to host". I am assuming the first reason is because I am using a router not connected to internet. The other thing I tried doing to see if there was even a valid connection between the CS and the PC (both directly, and through the router) we by sending a PING command. This also failed. So now, I am stuck. What should I do?
plane2257
 

Postby TRUKO » 24.02.2010, 20:31

Hello Eric,

Did you switched on the "Gateway" tickbox on the CS2?

The point that your router is not connected to the internet is not relevant.

Regards,
Rutger
Last edited by TRUKO on 24.02.2010, 20:32, edited 1 time in total.
TRUKO
 

Postby ron&bram » 24.02.2010, 20:31

Hi Eric,

Some more tips:

How does your pc connect to the router, wired or wireless? Wired would be my preferred option, at least until everything is up and working.

When your router supports working as a DHCP server and it has the possibility to assign allways the same ip address to the same mac address (mac address is a unique number for each network card) you can try to have the router assign the ip addresses to both the CS2 and your pc.

When you go into the configuration of your router, there is very often an overview of all connected devices, can you there see both the pc and the CS2?

Have you enabled Rocrail to use the CS2 ports in the windows firewall?

Best regards, Ronald
Best regards, Viele Grüsse, vriendelijke groeten, Ronald :rr_cap:
GCA85/50/93/145/146/153 Loconet, Twincenter+booster for locs, seperate booster for accessory decoders, dedicated laptop with XP and Ubuntu for Rocrail, AndRoc, LGB indoor OTF layout
ron&bram
 

Postby plane2257 » 24.02.2010, 22:58

Ok, what I did was connect ethernet cable from cs to router, and router to pc. I called Belkin to have them help me set up so that the pc was listening to the router. They made me change setting and automatically get IP and DNS. Now when I Ping 192.168.2.3 no data is lost. I tried putting this IP in the CS IP but Rocrail is still not recognizing it. What do you suggest? And yes, I have the gateway box checked.
plane2257
 

Postby plane2257 » 24.02.2010, 23:55

Ok. When I go to cmd and type in IPCONFIG this is what I get:

Ethernet adapter Local Area Connection:
Connection-Specific DNS Suffix: Belkin
IPv4 Address: 192.168.2.4
Subnet mask: 255.255.255.0
Default Gateway: 192.168.2.1

Could we set it up using these things?
plane2257
 

Postby plane2257 » 25.02.2010, 01:43

I tried something else. I set the CS2 IP to automatic, and then PING'd with the IP given to me. It does work, no data is lost. But when I input that into Rocrail, still no response..
plane2257
 

Postby plane2257 » 25.02.2010, 02:10

Also, it only shows as my PC connected to the router under the router settings. It doesnt show the mac address of the CS.
plane2257
 

Postby gramels » 25.02.2010, 07:08

Hi,
it sounds to me like a localnetwork setup issue.

The generic guide to set up a small network at home with a home router is the follwing:
*reset the router to factory default, that make most of the provide IP adresses using DHCP protocol to the LAN w/o other configuration changes
*plug in one the internal port of the router (it might have an integrated switch) (usually labeled LAN) the PC
*plug in an other LAN port the CS
*in case there is no 2nd LAN port, you need to add an ethernet switch to the router
*put the pc and the router in automatic IP configuration mode
*restart both
*look up the IP of the PC and enter it in the CS

How many ethernet plugs has this belkin thing and how are they labeled? Most likely you have used the wrong connectors at your belkin router.
gramels
 

Postby plane2257 » 25.02.2010, 08:26

thank you. i will try this. Here is a picture of the back of a router that is similar to mine:
http://imagehost.vendio.com/a/3578944/a ... l_main.jpg
[/url]
So basically I'm using 1 and 2 on the back. 1 for PC to router and other from router to CS. I left the "connection to modem" plug empty because this is an extra router i have, not connected to the internet.

thanks !

[/url]
plane2257
 

Postby ron&bram » 25.02.2010, 10:17

Hi Eric,

From the picture I would say that you indeed have a router with intergrated switch, which is OK.
I also read that enabled the DHCP server on the router and set your pc and the CS2 to obtain an ip address automatically (best solution). The router is apparently setup to use the ip range 192.168.2.xxx, which is fine. It did assign ip address 192.168.2.4, no problem there. The subnetmask of 255.255.255.0 given to your pc is also ok.
When you go to the network settings of the CS2, what ip address is shown there?
Gateway box ticked on the CS2?
On the CS2 network settings, the subnetmask must be 255.255.255.0 and the broadcast address (destination address) must be 192.168.2.255.
At the front of your router there are leds numbered 1 to 4. When you connect a device to port 1, the led 1 should turn on. When there is traffic, the led should flash. Does the appropriate led turn on when you connect the cs2?

Best regards, Ronald
Best regards, Viele Grüsse, vriendelijke groeten, Ronald :rr_cap:
GCA85/50/93/145/146/153 Loconet, Twincenter+booster for locs, seperate booster for accessory decoders, dedicated laptop with XP and Ubuntu for Rocrail, AndRoc, LGB indoor OTF layout
ron&bram
 

Postby plane2257 » 25.02.2010, 18:10

IT WORKS! THANK YOU VERY, VERY MUCH. The IP address is 192.168.2.2 for the CS and I had to change the default gateway from 192.168.1.255 to what you said, 192.168.2.255. Also, yesterday I went into the router settings, opened up ports, put the CS mac address in, and did something with DHCP settings. I just tested the power switch and it works! I learned a lot from you guys about network settings, etc. Thanks again! I'm sure I'll have many more questions about rocrail..
plane2257
 

Postby ron&bram » 25.02.2010, 19:05

Hi Eric,

Good to read, congratulations, you have past the most difficult obstavle most CS2 users experience.
Which version of Rocrail are you using?

Best regards, Ronald
Best regards, Viele Grüsse, vriendelijke groeten, Ronald :rr_cap:
GCA85/50/93/145/146/153 Loconet, Twincenter+booster for locs, seperate booster for accessory decoders, dedicated laptop with XP and Ubuntu for Rocrail, AndRoc, LGB indoor OTF layout
ron&bram
 

Next

Return to CS2