Issues with feedback from s88 and signals

Märklin Central Station 2

Issues with feedback from s88 and signals

Postby moman » 23.08.2011, 15:34

Hello,

I'm working on setting up a new layout and before starting I wanted to experiment a little with rocrail and the central station to see what level of automatization would be feasible.

Right now, my test layout consists of two switches, two signals (controlled via a k84 decoder) and two sensors (receiving feedback via an s88 decoder).

Signal A is connected at k84 #4 port 3, and signal B is connected at k84 #4 port 4, which map to 15 and 16 on the keyboard, respectively.

Below is a snaphot of the layout:

Image

I'm able to control both the switches and the signals via rocrail (i.e. when I click on a switch or a signal, the state changes on the track), but I've run into a strange issue:

-When I change the state of signals A or B via the central station, their state is NOT updated in rocrail. As a temporary workaround, I instead added a "decoupler" element at the same addresses (4 port 3, 4 port 4), and was able to verify that when I change the state of the signals via the central station, the decouplers change color (but the signals still don't).

Why are the signals not being updated in rocrail? Is a special configuration parameter necessary?

-----
-The second issue is that neither of the sensors seem to be giving any feedback to rocrail. I haven't created any routes in rocrail yet, but I'm assuming that isn't necessary just to be able to observe the event.

How should they be configured? Should I just use addresses 1 and 2 if that's where they're connected on the s88 decoder? Does the event need to be registered somehow?

I already added fbmod="1" to rocrail.ini:
<digint iid="CS2" lib="mcs2" host="192.168.1.2" port="0" fbmod="1"/>

In order to verify that the sensors are working I made a quick route using CS2's memory system, and it worked, so the sensors are definitely operation.

------

Overall rocrail looks like an amazing piece of software- I'm looking forward to using it on my layout! Thanks in advance for your help!
moman
 

Postby ron&bram » 02.09.2011, 21:14

Hi,

The first input of the first S88 unit has address 1 in Rocrail, from there on they just number upwards. When the address is set correctly, you should see the feedback going from green to red in Rocview when it is occupied.

With regard to the signals, this has a very technical background. But in short, the signal processing in Rocrail is not done at the level of the command station library. This library only receives accessory decoder commands from the higher level and does not know if this is an output, a switch or a signal. Currently, there is no command station library that can pass on changed signal states back to the toplevel.
Best regards, Viele Grüsse, vriendelijke groeten, Ronald :rr_cap:
GCA85/50/93/145/146/153 Loconet, Twincenter+booster for locs, seperate booster for accessory decoders, dedicated laptop with XP and Ubuntu for Rocrail, AndRoc, LGB indoor OTF layout
ron&bram
 


Return to CS2