SOLVED Power icon not updated after external power command

Märklin Central Station 2

SOLVED Power icon not updated after external power command

Postby woodyboy » 29.03.2014, 18:33

Dear forummembers,

If the command station powers down with a CS2 STOP command, the power icon on the symbol bar is not changing its indication according to the powerstate on track. The controller monitor pane shows a CS2 STOP but the power icon status doesn't change.

Version 7065
Version that works ok is 6603. My suspicion is that it went wrong since the icon change about 2 month ago.
Last edited by woodyboy on 30.03.2014, 11:11, edited 1 time in total.
Regards,

Bert

Equipment: Roco WLANMaus, MS2, Gleisbox 2x(separated switch & rollingstock). Ubuntu 16. Edits booster. Arduino: S88 CANbus interface & Ethernet-CANbus gateway
woodyboy
 

Re: Error Power icon not updated after external power comman

Postby rjversluis » 29.03.2014, 18:37

Hi Bert,

can you attach a small trace in which this power command is included?
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Error Power icon not updated after external power comman

Postby rjversluis » 29.03.2014, 18:44

I just investigated the code; It should work.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Error Power icon not updated after external power comman

Postby woodyboy » 29.03.2014, 18:57

Hi Rob,

Thanks for the quick response. Hereby the log attached. The first is power off, power on by MS2. After this cycle I fired an action with a Rocrail issued STOP. Power wents off, in both cases no icon update.
Last edited by woodyboy on 29.03.2014, 19:54, edited 1 time in total.
Regards,

Bert

Equipment: Roco WLANMaus, MS2, Gleisbox 2x(separated switch & rollingstock). Ubuntu 16. Edits booster. Arduino: S88 CANbus interface & Ethernet-CANbus gateway
woodyboy
 

Re: Error Power icon not updated after external power comman

Postby rjversluis » 29.03.2014, 19:02

I do not see any power commands except for actions with power commands...
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Error Power icon not updated after external power comman

Postby woodyboy » 29.03.2014, 19:13

Hi Rob,

I do not see any power commands except for actions with power commands...


Me too, but I also see a dirty reply packet from my code
00 01 3B 79 05 00 00 02 00 01 00 00 00

Give me some time to investigate and where my command stays..... The power really switches off :D :D

On the other hand the action power command does not change the icon too. Or is this implemented by monitoring the CAN feedback command?

to be continued
Regards,

Bert

Equipment: Roco WLANMaus, MS2, Gleisbox 2x(separated switch & rollingstock). Ubuntu 16. Edits booster. Arduino: S88 CANbus interface & Ethernet-CANbus gateway
woodyboy
 

Re: Error Power icon not updated after external power comman

Postby woodyboy » 29.03.2014, 22:10

A new shortened log, I observed still errors in the previous log. Now, to my opinion, it shows well shaped packages.
At startup power is switched on
The sequence is manual STOP via MS2
power is switched off
click on the icon also a STOP is send to both controllers

manual GO on the MS2
power is switched on to the track
click on the icon two GO commands are send by Rocrail.

for readability the sensor events are deactivated.
You do not have the required permissions to view the files attached to this post.
Regards,

Bert

Equipment: Roco WLANMaus, MS2, Gleisbox 2x(separated switch & rollingstock). Ubuntu 16. Edits booster. Arduino: S88 CANbus interface & Ethernet-CANbus gateway
woodyboy
 

Re: Error Power icon not updated after external power comman

Postby rjversluis » 30.03.2014, 06:46

A system command with response bit set is now also evaluated. (7072)
But a system command with sub-command 6 is not handled.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Error Power icon not updated after external power comman

Postby woodyboy » 30.03.2014, 09:41

Hi Rob,

Thanks for modifying, The 06 subcommand is the command for setting the accesory timeout. No evaluation is necessary. According to my observations the problem are not the discarded response power commands. The original manual command for stop is in the right way evaluated
offset: 00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F |ASCII...........|
--------------------------------------------------------- |----------------|
00000000: 00 00 37 35 05 00 00 00 00 00 00 00 00 |..75......... |
20140329.215831.165 r9999c mcs2read OMCS2 0742 CS2 STOP

The icon has not changed, but clicking the icon will issue a STOP to both controllers. To me it sounds that actually the external STOP command has not updated the internal Rocrail status. Maybe the thread title is not accurate, but this is are my 2cents after a short night and my first :coffee:
Regards,

Bert

Equipment: Roco WLANMaus, MS2, Gleisbox 2x(separated switch & rollingstock). Ubuntu 16. Edits booster. Arduino: S88 CANbus interface & Ethernet-CANbus gateway
woodyboy
 

Re: Error Power icon not updated after external power comman

Postby rjversluis » 30.03.2014, 10:05

Hi Bert,

maybe you should check the reportstate attribute in you rocrail.ini
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Error Power icon not updated after external power comman

Postby woodyboy » 30.03.2014, 11:10

Hi Rob,

You made my day :D . The reportstate attribute was defined as false, true solved the issue. For the second controller this attribute is missing. It is a controller attribute, but I observe no change in de controller dialog when changing the value in the ini. Even I can't find any documentation on this attribute, a search in the wiki reports:

This topic does not exist yet

You've followed a link to a topic that doesn't exist yet. If permissions allow, you may create it by using the Create this page button.

Trace: » rocrailini-en


Is this maybe a rest of a former problem analysis I don't remember?

But anyway, issue is solved. Thanks for investigating and the solution.

Have a nice day! :beer:
Regards,

Bert

Equipment: Roco WLANMaus, MS2, Gleisbox 2x(separated switch & rollingstock). Ubuntu 16. Edits booster. Arduino: S88 CANbus interface & Ethernet-CANbus gateway
woodyboy
 

Re: SOLVED Power icon not updated after external power comma

Postby rjversluis » 30.03.2014, 11:12

Hi Bert,

you asked for this option... :roll:

I made it visible in the setup dialog in case you forget about this option again.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: SOLVED Power icon not updated after external power comma

Postby woodyboy » 30.03.2014, 11:20

Still one question keeps me busy. Why the Rocrail internal power state not changes after the executed action with a STOP command. I should expect that this is independent from the controller. But I can confirm that this is issue is solved too with the reportstate change to true.
Regards,

Bert

Equipment: Roco WLANMaus, MS2, Gleisbox 2x(separated switch & rollingstock). Ubuntu 16. Edits booster. Arduino: S88 CANbus interface & Ethernet-CANbus gateway
woodyboy
 

Re: SOLVED Power icon not updated after external power comma

Postby woodyboy » 30.03.2014, 11:22

O really, I should be ashamed in the most horrible way :oops: :oops: :oops:
Regards,

Bert

Equipment: Roco WLANMaus, MS2, Gleisbox 2x(separated switch & rollingstock). Ubuntu 16. Edits booster. Arduino: S88 CANbus interface & Ethernet-CANbus gateway
woodyboy
 

Re: SOLVED Power icon not updated after external power comma

Postby woodyboy » 01.04.2014, 14:06

Hi Rob,

Did you mean the system command with the sub cmd 9 instead of sub cmd 6?
Regards,

Bert

Equipment: Roco WLANMaus, MS2, Gleisbox 2x(separated switch & rollingstock). Ubuntu 16. Edits booster. Arduino: S88 CANbus interface & Ethernet-CANbus gateway
woodyboy
 

Next

Return to CS2