CS2 S88 Not Working

Märklin Central Station 2

CS2 S88 Not Working

Postby Jvt » 04.07.2015, 07:48

Hello Team

I have setup my CS2 and PC as per the instructions. The PC (Rocrail) and the CS2 are working as I can control locos, point, signals , etc from Rocrail, however I can not get Rocrail to recognise my Sensors. :(

I had them working previously before my old CS2 short circuited and stopped working. So I know that the Sensors were working and should be setup correctly.

Does anyone have any suggestions/recommendations?

Thank you

JVT :rr_for_ever:
Jvt
 

Re: CS2 S88 Not Working

Postby rjversluis » 04.07.2015, 09:03

Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: CS2 S88 Not Working

Postby Jvt » 04.07.2015, 11:07

Hi

Have reviewed the list and I think everything is ok.

I am not a network person but does the fact that my PC IP starts with 192.168 and the CS2 169.254?

:evil: I am really confused!

Thanks again.

JVT
Jvt
 

Re: CS2 S88 Not Working

Postby rjversluis » 04.07.2015, 11:10

Jvt wrote:I am not a network person but does the fact that my PC IP starts with 192.168 and the CS2 169.254?

this cannot work. The first three numbers must be the same.
Example: 192.168.0.*
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: CS2 S88 Not Working

Postby Jvt » 04.07.2015, 11:14

Ah. Ok

So I have tried to change the CS2 IP manually and then align with Rocrail however that didn't work. How do I get both to 192.168.2.x?
Jvt
 

Re: CS2 S88 Not Working

Postby rjversluis » 04.07.2015, 11:17

Sorry, I can't help you with that because I have no CS2 my self.
There are a lot of CS2 users in this forum which could help out.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: CS2 S88 Not Working

Postby Jvt » 04.07.2015, 11:19

Can anyone help? With how to change the IP address on a CS2?
Jvt
 

Re: CS2 S88 Not Working

Postby rjversluis » 04.07.2015, 11:25

Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: CS2 S88 Not Working

Postby Jvt » 04.07.2015, 11:29

Yes. But don't really understand.
Jvt
 

Re: CS2 S88 Not Working

Postby eroncelli » 04.07.2015, 16:44

To set the correct IP address in CS2:

1) go to the "setup" page
2) click on the "wrench" (bottom left of the screen)
3) search the "IP" page with <> arrows
4) chose to set a "manual" address (NO DHCP)
5) set an address like 192.168.2.x
6) set to 255.255.255.0 the Subnet Mask
7) for the time being, don't change the remaining 2 fields

The correct address depends on your network: get the address of your PC ("how to" depends on O.S., generally under "network configuration").
This should be again something like 192.168.1.y (or 192.168.2.y) so you can set the "x" at any value between 1 and 253 (say 100, just a value easy to remember).

If possible, set your PC address to "no DHCP": if DHCP is enabled, the network control manager (the "router", i.e. the "box" where net cables are connected to) could change the addresses and the dialogue between PC and CS2 could messed up (PC address set to 192.168.1.99 for instance).

If any problem, ask again and I will take a "snap" of my CS2/PC configuration.
HO Maerklin, CS2+MS2, PC with Win10, Android phone, electronics by IEK, decoder by Maerklin-ESU-TAMS
".. and let your dog enjoy Rocrail"
eroncelli
 

Re: CS2 S88 Not Working

Postby Jvt » 04.07.2015, 22:03

Thank you.

I have added in the CS2 a IP address of 192.168.2.100, subnet mask 255.255.255.0. I then left the next two as is nothing and 192.168.2.1.

I am on Window 7, and sure that my Router is non DHCP, and I ran Cmd, ipconfig and found my PC IP address of192.168.2.2.

I added this to the CS2 CAN on Broadcast.

Added the 192.168.2.100 in to Rocrail controller properties.

After all that the communication between Rocrail and CS2 does not work! :(

If I then go back in to CS2 IP and change back to DHCP, the IP changes back to 169.254.84.218,which if I update Rocrail, the Rocrail and CS2 work however my sensors (s88) do not work, which is what I am trying to resolve.

Appreciate your further support
JVT
Jvt
 

Re: CS2 S88 Not Working

Postby ups60 » 04.07.2015, 22:50

Jvt wrote:Thank you.

I have added in the CS2 a IP address of 192.168.2.100, subnet mask 255.255.255.0. I then left the next two as is nothing and 192.168.2.1.

I am on Window 7, and sure that my Router is non DHCP, and I ran Cmd, ipconfig and found my PC IP address of192.168.2.2.

I added this to the CS2 CAN on Broadcast.

Added the 192.168.2.100 in to Rocrail controller properties.

After all that the communication between Rocrail and CS2 does not work! :(

If I then go back in to CS2 IP and change back to DHCP, the IP changes back to 169.254.84.218,which if I update Rocrail, the Rocrail and CS2 work however my sensors (s88) do not work, which is what I am trying to resolve.

Appreciate your further support
JVT

First off all, my english isn't very good. But I will try.

If no component in your network is run as DHCP-Server you have to set your CS2 to manually. So the 192.168.2.100 and 255.255.255.0 is right. Broadcast should be set to last adress of your network, I think 192.168.2.254 (or 255) and Gatewayto your PC's adress (192.168.192.2).

Second you have to free in Windowsfirewall the UDP-Ports 15730 and 15731 for rocrail.exe.

Hope this help's.

Uwe
Märklin H0 K-Gleis, CS2 60215 (V4.2.1), Raspi 3 RR-Server, Windows 10, Ubuntu 16.04, Raspi B2+ Rocnetnode, GCA_PI01, GCA_PI02, GBM-Boost + GBM-16T
ups60
 

Re: CS2 S88 Not Working

Postby Jvt » 05.07.2015, 00:51

Your English is very good

I have tried again and it just doesn't work.

But every time I put back in the 169.254.x.x it works perfectly except for the Senors S88 :?
Jvt
 

Re: CS2 S88 Not Working

Postby ups60 » 05.07.2015, 02:12

Jvt wrote:Your English is very good

I have tried again and it just doesn't work.

But every time I put back in the 169.254.x.x it works perfectly except for the Senors S88 :?


Have you restart your CS2 after changing your IP-Adresses. Other it won't react on your LAN-changes? (restart)

Greetings Uwe
Märklin H0 K-Gleis, CS2 60215 (V4.2.1), Raspi 3 RR-Server, Windows 10, Ubuntu 16.04, Raspi B2+ Rocnetnode, GCA_PI01, GCA_PI02, GBM-Boost + GBM-16T
ups60
 

Re: CS2 S88 Not Working

Postby ups60 » 05.07.2015, 02:24

Jvt wrote:Your English is very good

I have tried again and it just doesn't work.

But every time I put back in the 169.254.x.x it works perfectly except for the Senors S88 :?

This works about it's broadcast, but not working in your network. You have first to find out that your Cs2 is in the same Network as your LAN.

Uwe
Märklin H0 K-Gleis, CS2 60215 (V4.2.1), Raspi 3 RR-Server, Windows 10, Ubuntu 16.04, Raspi B2+ Rocnetnode, GCA_PI01, GCA_PI02, GBM-Boost + GBM-16T
ups60
 

Next

Return to CS2