Sensor status on status bar for CBUS

http://www.merg.org.uk/merg_resources/cbus.php
Post Reply
joergseiler
Posts: 3
Joined: 21.07.2019, 13:26

Sensor status on status bar for CBUS

Post by joergseiler » 08.09.2019, 05:32

Hello,

I have created my own command station based on the STM32F205RGY6 120Mhz ARM Cortex M3 processor using the MERG CANbus protocol.

All is well and rocrail is successfully controlling trains.

I have one question though. The sensor status on the status bar at the bottom right hand corner of the Rocrail widnow does not turn green like the other indicators.

I am using short messages events 0x98 (ASON) and 0x99 (ASOF) to successfully get sensor information to Rocrail. All sensors report correctly at Start of Day and during operation.

Exactly what message, opcode, is Rocrail looking for to show sensor status green.

I have read the wiki and for the status bar is says not all command stations report a separate status for sensor and accessories. Since I am coding my own command station I'd like it to report this status correctly. I have also found the same topic regarding the S88 bus but that did not answer my question.

Thanks for any help you can offer.

rjversluis
Site Admin
Posts: 42384
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: Sensor status on status bar for CBUS

Post by rjversluis » 08.09.2019, 07:09

Hi,

CBUS does not feature a separate Sensor Bus, so you can ignore this indicator.

joergseiler
Posts: 3
Joined: 21.07.2019, 13:26

Re: Sensor status on status bar for CBUS

Post by joergseiler » 10.09.2019, 04:18

Thank you, that puts my mind at ease.

Post Reply

Return to “mergCBUS”