Getting started with CBUS

http://www.merg.org.uk/merg_resources/cbus.php

Getting started with CBUS

Postby svesch » 20.02.2015, 22:25

I have recently bought a GC1 (USB version) and GC6 from Peter and build them up last week. This evening I was going to setup the "CAN network" with Rocrail. The short version: I have failed...

The long story:
I have added a controller of type cbus. Settings are Serial, 230400 no handshake. What to set for CANID? All other settings are default.
And now? What next? Selected menu "Programming|CBUS" and tried to QUERY the bus. Brings no results. Do not even know if this is correct...
First of all: How can I see if communication with GC1 works?

Thanks for any help and hints.

Sven
svesch
 

Re: Getting started with CBUS

Postby rjversluis » 21.02.2015, 08:40

Hi Sven,

just post your rocrail.*.trc and rocrail.ini.
Did you double check the self build CBUS kits?
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Getting started with CBUS

Postby svesch » 21.02.2015, 11:39

There was an error in cable, CANH and CANL were interchanged. Also I have installed the latest Rocrail version. I did not get offered COM16 by the system so entered it manually in controller settings. Handshake stayed disabled. After restarting it I was able to query the GC6. The LED L1 at the GC6 is flashing when something happens which is a bit helpful. But the GC1 is somewhat quiet so that no one can see if there is something going on. Would be helpful for first steps if there would be some feedback from GC1. Only as recommendation.

Other question: For what the push button on GC6 is for?
svesch
 

Re: Getting started with CBUS

Postby phil45 » 21.02.2015, 22:39

Hi Sven

I think that the push button is for the FLim learning mode.
See http://wiki.rocrail.net/doku.php?id=cbus:flim-en for details.

sorry but i can say nothing else, i don't use CBUS :(

Philippe .
OS=(GNU Linux/Debian & Android) - Scale=N - Command Station=Digitrax DB150/GCA101 - Bus=Loconet - Hardware=GCA
phil45
 

Re: Getting started with CBUS

Postby svesch » 22.02.2015, 17:38

Ok, I probably wont need the push button for now (only if CAN ID shall be changed).

Next question is how I map servo 1 of GC6 (on address 112) to a switch command.

See attached my rocrail.ini. I have changed sw1 for controlling the first servo. I have tried port 0, 1, 5. But it does not work. I see the CAN activity LED flashing but the servo is not turned. What other parameters have to be changed?
You do not have the required permissions to view the files attached to this post.
svesch
 

Re: Getting started with CBUS

Postby rjversluis » 22.02.2015, 18:26

Maybe a short look in the Wiki could help:
http://wiki.rocrail.net/doku.php?id=cbus-en#addressing
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Getting started with CBUS

Postby svesch » 22.02.2015, 20:04

Ok, that helped.
I have used the method try and error and finally got it to work: I have to set the bus property to 112 (which is not only the CAN ID but also the node number) and the address property to 0 (the event number which can be seen in the CBUS/GCA6 programming dialog). The port must be set to 1.

For servo 2 the event number is 6 and so on...

Thank you well!
svesch
 


Return to mergCBUS