Crash with Canbus board

http://wiki.rocrail.net/doku.php?id=roc ... netnode-en

Crash with Canbus board

Postby MStoeckle » 08.12.2016, 15:49

Hi Rob,

Cool -thanks very much. Nevertheless, if the Canbus board is installed (without loading its drivers), Rocnetnode crashes with a core dump, log saying setsockopt () no such device.

Maybe the GPIO port is initialized regardless whether it's used or not?

Greets, Martin
MStoeckle
 

Re: Rocrail sources access.

Postby rjversluis » 10.12.2016, 16:30

MStoeckle wrote:Hi Rob,

Cool -thanks very much. Nevertheless, if the Canbus board is installed (without loading its drivers), Rocnetnode crashes with a core dump, log saying setsockopt () no such device.

Maybe the GPIO port is initialized regardless whether it's used or not?

Greets, Martin

Just attach the core dump so I can fix it.
Best Regards, Rob.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Rocrail sources access.

Postby MStoeckle » 10.12.2016, 19:46

Hi Rob,

thanks for looking at the core dump - here it is along with nohup.out and .trc.

Best regards, Martin

rjversluis wrote:
MStoeckle wrote:Hi Rob,

Cool -thanks very much. Nevertheless, if the Canbus board is installed (without loading its drivers), Rocnetnode crashes with a core dump, log saying setsockopt () no such device.

Maybe the GPIO port is initialized regardless whether it's used or not?

Greets, Martin

Just attach the core dump so I can fix it.
You do not have the required permissions to view the files attached to this post.
MStoeckle
 

Re: Crash with Canbus board

Postby MStoeckle » 29.01.2017, 16:21

Hi Rob,

in the latest build of RocNetNode problem seems to be fixed - at least it works in my setup now.

Thanks!
MStoeckle
 


Return to RocNetNode