[erledigt]rocweb verbindung zum Server

[erledigt]rocweb verbindung zum Server

Postby GeSchu » 04.01.2018, 21:06

Moin Zusammen,
zunächst ein frohes Neues an alle Mitstreiter. Kommen wir gleich zur Sache:
Zu Weihnachten gab es ein neues Tablet, Samsung Galaxy SM-T280. Dieses wurde sogleich an der Bahn ausprobiert. Rocweb funktionierte einwandfrei. Spaßeshalber auch mal andRoc installiert. Auch alles Okay. AndRoc habe ich wieder deinstalliert. Dann alles ausgeschaltet. Damit meine ich das ganze Equipment, die Bahn, jeden PC, den Raspi, eben alles. Dann ab in den Urlaub. Gestern habe ich dann alles wieder angeschaltet und zunächst den Raspi und dann rocrail per kompiling auf den neuesten Stand ( version 13336) sowohl als Server auf dem raspi als auch als Client auf dem MAC gebracht. Per rocview alles okay, jedoch per Rocweb nicht. Der Gleisaufbau, sowohl auf dem MAC wie auf dem Samsung im firefox 57.0.3 dauert ewig. Mit ewig meine ich: Nach einer halben Stunde habe ich das Ganze abgebrochen.
Netstat -an auf dem raspi zeigt:
Code: Select all
Aktive Internetverbindungen (Server und stehende Verbindungen)
Proto Recv-Q Send-Q Local Address           Foreign Address         State     
tcp        0      0 0.0.0.0:8051            0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:8088            0.0.0.0:*               LISTEN     
tcp        0      0 192.168.178.23:8088     192.168.178.32:40987    TIME_WAIT 
tcp        0      0 192.168.178.23:22       192.168.178.20:51646    VERBUNDEN 
tcp      188      0 192.168.178.23:8088     192.168.178.32:44674    VERBUNDEN 
tcp      291      0 192.168.178.23:8088     192.168.178.32:40988    VERBUNDEN 
udp        0      0 0.0.0.0:51939           0.0.0.0:*                         
udp        0      0 0.0.0.0:68              0.0.0.0:*                         
udp        0      0 192.168.178.23:123      0.0.0.0:*                         
udp        0      0 127.0.0.1:123           0.0.0.0:*                         
udp        0      0 0.0.0.0:123             0.0.0.0:*     

Ping Zeiten MAC <-> raspi sind auch okay, siehe
Code: Select all
ping pimoba
PING pimoba.fritz.box (192.168.178.23): 56 data bytes
64 bytes from 192.168.178.23: icmp_seq=0 ttl=64 time=0.795 ms
64 bytes from 192.168.178.23: icmp_seq=1 ttl=64 time=0.608 ms
64 bytes from 192.168.178.23: icmp_seq=2 ttl=64 time=0.654 ms
64 bytes from 192.168.178.23: icmp_seq=3 ttl=64 time=0.621 ms
64 bytes from 192.168.178.23: icmp_seq=4 ttl=64 time=0.600 ms
64 bytes from 192.168.178.23: icmp_seq=5 ttl=64 time=0.526 ms
64 bytes from 192.168.178.23: icmp_seq=6 ttl=64 time=0.585 ms
^C
--- pimoba.fritz.box ping statistics ---
7 packets transmitted, 7 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 0.526/0.627/0.795/0.078 ms

192.168.178.20 ist der MAC, x.x.x.32 ist das Tablett, x.x.x.23 ist der raspi.
Auf einem Handy habe ich noch andRoc installiert. Eine Verbindung zum rocrail Server ist da gar nicht möglich. ssh zum raspi geht einwandfrei. Was könnte hier passiert sein?
Gruß
Gerd(GeSchu)
Last edited by GeSchu on 06.01.2018, 15:47, edited 1 time in total.
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: rocweb verbindung zum Server

Postby peter&basti » 04.01.2018, 23:20

Hallo Gerd,

und zunächst den Raspi und dann rocrail per kompiling auf den neuesten Stand ( version 13336)


Du und ich, wir sind doch erfahrene Techniker, oder nicht?

Mein erster Ansatz wäre:

- die letzte nachgewiesen funktionierende Release zu installieren (die vor Deinem Urlaub)
- wenn dann alles klappen sollte, die Release Notes lesen
- wenn da was auffälliges (zum Problem passendes) zu entdecken ist, bei Rob konkreter nachfragen....

Wenn der Rückstieg auch nicht klappt, dann muss ein zweiter Ansatz her (den habe ich aber nicht parat)
Liebe Grüße / best regards
Peter


System: DCC 2-Leiter H0, Rocrail 64bit auf Win10 Pro 64
Traktion: OpenDCC GBM
Fahrweg: RocNetNode & GCA PI01/2/3, GCA41/Arduino RFID, GCA145 Drehscheibe, etc.
Decoder: 99% Zimo
Experimentell: MQTT & Node-Red
peter&basti
 

Re: rocweb verbindung zum Server

Postby peter&basti » 04.01.2018, 23:23

Hallo Gerd,

es gibt seit Weihnachten einen einzigen commit zum Thema Rocweb:

Code: Select all
13289 2017-12-27 09:41:27 +0100 http: prevent deadlock in the rocwweb broadcast service
Liebe Grüße / best regards
Peter


System: DCC 2-Leiter H0, Rocrail 64bit auf Win10 Pro 64
Traktion: OpenDCC GBM
Fahrweg: RocNetNode & GCA PI01/2/3, GCA41/Arduino RFID, GCA145 Drehscheibe, etc.
Decoder: 99% Zimo
Experimentell: MQTT & Node-Red
peter&basti
 

Re: rocweb verbindung zum Server

Postby Pirat-Kapitan » 05.01.2018, 00:27

GeSchu wrote:Auf einem Handy habe ich noch andRoc installiert. Eine Verbindung zum rocrail Server ist da gar nicht möglich. ssh zum raspi geht einwandfrei. Was könnte hier passiert sein?
Gruß
Gerd(GeSchu)

Moin Gerd,
welche Fehlermeldung erscheint denn, wenn Du per andRoc Dich mit dem Server verbinden willst?
Hast Du es mal mit einem fertigen Installationspaket für den RasPi als Alternative probiert?
Meine erste Vermutung wäre, dass Du Rocrail in mehr als 1 Instanz auf dem RasPi laufen hast.

Schöne Grüße
Johannes
Clearasilfahrer auf Spur G, Lenz LZV (3.6), ORD-20, Manhart-Funki und WLM, RS-Bus Rückmelder (Reedkontakte),
Rocrail auf RasPi ("raspiRoc") mit mobilen Geräten (andRoc). Details auf http://wiki.rocrail.net/doku.php?id=use ... at-kapitan.
Pirat-Kapitan
 

Re: rocweb verbindung zum Server

Postby AndKie » 05.01.2018, 10:29

Hallo Gemeinde,

ich bekomme Rocweb, auf dem Festrechner und dem Tablet seit Neuestem auch nur sehr langsam und zögerlich ans laufen, androc hingegen funktioniert auf dem Smartphone und Tablet wie gewohnt einwandfrei!
Da ich ein kleineres, älteres Tablet habe, 7", mit Android 4.4, nutze ich sowieso lieber androc, das ist da viel praktikabler und besser, schneller.
Die Darstellung und Handhabung von Rocweb auf dem Tablet, über den Browser, (Firefox) ist da nicht lustig.


Rocrail-Server2.0 13346 auf dem Raspberry 3 Stretch

Gruß
Andreas
H0, Open Source, DR5000, RaspberryPi III, - I2C Bus
AndKie
 

Re: rocweb verbindung zum Server

Postby rjversluis » 05.01.2018, 10:58

Moin,

da ist der Wurm drin...
Ich bin schon dran was es sein kann.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: rocweb verbindung zum Server

Postby rjversluis » 05.01.2018, 11:23

Moin,

ist jetzt wieder iO.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: rocweb verbindung zum Server

Postby GeSchu » 05.01.2018, 19:03

Moin zusammen,
ich bin noch unterwegs, habe aber bereits meinen ersten Feierabend in diesem Jahr.
Zum Thema:
@Peter:
Recht hast Du, mit allen was du schreibst. Was ich in meiner Problembeschreibung nicht schrieb: Natürlich habe ich mit dem ersten Anschalten probiert, ob noch alles geht. Es hätte ja auch an der Hauselektrik, am Router, etc pp liegen können. Mit der alten installierten Version klappte alles noch. Ich muss noch genauer mit meinen Beschreibungen werden.
@Johannes:
Das Verwunderliche war: Es gab keine Fehlermeldung. Auch in den, das Netzwerk betreffenden log Dateien auf dem raspi war kein Fehlverhalten zu erkennen.
Nun, Rob hat den Fehler ja augenscheinlich schon gefunden und behoben.
@Rob:
danke für die schnelle Reaktion. Komme erst morgen zum Testen.
Vielen Dank an Alle für die Tipps.
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: [erledigt]rocweb verbindung zum Server

Postby GeSchu » 06.01.2018, 15:47

Moin Rob,
geht wieder. Danke dafür.
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 


Return to Rocweb (DE)