Search found 50 matches

by applor
16.05.2019, 21:53
Forum: Automatic mode
Topic: trains stopping at Shortin event - live mode only
Replies: 3
Views: 140

Re: trains stopping at Shortin event - live mode only

I just wanted to come back and post an update that I did discover the problem. This issue was being caused by a sensor fault which would flicker when the preceding sensor was activated, causing the premature IN event. I had to closely observe on my live layout what was happening and then discovered ...
by applor
04.03.2019, 06:36
Forum: Automatic mode
Topic: feature request - block additional event or sensor action ctrl retrieve block locoID
Replies: 8
Views: 249

Re: feature request - block additional event or sensor action ctrl retrieve block locoID

I found some time to work on this today and test. I have it working with the below script. This will activate the function for whistle or horn for a second for the loco leaving Block 35: <?xml version="1.0" encoding="UTF-8"?> <xmlscript> <query vr="lcid" table="bklist" id="35" get="locid"/> <fn id="...
by applor
13.02.2019, 23:20
Forum: Automatic mode
Topic: feature request - block additional event or sensor action ctrl retrieve block locoID
Replies: 8
Views: 249

Re: feature request - block additional event or sensor action ctrl retrieve block locoID

Hi Rob/Peter, Thanks for your response and solution, though I am having some issues. When I first implemented the XML script and virtual tested, it worked for the VT8.5 . However the Horn stayed on permanently so it needed a duration. Also, I need to use Function description rather than a function n...
by applor
12.02.2019, 22:16
Forum: Automatic mode
Topic: BBT steps = 0
Replies: 2
Views: 168

Re: BBT steps = 0

Ignore that - as soon as the locomotive uses that block Rocrail will automatically set it to 10 steps and do initial values for deceleration etc. In fact, you do not even need to manually add a BBT entry for a loco. If the block has BBT enabled and so does the loco, Rocrail will automatically create...
by applor
12.02.2019, 22:11
Forum: Automatic mode
Topic: feature request - block additional event or sensor action ctrl retrieve block locoID
Replies: 8
Views: 249

Re: feature request - block additional event or sensor action ctrl retrieve block locoID

Hello! Maybe you would think of a crossing block ? Crossing block events are not triggered (it does not register Enter or In events, sensor events are ignored on crossing blocks) so this does not allow you to trigger an action with it. Hi Eric, I then have a third short sensor after the signal and ...
by applor
11.02.2019, 00:16
Forum: Automatic mode
Topic: feature request - block additional event or sensor action ctrl retrieve block locoID
Replies: 8
Views: 249

feature request - block additional event or sensor action ctrl retrieve block locoID

Hello, I have a bit of a plan problem I need suggestions with or perhaps feature addition. It is best for me to explain the scenario: There is a length of track with a stop signal and then a tunnel shortly after. In rocrail I have a block configured with two sensors, an ENTER sensor and then an IN s...
by applor
10.02.2019, 22:18
Forum: Automatic mode
Topic: trains stopping at Shortin event - live mode only
Replies: 3
Views: 140

Re: trains stopping at Shortin event - live mode only

Hi Eric, some blocks have shortin events and some locos are using shortin. So whats the problem? BTW: I also saw that you are using IN delays of 2 seconds... The problem is the locos / trains that are stopping at shortin do not have the it enabled. Look at my example - the E75 05 and train E52 mixe...
by applor
10.02.2019, 01:52
Forum: Automatic mode
Topic: trains stopping at Shortin event - live mode only
Replies: 3
Views: 140

trains stopping at Shortin event - live mode only

Hello, I've been experiencing an unusual issue with Rocrail. For some reason my trains are stopping at the Shortin sensor event in some blocks (Blocks 04 and 05 identified) when the loco and train are not set to use the Shortin event. What is more, I am unable to reproduce the problem using simulate...
by applor
06.02.2019, 23:39
Forum: Automatic mode
Topic: Block 'IN' sensor event timer not working
Replies: 4
Views: 172

Re: Block 'IN' sensor event timer not working

Hi Claus, Thanks for taking the time to solve this problem for me. You are right the problem was the loco event timer which I did not realise had been set on some of the locos to 200ms. None of my locos should have had an event timer set. Probably from very early on when I was still learning Rocrail...
by applor
06.02.2019, 03:11
Forum: General
Topic: Rocrail in Australia
Replies: 14
Views: 1368

Re: Rocrail in Australia

My Brisbane layout linked earlier now has full automation going with complex routes, signals, actions etc.

Loving Rocrail.
by applor
05.02.2019, 23:24
Forum: Automatic mode
Topic: Block 'IN' sensor event timer not working
Replies: 4
Views: 172

Block 'IN' sensor event timer not working

Hello, I use the Block Event Timers a fair bit and it works great except one particular block which does not and I have not been able to determine why. On my plan Block 36 has + side sensor M2-12 and configured with Event timer 1 of 5000ms. However as soon as a train activates the IN sensor, the blo...
by applor
24.01.2019, 23:35
Forum: Automatic mode
Topic: loco/train does not randomise routes
Replies: 9
Views: 295

Re: loco/train does not randomise routes

Hi Hermann, Yes I see your point and that it is working as per the documentation, though disappointing as I am forced to choose between correct stop locations in my staging yards or randomization through my main station. I can work around the issue at least, I have configured my staging yard with in...
by applor
23.01.2019, 05:40
Forum: Automatic mode
Topic: swap timer does not zero throttle after 'in' event
Replies: 2
Views: 129

swap timer does not zero throttle after 'in' event

Hello, Another auto mode issue I am having. I have routes in a terminus station which have 'swap placing post', so that the locomotive swaps travelling direction at a dead end block. In this example, loco BR 80 032 is in block 86 and travels to block 77 where it must reverse so it can travel to bloc...
by applor
23.01.2019, 03:57
Forum: Automatic mode
Topic: loco/train does not randomise routes
Replies: 9
Views: 295

Re: loco/train does not randomise routes

OK I have done more testing and found the problem! Testing has shown it working correctly with 'select shortest block' disabled. However if I enable 'select shortest block' and all the blocks are the same length, then auto mode always selects the first route instead of random rate. What I expect to ...

Go to advanced search