(erledigt) Clients via RocWeb verbinden geht nicht

(erledigt) Clients via RocWeb verbinden geht nicht

Postby gartenbahn » 14.02.2017, 20:23

Hallo,
habe alle Einstellung gefixt, Rocrail funktioniert vom Latop aus, angeschlossen an einem W-Lanrouter und Interface an die Zentrale, alles per LanKabel, fahren, schalten alles ok.
Doch nun habe ich die Einstellungen so wie hier beschrieben
http://wiki.rocrail.net/doku.php?id=rocweb:rocweb-de
gemacht, aber es geht gar nichts. Ich bekomme keinen Client an den Server.
Nun stehe ich an und weiss nicht wo suchen, ev. habe ich was nicht oder falsch eingetragen, aber was und wo?
Nun bitte ich um Tipps, welche Partien/Listen ich kontrollieren muss, oder wie ich vorgehen soll um doch noch ans Ziel zu kommen.
Mit dem bereits aufgelisteten Link komme ich nicht ans Ziel.

Danke für eure Hinweise.
Gruss Edy
Last edited by gartenbahn on 19.02.2017, 17:24, edited 1 time in total.
Schöne Grüsse Edy

LENZ LZV 100 und LV200
Lenz-LAN/USB-Interface
LH 100,
I Pad via LAN direkt an LENZ
Decoder ZIMO, Massoth, LENZ
gartenbahn
 

Re: Clients via RocWeb verbinden geht nicht

Postby GeSchu » 14.02.2017, 20:36

Moin Edy,
also, fangen wir mal an zu fragen. Das weitere Vorgehen ist von den Antworten abhängig.
Du hast einen gültigen Key?
Du kennst den Namen, resp. die IP Adresse des Rechners, auf dem der Server läuft?
Du hast in Rocrail->Eigenschaften->Tab RocWeb einen Port, ideallerweise 53702 eingetragen?
Unter Pfad in dem Tab steht der Name "web"?
Du hast in einen Browser Deiner Wahl in die Adresszeile eingegeben: <Name oder IP des Rechners>:53702?
Was zeigt der Browser an?
Achja: Welchen Browser nutzt du?
Gruß
Gerd(Geschu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Clients via RocWeb verbinden geht nicht

Postby Schorse » 14.02.2017, 21:59

Moin Gerd,

Du hast in Rocrail->Eigenschaften->Tab RocWeb einen Port, ideallerweise 53702 eingetragen?
Ist das nicht eine Portnummer für die "alten" HTTP-Dienste?
Als ideal würde ich den Port 8088 (wie im Wiki erwähnt) bezeichen; dieser ist m. W. nicht standardisiert.
Viele Grüße Gerd
Schorse
 

Re: Clients via RocWeb verbinden geht nicht

Postby gartenbahn » 14.02.2017, 22:00

Hallo Gerd
vorab einmal Danke, dass du dich meinem Problem annimmst.

Gültiger Key ist beantragt, noch nicht eingetragen, sollt ja 5 Minuten ohne Schlüssel gehen, oder?
IP Adresse des PCs wo der Server drauf läuft kenne ich, FixIP 192.168.030.
Port habe ich 8051 eingetragen, da der PC meldet localhost: 8051
nach dieser Eingabe wird gesucht und gesucht: Dann Mitteilung: webseite (IP) ist nicht erreichbar, hat zu lange gedauert.
Habe auch die Eingabe 53702 probiert, gleiches Ergebnis.
Browser ist chrome

Gruss Edy
Schöne Grüsse Edy

LENZ LZV 100 und LV200
Lenz-LAN/USB-Interface
LH 100,
I Pad via LAN direkt an LENZ
Decoder ZIMO, Massoth, LENZ
gartenbahn
 

Re: Clients via RocWeb verbinden geht nicht

Postby GeSchu » 14.02.2017, 22:06

Moin Edy,
gartenbahn wrote:Hallo Gerd
vorab einmal Danke, dass du dich meinem Problem annimmst.

Gültiger Key ist beantragt, noch nicht eingetragen, sollt ja 5 Minuten ohne Schlüssel gehen, oder?
IP Adresse des PCs wo der Server drauf läuft kenne ich, FixIP 192.168.030.
Port habe ich 8051 eingetragen, da der PC meldet localhost: 8051
nach dieser Eingabe wird gesucht und gesucht: Dann Mitteilung: webseite (IP) ist nicht erreichbar, hat zu lange gedauert.
Habe auch die Eingabe 53702 probiert, gleiches Ergebnis.
Browser ist chrome

Okay, das ist nicht die IP Adresse. Deswegen wird auch nix gefunden. Kennst Du dich ein wenig mit Netzwerktechnik aus?
Eine IP-Adresse besteht aus 4 Segmenten . Was Du oben als IP Adresse interpretierst sind nur 3 Segmente. Es fehlt das vierte. Es muss noch eine Zahle zwischen 001 und 254 folgen.
Der Rechner, auf dem der Server läuft hat die IP-Adresse 192.168.030.xxx. Besser wäre, wenn der Name des Rechners bekannt wäre.
8051 ist nicht der Port für RocWeb sondern für rocrail. Das ist etwas anderes. Trage also bitte als Port 53702 oder 8088 ein.
Gruß
Gerd(GeSchu)
Last edited by GeSchu on 14.02.2017, 22:18, edited 3 times in total.
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Clients via RocWeb verbinden geht nicht

Postby GeSchu » 14.02.2017, 22:11

Moin Gerd,
Schorse wrote:Moin Gerd,

Du hast in Rocrail->Eigenschaften->Tab RocWeb einen Port, ideallerweise 53702 eingetragen?
Ist das nicht eine Portnummer für die "alten" HTTP-Dienste?
Als ideal würde ich den Port 8088 (wie im Wiki erwähnt) bezeichen; dieser ist m. W. nicht standardisiert.

Du hast recht. jedoch funktioniert 53702 genauso gut wie 8088. Wichtig ist, das der Port nicht von einem anderen Programm genutzt wird. Ich habe in meinem Netzwerk beide probiert. Funktionieren beide einwandfrei.
Nebenbei: Der Port für die alten WEB Dienste hieß 53701, glaube ich.
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Clients via RocWeb verbinden geht nicht

Postby Pirat-Kapitan » 14.02.2017, 22:21

Moin Edy,
Deine Adresse für den Browser heißt 192.168.0.30:8088 (vorausgesetzt, Du hast wie im Wiki beschrieben als Port für RocWeb 8088 eingetragen).

Bitte Deine rocrail.ini mal hier anhängen (Du weißt doch, vertrauen ist gut, Kontrolle ist besser).

Schöne Grüße
johannes
Last edited by Pirat-Kapitan on 14.02.2017, 22:23, edited 1 time in total.
Clearasilfahrer auf Spur G&H0m, Lenz LZV (3.6), ORD-20, Manhart-Funki und WLM, RS-Bus Rückmelder (Reedkontakte/GBM),
Rocrail auf RasPi mit mobilen Geräten (andRoc). Details auf http://wiki.rocrail.net/doku.php?id=use ... at-kapitan.
Pirat-Kapitan
 

Re: Clients via RocWeb verbinden geht nicht

Postby gartenbahn » 14.02.2017, 22:22

Hier noch ein bild der Einstellungen RocWeb
You do not have the required permissions to view the files attached to this post.
Schöne Grüsse Edy

LENZ LZV 100 und LV200
Lenz-LAN/USB-Interface
LH 100,
I Pad via LAN direkt an LENZ
Decoder ZIMO, Massoth, LENZ
gartenbahn
 

Re: Clients via RocWeb verbinden geht nicht

Postby Pirat-Kapitan » 14.02.2017, 22:23

bitte deinen Port auf 8088 ändern !

Die Dateipfade bei Themen 2 und Themen 3 sind falsch ( / gegen \)

Schöne Grüße
johannes
Clearasilfahrer auf Spur G&H0m, Lenz LZV (3.6), ORD-20, Manhart-Funki und WLM, RS-Bus Rückmelder (Reedkontakte/GBM),
Rocrail auf RasPi mit mobilen Geräten (andRoc). Details auf http://wiki.rocrail.net/doku.php?id=use ... at-kapitan.
Pirat-Kapitan
 

Re: Clients via RocWeb verbinden geht nicht

Postby gartenbahn » 14.02.2017, 22:33

Hallo
ich habe nun den Port geändert. Nun werde ich noch die / Zeichen ändern.

Im Anhang die Daten, hoffe, es sind die richtigen.
Gruss
You do not have the required permissions to view the files attached to this post.
Schöne Grüsse Edy

LENZ LZV 100 und LV200
Lenz-LAN/USB-Interface
LH 100,
I Pad via LAN direkt an LENZ
Decoder ZIMO, Massoth, LENZ
gartenbahn
 

Re: Clients via RocWeb verbinden geht nicht

Postby gartenbahn » 14.02.2017, 22:35

Hallo
mit der Eingabe:
192.168.0.30:8088 und den der Portänderung gehts auch nicht

Gruss
Schöne Grüsse Edy

LENZ LZV 100 und LV200
Lenz-LAN/USB-Interface
LH 100,
I Pad via LAN direkt an LENZ
Decoder ZIMO, Massoth, LENZ
gartenbahn
 

Re: Clients via RocWeb verbinden geht nicht

Postby gartenbahn » 14.02.2017, 22:40

Neueste Einstellungen

Mein Laptop hat ein Win10 home als Betriebssystem, macht das ev. was aus?
You do not have the required permissions to view the files attached to this post.
Schöne Grüsse Edy

LENZ LZV 100 und LV200
Lenz-LAN/USB-Interface
LH 100,
I Pad via LAN direkt an LENZ
Decoder ZIMO, Massoth, LENZ
gartenbahn
 

Re: Clients via RocWeb verbinden geht nicht

Postby gartenbahn » 14.02.2017, 23:44

Hallo,
ich habe noch im Laptop gesucht und gesehen, dass Rocrail an 2 Orten gespeichert ist:
1. Im Ordner Programme(c86)
2. Im Ordner Dokumente
Ich vermute, dass die aktuellen Daten stets im Ordner Dokumente abgelegbt werden.
Kann der das Programm oder die Daten nicht gefunden werden?
Wäre allenfalls eine Neuistallation von RocRail sinnvoll?

Gruss
You do not have the required permissions to view the files attached to this post.
Schöne Grüsse Edy

LENZ LZV 100 und LV200
Lenz-LAN/USB-Interface
LH 100,
I Pad via LAN direkt an LENZ
Decoder ZIMO, Massoth, LENZ
gartenbahn
 

Re: Clients via RocWeb verbinden geht nicht

Postby rjversluis » 15.02.2017, 06:19

Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
rjversluis
Site Admin
 

Re: Clients via RocWeb verbinden geht nicht

Postby Pirat-Kapitan » 15.02.2017, 06:22

Moin Edy,
Firewall muss für Rocrail geöffnet sein.
Du solltest einfach die korrekte Rocrail.ini nehmen.
Neuinstallation macht nur Sinn, wenn Du alle Rocraildaten und - informationen löscht und anschliessend ohne Experimente Rocrail korrekt installierst.

Im Übrigen ist Robs Tip nichtzu verachten.

Schöne Grüße
Johannes
Clearasilfahrer auf Spur G&H0m, Lenz LZV (3.6), ORD-20, Manhart-Funki und WLM, RS-Bus Rückmelder (Reedkontakte/GBM),
Rocrail auf RasPi mit mobilen Geräten (andRoc). Details auf http://wiki.rocrail.net/doku.php?id=use ... at-kapitan.
Pirat-Kapitan
 

Next

Return to Rocweb (DE)