Mit Build 14738 wird Server mit installiert, ab Build 14741 nicht mehr? Topic is solved

Post Reply
Housefred
Posts: 5
Joined: 18.09.2013, 16:26
Location: Fritzlar

Mit Build 14738 wird Server mit installiert, ab Build 14741 nicht mehr?

Post by Housefred » 11.05.2019, 18:11

Hallo,

ich habe heute versucht auf meinem neuen Raspberry Pi3 B+ mit Raspbian/Noobs das aktuelle Raspbian-Stretch Build 15399 zu installieren, leider nur mit mäßigen Erfolg.

Es werden lediglich RocControl, RocView und RocWeb installiert, der Server fehlt.

Ich bin dann in den Builds Rückwärts gegangen bis zum Build 14738, hier wird der Server mit installiert, ab 14741 aufwärts nicht mehr.

Die Revisionsinfo geht leider nur bis Build 15300 https://wiki.rocrail.net/rocrail-snapshot/log.txt

Was hat sich geändert oder habe ich übersehen?

Mit dieser Befehlszeile aus dem Wiki https://wiki.rocrail.net/doku.php?id=raspi:raspi-dev-en :
Bekomme ich die Fehlermeldung:
pi@raspberrypi:~ $ wget https://rocrail.net/software/rocrail-sn ... -armhf.deb
--2019-05-11 19:02:48-- https://rocrail.net/software/rocrail-sn ... -armhf.deb
Auflösen des Hostnamens »rocrail.net (rocrail.net)« … 2a00:1158:2d:300::ef, 134.119.234.239
Verbindungsaufbau zu rocrail.net (rocrail.net)|2a00:1158:2d:300::ef|:443 … verbunden.
FEHLER: Dem Zertifikat von »rocrail.net« wird nicht vertraut.
FEHLER: Das Zertifikat von »»rocrail.net«« wurde von einem unbekannten Austeller herausgegeben.
Der Zertifikat-Eigentümer passt nicht zum Hostname »»rocrail.net««.
pi@raspberrypi:~ $
Keine Ahnung ob das was damit zu tun hat.

Für Hinweise, wo ich suchen muss, wäre ich dankbar.

Gruß
Matthias

LDG
Site Admin
Posts: 2686
Joined: 18.10.2010, 00:03
Location: near Karlsruhe/Germany

Re: Mit Build 14738 wird Server mit installiert, ab Build 14741 nicht mehr?

Post by LDG » 11.05.2019, 19:53

Hallo Matthias,

das Zertifikat des Servers ist auf den Provider (webserver.ispgateway.de) ausgestellt. Deshalb gibt es sowohl mit den gängigen Browsern als auch mit wget eine Warnung wenn man dort mit "rocrail.net" ankommt.

Versuche den Download mit http statt https

Code: Select all

wget http://rocrail.net/software/rocrail-snapshot/rocrail-15399-raspbian-stretch-armhf.de
oder nimm bei https die Prüfung des Serverzertifikates temporär für diesen Download raus

Code: Select all

wget --no-check-certificate https://rocrail.net/software/rocrail-snapshot/rocrail-15399-raspbian-stretch-armhf.deb
Gruß,
Lothar

ups60
Posts: 1034
Joined: 30.07.2013, 17:36
Location: 50321 Brühl

Re: Mit Build 14738 wird Server mit installiert, ab Build 14741 nicht mehr?

Post by ups60 » 11.05.2019, 19:55

Hallo Matthias,

da scheint was mit der gesicherten Verbindung nicht zu stimmen, versuch's mal mit http anstatt https.

mfg Uwe

ps: Lothar war schneller

roco007
Posts: 111
Joined: 10.11.2012, 23:28

Re: Mit Build 14738 wird Server mit installiert, ab Build 14741 nicht mehr?

Post by roco007 » 11.05.2019, 20:13

Hallo Mathias,
Blöde Frage: Wie stellst du fest, dass der Server nicht installiert wird? Wenn ich mich richtig erinnere wurde igendwann die Methode den Server zu starten umgestellt, jetzt wird er im user modus gestartet und nicht mehr als service. Dadurch gibt es vielleicht kein /etc/init.d/rocrail mehr. Aber eigentlich sollte es den server, also das binary rocrail noch geben und mitinstalliert werden.
Irgendwo gibt es was wie der Server jetzt über cron oder crontab gestartet wird ( ich verwende immer noch /etc/init.d/rocrail).
Uli

Housefred
Posts: 5
Joined: 18.09.2013, 16:26
Location: Fritzlar

Re: Mit Build 14738 wird Server mit installiert, ab Build 14741 nicht mehr?

Post by Housefred » 11.05.2019, 21:13

Hallo,

Uli's Hinweis hat mich etwas weiter gebracht. Ich starte Rocrail auf dem Raspi über die Windows-ähnliche Oberfläche. Da fehlt eben der Server (Icon) zum starten.

Wenn ich RocView starte funktioniert das auch, aber verbinden zum Server läuft ins leere, daher war ich davon ausgegangen, er wird nicht installiert.

Ich habe aber nach Uli's Hinweis in Rocview noch eine Revisionsliste gefunden und da steht es drin:
14741 2018-12-25 12:08:07 +0100 install: no longer provide a server icon
Jetzt muss ich nur noch den Befehl zum Serverstart finden...

Danke soweit schon mal
Matthias

ups60
Posts: 1034
Joined: 30.07.2013, 17:36
Location: 50321 Brühl

Re: Mit Build 14738 wird Server mit installiert, ab Build 14741 nicht mehr?

Post by ups60 » 11.05.2019, 21:16

Hallo Matthias,

eine Anleitung dazu findest Du hier: https://wiki.rocrail.net/doku.php?id=ro ... ux-user-en

mfg Uwe

peter&basti
Moderator
Posts: 6559
Joined: 09.01.2012, 22:09
Location: Vienna, Austria

Re: Mit Build 14738 wird Server mit installiert, ab Build 14741 nicht mehr?

Post by peter&basti » 11.05.2019, 21:31

Hallo Matthias,

einfach einen Arbeitsbereich in Rocview öffnen, dann wird der Server gestartet.
In zweiten Schritt kannst Du dann (optional) in Rocview deinen Standard Arbeitsbereich hinterlegen, dann wird bei Start von Rocview dieser automatisch geladen und der Server gestartet.

Housefred
Posts: 5
Joined: 18.09.2013, 16:26
Location: Fritzlar

Re: Mit Build 14738 wird Server mit installiert, ab Build 14741 nicht mehr?

Post by Housefred » 11.05.2019, 22:14

Hallo Uwe,
Hallo Peter,

diese grundlegende Änderung ist irgendwie an mir vorbeigelaufen.

Peter's Lösung funktioniert natürlich, aber auch mit dem Link von Uwe habe ich für mich eine Lösung gefunden.

Hab mir die Befehlszeile in ein Textdokument gespeichert und auf dem Desktop abgelegt. Bei Bedarf gibt's dann Copy&Paste in das LXTerminal.

Der Mensch ist halt ein Gewohnheitstier.

Danke für alle Mithelfenden und sry für mein Brett vorm Kopf :beer:

Gruß
Matthias

Post Reply

Return to “RaspberryPi / BananaPi (DE)”