[erl.]Probleme beim Starten von Rocrail auf Raspi mit U Mate

Mobahner13
Posts: 54
Joined: 06.07.2017, 01:46

[erl.]Probleme beim Starten von Rocrail auf Raspi mit U Mate

Post by Mobahner13 » 12.08.2017, 15:51

Hallo,

ich habe auf meinem Raspberry Ubuntu Mate drauf installiert und dann die Raspberry Version von Rocrail, leider startet Rocrail nicht und wenn ich es übers Terminal starten will erscheint die Fehlermeldung:

"Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1009, wx containers, compatibility with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1009, wx containers, compatibility with 2.8).
Segmentation fault"

Über eine Lösung würde ich mich freuen!

LG Andy
Last edited by Mobahner13 on 22.09.2017, 22:15, edited 1 time in total.

LDG
Site Admin
Posts: 2623
Joined: 18.10.2010, 00:03
Location: near Karlsruhe/Germany

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Post by LDG » 12.08.2017, 16:25

Hallo Andy,

Vorweg: Ich habe derzeit ein "original" Raspbian 8 auf meinem RasPi.

Was liefert:

Code: Select all

sudo dpkg -l libwxgtk3.0-0
Wenn

Code: Select all

dpkg-query: Kein Paket gefunden, das auf libwxgtk3.0-0 passt
(oder sinngemäß auf englisch) dann

Code: Select all

sudo apt-get install libwxgtk3.0-0

Gruß,
Lothar

Mobahner13
Posts: 54
Joined: 06.07.2017, 01:46

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Post by Mobahner13 » 12.08.2017, 16:38

Hallo Lothar,

ich hab ja libwxgtk3.0 installiert, auch mehrfach, trotzdem kommt immer wieder der Fehler.

Rocrail habe ich auch nochmal installiert, trotzdem klappt dies nicht...

LG Andy

Schorse
Posts: 4900
Joined: 12.09.2008, 19:38
Location: D - Niedersachsen

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Post by Schorse » 12.08.2017, 17:00

Hallo Andy,

hast Du schon mal das Paket "libwxgtk3.0-0v5 "probiert?

Mobahner13
Posts: 54
Joined: 06.07.2017, 01:46

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Post by Mobahner13 » 12.08.2017, 17:06

Hallo Gerd,

ja auch dies ist installiert und die neueste Version...

LG Andy

Schorse
Posts: 4900
Joined: 12.09.2008, 19:38
Location: D - Niedersachsen

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Post by Schorse » 12.08.2017, 17:33

Hallo Andy,

dann schmeiß' das Ubuntu Dings runter.. :) Ich habe auch keine Lösung für Dein Problem. :(

Mobahner13
Posts: 54
Joined: 06.07.2017, 01:46

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Post by Mobahner13 » 12.08.2017, 18:08

Hallo Gerd,

naja ich hatte schon mal Jessie mit Rocrail drauf und einen Adapter von Renkforce https://www.conrad.de/de/raspberry-pi-e ... 77411.html und die DXX bzw. die DCC232 Zentrale konfiguriert, nur leider haben diese keine Lok angesprochen, auch nicht über den Rootbenutzer.

Aber über meinen alten PC mit Ubuntu funktioniert alles tadellos.

LG Andy

Pirat-Kapitan
Moderator
Posts: 4805
Joined: 06.02.2010, 15:46
Location: Rösrath bei Köln / Germany

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Post by Pirat-Kapitan » 12.08.2017, 19:23

Moin Andy,
dann sehe ich nur 2 Lösungsalternativen:
1. alten PC mit der bisherigen Softwarezentrale
2. RasPi mit jessie und Hardwarezentrale.

Manche Kombinationen (z.B. anscheinend die von Dir gewünschte) sind mit vertretbarem Aufwand nicht herstellbar.

Schöne Grüße
Johannes

Mobahner13
Posts: 54
Joined: 06.07.2017, 01:46

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Post by Mobahner13 » 12.08.2017, 20:22

Hallo Johannes,

ja anscheinend sieht es so aus...

wollt halt eigentlich keine Hardwarezentrale extra für diese Anlage nutzen...

mal gucken was wird oder hier jemand noch eine Idee hat...

LG Andy

StefanF.
Moderator
Posts: 2744
Joined: 27.10.2008, 21:40
Location: Hamburg/Germany

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Post by StefanF. » 12.08.2017, 22:32

Hallo Andy,
Ubuntu Mate kenne ich nicht, aber generell funzt ein Raspi auch mit Software-Zentrale. Ist hier auch schon mehrfach beschrieben worden. Rocrail muß auch funktionieren, wenn keine Softwarezentrale installiert ist, Die Bereitstellung von DDX oder DCC232 ist da wohl nicht der der Grund. Das Problem muß an Deiner Konfiguration und Installation liegen,
Leider kann ich Dir da nicht helfen, mit Jessie geht es jedenfalls.
Beste Grüße
Stefan.

P.s.: anstatt dieser Schnittstelle von C...d, benutze doch mal die USB2Serial-Adapter, die heir bei Rocrail immer wierder empfohlen werden. Dann klappt es auch mit der Softwarezentrale und nachgeschalteten Booster.

Schorse
Posts: 4900
Joined: 12.09.2008, 19:38
Location: D - Niedersachsen

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Post by Schorse » 12.08.2017, 23:17

Hallo Stefan,
Dann klappt es auch mit der Softwarezentrale und nachgeschalteten Booster.
Das traue ich mich gar nicht zu schreiben.
Das das jemand getestet? Ich bin der Meinung das der Wandler das Timing des Gleissignal zerstört.

Mobahner13
Posts: 54
Joined: 06.07.2017, 01:46

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Post by Mobahner13 » 12.08.2017, 23:41

Hallo Ihr beiden,

also ich habe jetzt mal auf eine zweite SD-Karte Jessie drauf gemacht und Rocrail installiert, funzt.

Als nächstes hab ich DCC232 Zentrale Konfiguriert und auch die RS232 Schnittstelle wurde erkannt und konnte ich auswählen, Rocrail neugestartet...

Jetzt kommts: Ich schalt die Spannung ein und aufeinmal geht diese wieder aus :shock: Also auch am Gleis liegt Spannung an, da meine Dostos leuchten, dennoch kann ich solange die Spannung anbleibt nicht die Lok ansprechen, jedenfalls geht die Spannung relativ schnell aus, Fehlermeldung siehe Bild!
Bildschirmfoto 2017-08-13 um 00.28.36.png
Fehlermeldung
Oh da muss ich mal nach diesen Adaptern schauen :o

LG Andy

rjversluis
Site Admin
Posts: 39125
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Post by rjversluis » 13.08.2017, 06:55

Moin,

ich benutze ein Raspi 1 mit RocNetNode, DCC232, FTDI USB, und ORD-3. Mit diese Kombination funktioniert alles.

StefanF.
Moderator
Posts: 2744
Joined: 27.10.2008, 21:40
Location: Hamburg/Germany

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Post by StefanF. » 13.08.2017, 08:34

Moin Gerd,
so benutze ich das System schon seit einiger Zeit in meinem Testkoffer.
http://wiki.rocrail.net/lib/exe/detail. ... stcase.png
Im Testkoffer, wie auch auf meiner 7m langen Teststrecke im Flur funktioniert das Ganze im Dauerbetrieb. Die Flurstrecke muss dabei über den 1.ten Converter einen simplen Booster aus der Bastelkiste ansteuern und der 2. Converter die MGV85 für Rückmelder und Signale.
Beste Grüße
Stefan

Schorse
Posts: 4900
Joined: 12.09.2008, 19:38
Location: D - Niedersachsen

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Post by Schorse » 13.08.2017, 09:19

Moin Stefan,

super, dann haben sich meine Bedenken ja aufgelöst. Mein alter RS232 Booster ist schon länger defekt daher kann ich nichts testen. Vielleicht solllte ich ihn doch mal reparieren. :wink:

Post Reply

Return to “RaspberryPi (DE)”