[erl.]Probleme beim Starten von Rocrail auf Raspi mit U Mate

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Postby Schorse » 13.08.2017, 09:24

Moin Andy,

Jetzt kommts: Ich schalt die Spannung ein und aufeinmal geht diese wieder aus
Das könnte an der Kurzschlußüberwachung liegen falls diese aktiv ist.
Bildschirmfotos sind nicht sehr hilfreich; besser ist es ein Trace File hochzuladen oder einen Problemfall zu erstellen.
Viele Grüße Gerd
Schorse
 

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Postby Mobahner13 » 13.08.2017, 11:09

Hallo,

was mach ich da falsch??????????????

Vielleicht liegt es auch an dem Converter den ich oben verlinkt habe... habe mir auch gleich gestern Abend noch den Converter bestellt, der auf der Rocrailseite verlinkt ist, vielleicht klappt es ja damit?

Denn eigentlich ist es doch so wie auf meinem alten PC, Ubuntu drauf, Rocrail drauf, den Booster mit der RS232 Schnittstelle an die interne RS232 Schnittstelle anschließen, Zentrale einrichten, los gehts... jedenfalls auf dem PC aber nicht auf dem Pi...

Hoffentlich liegt es nur am Converter...

LG Andy
Mobahner13
 

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Postby Mobahner13 » 13.08.2017, 11:11

Hallo Gerd,

naja das Bild ist ja von den Fehlermeldungen die ich erhalten habe... Zumal ich eigentlich die Kurzschlussüberwachung ausgeschaltet habe und sogar die Rocrail.ini verändert hab, weil manche Converter Probleme mit dem RTS haben, das hat ein wenig gefühlt Besserung gebracht, dennoch konnte ich keine Lok ansprechen.

Aber gerne kann ich das auch noch machen, mal gucken wie ich heute Zeit dazu finde :)

LG Andy
Mobahner13
 

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Postby StefanF. » 13.08.2017, 11:15

Moin andy,
wie Gerd schon schrieb, was sagt denn Dein Trace-file. Eventuell hast Du auch nicht die Schreibrechte, um auf die Schnittstelle zugreifen zu können?
Stichwort: group=dialout

#serielle Schnittstelle für Benutzer öffnen
sudo usermod -a -G dialout username

Beste Grüße
Stefan
=========================
Zentrale: OpenDCC Z1 und 2 Booster: OpenDCC - Booster2
Loconet MGV85, 50, 93,76,77,136
Rechner: Kubuntu14.04 auf 2*Core i3 (3Monitore) 6GBRAM
=========================
StefanF.
 

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Postby Mobahner13 » 13.08.2017, 11:40

Hallo Stefan,

muss ich gleich mal gucken...

naja sobald ich mit Root eingeloggt bin sollte dies doch funktionieren? Und den Strom auf die Gleise kann ich ja einschalten nur halt nicht lange...

LG Andy
Mobahner13
 

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Postby Mobahner13 » 13.08.2017, 12:33

Hallo,

so jetzt die Dateien aus Rocrail...

LG Andy
You do not have the required permissions to view the files attached to this post.
Mobahner13
 

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Postby StefanF. » 13.08.2017, 13:17

Hallo Andy,
die Kommunikation zwischen Rocrail und Deiner Schnittstelle scheint zu funktionieren. Die Schreib- und Leserechte sind beim Start vorhanden. Danach aber wohl nicht mehr. Großes Fragezeichen, auch bei mir.
Beste Grüße
Stefan
=========================
Zentrale: OpenDCC Z1 und 2 Booster: OpenDCC - Booster2
Loconet MGV85, 50, 93,76,77,136
Rechner: Kubuntu14.04 auf 2*Core i3 (3Monitore) 6GBRAM
=========================
StefanF.
 

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Postby ViktorHotel » 13.08.2017, 14:00

Hallo zusammen,
Wir hatten das Thema mit schwachen Pegeln an USB RS232 Konvertern hier schon mal. Die Lösung war damals diese Platine:
http://wiki.rocrail.net/doku.php?id=ord ... 3-boostern
Viele Grüße
Volker
rocrailing with:
Ubuntu 16.04 LTS, MDRRC-II mit BMB Booster-B5 (Fahren), HSI88(Rückmelden), Sprog3 (Weichen und Signale), DMX-Artnetnode (Wetter und Licht)
ViktorHotel
 

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Postby Schorse » 13.08.2017, 14:53

Hallo Andy,
es gibt da einen Fehler in der seriellen Kommunikation:
20170813.125713.947 r9999W dcc232tx OSerial 0761 tcsetattr failed! [5] [I/O error]
20170813.125713.948 r9999W dcc232tx OSerial 0525 write error size=52 written=-1 [5] [I/O error]
20170813.125713.948 r9999E dcc232tx ODCC232 0665 transmit error=0 (Power Off)

Was das genau bedeutet kann ich Dir leider nicht sagen, nur das ein Problem gibt beim setzen der Schnittstellenparameter. :(
Viele Grüße Gerd
Schorse
 

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Postby GeSchu » 13.08.2017, 18:12

Moin zusammen,
moin Andy,
mit Verlaub, wie oft den noch? Wir hatten das alles doch schon des öfteren gelöst. Zuletzt glaube ich hier. Einfach mal im WIKI nachlesen und dann die Pakete :build-essential, git, libwxgtk3.0-dev,libusb-1.0-0-dev sofern noch nicht geschehen, nachinstallieren. Und alles sollte laufen. Und ganz wichtig: Mit dem eigenen Betriebssystem beschäftigen.
Nebenbei: Warum installiert man auf seinen Raspian UBUNTU MATE?
Und: Die Geschichte mit der seriellen Schnittstelle ist ein anderes Thema. Volker hat doch weiter oben auch schon etwas dazu geschrieben. Stefan, viele andere und ich nutzen, auch wie im WIKI beschrieben, den dort beschriebenen USB Adapter. Funktioniert einwandfrei. Warum also immer etwas anderes nehmen als empfohlen wird? Die Probleme sind dann natürlich vorprogrammiert. Der Raspi ist schon etwas besonderes und bedarf einer besonderen Behandlung.
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Postby GeSchu » 13.08.2017, 20:29

Moin zusammen,
gerade habe ich mal ein bischen zum Thema wxWidget /UBUNTU Mate / Raspberry mittels einer Suchmaschine recherchiert. Der von mir gefundene Tenor lautet so sinngemäß, diese Konfiguration ist mit vielen Problemen behaftet. Für mich wäre das Ganze mit zuviel Aufwand verbunden. Deshalb kann ich hier zum Thema auch keine weitere Hilfe anbieten.
Fazit:
UBUNTU vom Raspi wieder runter und Jessie oder wheezy drauf und alles wird mit vertretbarem Aufwand gut.
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Postby Schorse » 13.08.2017, 20:56

Moin Gerd,

UBUNTU vom Raspi wieder runter und Jessie oder wheezy drauf und alles wird mit vertretbarem Aufwand gut.
Ubuntu löschen hatte ich empfohlen (allerdings nicht ganz im Ernst und ohne Kenntnis der von Dir recherchierten Info's aber ich kann mich erinnern des es mit dem MATE Desktop schon öfters Probleme gab) und ist auch schon passiert. Andy hat wieder Jessie auf dem Raspi und der Adapter ist bestellt.
Viele Grüße Gerd
Schorse
 

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Postby StefanF. » 13.08.2017, 21:39

Toi, Toi, Toi
wir brauchen wohl noch eine Linux Unterrubrik. :beer:
Beste Grüße
Stefan
=========================
Zentrale: OpenDCC Z1 und 2 Booster: OpenDCC - Booster2
Loconet MGV85, 50, 93,76,77,136
Rechner: Kubuntu14.04 auf 2*Core i3 (3Monitore) 6GBRAM
=========================
StefanF.
 

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Postby Mobahner13 » 14.08.2017, 09:27

Hallo,

also mittlerweile hab ich jetzt nur noch Jessie drauf, Pakete hab ich alle schon installiert gehabt.

Ich denk mal das ich den ORD-5 nach bauen muss damit das dann klappt, warte aber noch auf einen neuen RS232 Adapter der empfohlen wurde.

Mal gucken ob es dann funzt bzw dann mit dem ORD-5...

Vielen Dank schon mal für Eure Hilfe!

LG Andy
Mobahner13
 

Re: Probleme beim Starten von Rocrail auf Raspi mit Ubuntu M

Postby Mobahner13 » 20.08.2017, 01:27

Hallo Ihr Lieben,

nun endlich ist das Paket da und hab mich ans ausprobieren gemacht...

UND????

ES KLAPPTTTT!!!!!!!! Anscheinend lag es echt nur an diesem blöden USB-RS232 Konverter :roll: :roll: :roll:

Vielen Dank für Eure Antworten und Lösungsvorschläge :)

LG Andy

PS: Hab jetzt den Konverter der auf der Rocrailseite empfohlen wird :)
Mobahner13
 

PreviousNext

Return to Raspberry Pi (DE)