[gelöst] Probleme mit ttyUSBx auf v2 und Stretch

Re: Probleme mit ttyUSBx auf v2 und Stretch

Postby StefanF. » 25.11.2017, 08:25

Moin Rob,
kann ich gar nicht glauben. RocNetNode und USB-RS232 Kommunikation haben bisher immer funktioniert. Unabhängig von Deinen Ergebnis, versuche ich heute mal ein System mit strech aufzusetzen. Habe mir ein wenig Zeit freigeschaufelt. 8)
Beste Grüße
Stefan
=========================
Zentrale: OpenDCC Z1 und 2 Booster: OpenDCC - Booster2
Loconet MGV85, 50, 93,76,77,136
Rechner: Kubuntu14.04 auf 2*Core i3 (3Monitore) 6GBRAM
=========================
StefanF.
 

Re: Probleme mit ttyUSBx auf v2 und Stretch

Postby Liviu M » 25.11.2017, 08:25

Hi Rob,
rjversluis wrote:Mit USB gibt es immer wieder Ärger; Neu eingestöpselt ist es anstatt ttyUSB0, ttyUSB1 geworden... Alles mau.


hast du mehrere ähnliche Schnittstellen gleichzeitig an Pi angeschlossen?
Wenn nicht, du kannst udev Regeln definieren, mit symbolische Namen für die verschiedene Schnittstellen und dann diese Namen verwenden.

Bei mir steht für FTDI232 Schnittstelle:
Code: Select all
# ftdi ft232
SUBSYSTEMS=="usb", ATTRS{idVendor}=="0403", ATTRS{idProduct}=="6001", MODE:="0666", SYMLINK+="ft232r"

Das bedeutet, ich kann ein FTDI Adapter auch mit /dev/ft232r, nicht nur mit /dev/ttyUSBx, ansprechen.

Grüße,
Liviu
----------------------------------------------
System: DCC N-Scale
CS: Profiboss (Loconet)
Server: RaspberryPi/OdroidC1/OpenSuse
Client: OpenSuse/Windows(?)
----------------------------------------------
Liviu M
 

Re: Probleme mit ttyUSBx auf v2 und Stretch

Postby rjversluis » 25.11.2017, 09:49

Hi,

ich habe das Problem gefunden und gelöst.
RocNetNode hat immer noch DCC232 auf ttyUSB0 aktiviert und das war dann der Auslöser für dieses Problem.
Soeben behoben in RocNetNode, und jetzt funktioniert es wie erhofft.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: [gelöst] Probleme mit ttyUSBx auf v2 und Stretch

Postby BR615 » 25.11.2017, 15:26

Glückwunsch. Dein Ergebnis fliesst ins Nightly Build ein?
US Güterzüge, EU Mischzüge, KATO Straba, Spur N, PC Rocrail an Digikeijs DR5000, RM: DR4088RB-CS, Littfinski Einspulenweichendecoder, Kehrschleife Littfinski KSM / TAMS KSM-2, KATO Unitrack, Windows 10, Linux Mint Cinn. 18.3, Raspberry Pi 3 Stretch OS
BR615
 

Re: [gelöst] Probleme mit ttyUSBx auf v2 und Stretch

Postby rjversluis » 25.11.2017, 15:30

BR615 wrote:Dein Ergebnis fliesst ins Nightly Build ein?

ja, inkl. das "Betriebsbeginn" Problem.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Previous

Return to Raspberry Pi (DE)