[gelöst]FTDI-Kabel Treiberproblem

Post Reply
TomTom
Posts: 39
Joined: 28.09.2016, 08:42
Location: Berlin

[gelöst]FTDI-Kabel Treiberproblem

Post by TomTom » 11.01.2018, 16:10

Hallo

Ich habe mir das FTDI-Kabel von Fichtelbahn gekauft und versucht mit dem BidiB Wizard (Debug-Console) das Update auf den GBM zu spielen. Ich bekomme keine Rückmeldung im Wizard. Das Kabel wird im Wizard erkannt. Die Einstellungen sind so wie in der Anleitung beschrieben, wenn ich ein "?" sende leuchtet die orange LED, aber keine Ausgabe im Wizard.
Habe mir dann den Treiber von der FTDI Webseite runter geladen und installiert, ohne Erfolg.

Auf meinem MacBook funktioniert alles einwandfrei. Darum vermute ich ein Problem mit dem Treiber.
Gibt es dafür eine Lösung. Auf dem Raspi läuft Stretch.

Gruß Tom
Last edited by TomTom on 16.01.2018, 11:44, edited 1 time in total.

rjversluis
Site Admin
Posts: 38747
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: FTDI-Kabel Treiberproblem

Post by rjversluis » 11.01.2018, 16:12

Hallo Tom,

falsche Forum.
Versuche es hier:
https://forum.opendcc.de

BTW: Wenn ich ein firmware update brauche schicke ich die Module nach Christoph. Der ist lieb und macht das für mich.

TomTom
Posts: 39
Joined: 28.09.2016, 08:42
Location: Berlin

Re: FTDI-Kabel Treiberproblem

Post by TomTom » 11.01.2018, 16:39

Hi Rob,

Bei Opendcc bin ich auch unterwegs. Hatte nur gehofft, dass mir die Raspi-Fans weiter helfen können.

Gruß Tom

rjversluis
Site Admin
Posts: 38747
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: FTDI-Kabel Treiberproblem

Post by rjversluis » 11.01.2018, 16:59

Hi Tom,

OK. Vielleicht meldet sich eine. :thumb_up:

Pirat-Kapitan
Moderator
Posts: 4742
Joined: 06.02.2010, 15:46
Location: Rösrath bei Köln / Germany

Re: FTDI-Kabel Treiberproblem

Post by Pirat-Kapitan » 11.01.2018, 19:20

Moin Tom,
da ich weder deine Hardware habe noch dieses Kabel, mußt Du mir schon ein bißchen helfen.
Was zeigt den "lsusb" im Terminalfenster an, wenn Du das Kabel angeschlossen hast? Es geht hier um Hersteller- und Produkt-ID des "FTDI" Bausteines.

Schöne Grüße
johannes

TomTom
Posts: 39
Joined: 28.09.2016, 08:42
Location: Berlin

Re: FTDI-Kabel Treiberproblem

Post by TomTom » 13.01.2018, 20:10

Hallo Johannes,
sorry, bin heute erst dazu gekommen
Pirat-Kapitan wrote:Es geht hier um Hersteller- und Produkt-ID des "FTDI" Bausteines.
VID 0x104C
PID 0xEA60
Serialnummer 0001
Product CP2102 USB to UART Bridge Controller
com Port /dev/ttyUSB0

dise Informationen werden beim Wizards eingeblendet, wenn ich das Kabel an den Rechner stecke.

Gruß Tom

Liviu M
Posts: 885
Joined: 03.12.2011, 20:44

Re: FTDI-Kabel Treiberproblem

Post by Liviu M » 13.01.2018, 20:31

Hallo Tom,
dein "FTDI Kabel" hat nix zu tun mit FTDI, sondern ist ein CP2102 von Silicon Labs.

Grüße,
Liviu

LDG
Site Admin
Posts: 2592
Joined: 18.10.2010, 00:03
Location: near Karlsruhe/Germany

Re: FTDI-Kabel Treiberproblem

Post by LDG » 13.01.2018, 21:02

Hallo Tom,

Du hast noch eine "Dreher" in der Hersteller-Kennung.
Du hast
VID 0x10c4 PID 0xea60 "CP210x UART Bridge / myAVR mySmartUSB light"
also vom Hersteller: "Cygnal Integrated Products, Inc."
Dieser Chipsatz ist u.a. auch in Tams MasterControl und RedBox verbaut.

Meine FTDI-Adapter melden sich mit:
VID 0x0403 PID 0x6001 "FT232 USB-Serial (UART) IC"
also von Hersteller: "Future Technology Devices International, Ltd"

Auf dem Raspi mit Stretch sollten die Treiber für beide oben erwähnten Chipsätze direkt im Betriebssystem verfügbar sein.
Falls Du als Benutzer "pi" (oder anderer "normaler Benutzer") und nicht als "root" arbeitest solltest Du folgenden Befehl eingeben:

Code: Select all

sudo usermod -a -G dialout $USER
damit auch der normale Benutzer ($USER ist Dein Login-Name) vollen Zugriff auf die seriellen und USB-Schnittstellen bekommt.
Danach abmelden und neu anmelden (oder Raspi neu starten).

Gruß,
Lothar

TomTom
Posts: 39
Joined: 28.09.2016, 08:42
Location: Berlin

Re: FTDI-Kabel Treiberproblem

Post by TomTom » 14.01.2018, 15:53

Hi Lothar,

leider ohne Erfolg.

Gruß Tom

TomTom
Posts: 39
Joined: 28.09.2016, 08:42
Location: Berlin

Re: FTDI-Kabel Treiberproblem

Post by TomTom » 16.01.2018, 11:43

Hallo

im Opendcc Forum haben wir eine Lösung gefunden. Man muss als Seriellen Port Treiber den Treiber "SCM" unter Einstellungen einstellen, der Treiber "RXTX" funktioniert beim FTDI-Kabel noch nicht. Man(n) ist dabei eine Lösung zu finden.

Gruß Tom

Post Reply

Return to “RaspberryPi (DE)”