XML Editor/Viewer Topic is solved

rjversluis
Site Admin
Posts: 41711
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: XML Editor/Viewer

Post by rjversluis » 25.05.2019, 10:26

Hi Peter,

versuche es mal mit 15443.
Unter Win7 gibt es überhaupt kein unterschied zwischen 15391...15443 mit ein Auflösung von 1920x1080. (Wird bei alle Revisionen auch so angezeigt.)

Unter Win10 habe ich leider keine Möglichkeit es zu testen.
Heute habe ich ein manifest hinzugefügt was Windows sagt das es HDI Aware ist...

peter&basti
Moderator
Posts: 6570
Joined: 09.01.2012, 22:09
Location: Vienna, Austria

Re: XML Editor/Viewer

Post by peter&basti » 25.05.2019, 10:29

Hi Rob,
Unter Win10 habe ich leider keine Möglichkeit es zu testen.
Darum teste ich ja :wink:

rjversluis
Site Admin
Posts: 41711
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: XML Editor/Viewer

Post by rjversluis » 25.05.2019, 10:37

Hi Peter,

der neue Build ist genau so unaware. Sch..sse.
Keine Ahnung was ich da ändern muss.

rjversluis
Site Admin
Posts: 41711
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: XML Editor/Viewer

Post by rjversluis » 25.05.2019, 11:32

Moin,

der Call SetDPIProcessAware() haben die in 3.1.x wieder raus genommen:
https://forums.wxwidgets.org/viewtopic. ... 94#p191394
Warum auch immer...

LDG
Site Admin
Posts: 2689
Joined: 18.10.2010, 00:03
Location: near Karlsruhe/Germany

Re: XML Editor/Viewer

Post by LDG » 25.05.2019, 13:31

Hallo Rob,

teste derzeit unter Win8.1

Rev15444 "try to use only one manifest" hat wieder die richtige Auflösung und Schärfe gebracht.

Ich war auch schon so weit, daß wenn man die wxMANIFEST_ID 24 ersetzt/überschreibt und die Warnung von rescomp ignoriert, die Auflösung wieder passt und alles wieder scharf dargestellt wird.
Die Icons in der Werkzeugleiste sehen noch "etwas seltsam" aus (egal ob grau oder farbig). Die sind wohl für ein "dark theme" optimiert. Die "Hintergrund"-Option bringt keine Änderung. Das ist aber zunächst mal nicht so wichtig.

Gruß,
Lothar

rjversluis
Site Admin
Posts: 41711
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: XML Editor/Viewer

Post by rjversluis » 25.05.2019, 13:33

Hi Lothar,

danke fürs testen.

Im wx Forum:
https://forums.wxwidgets.org/viewtopic.php?f=23&t=45915
habe ich diese Tip bekommen.

Der Daily Build habe ich soeben neu angestossen.

Nachtrag: Die Toolbar Icons liegen nur in Größe 20/24 pixel vor, also diese werden dann vin wxWidgets wahrscheinlich skaliert. Da muss ich irgendwann auch mal dran.

rjversluis
Site Admin
Posts: 41711
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: XML Editor/Viewer

Post by rjversluis » 25.05.2019, 16:32

Hallo,

unter Win10 zeigt der ProcessExplorer das Rocview Pre-Monitor aware ist... Oder so was ähnliches.
Die Toolbar Icons werden nicht richtig dargestellt weil der PNG Transparency scheinbar nicht ausgewertet wird.
:(
Bei Windows gibt es immer Überraschungen; Hat man ein Gespenst verjagt taucht ein andere wieder auf.
Jetzt ist mein Akku leer, und suche da erst Morgen wieder weiter. :roll:

@Lothar: Kannst du mal versuchen wie es aussieht wenn man dpiAwareness weglässt? Weil die meiste andere Anwendungen zeigen nur Aware an.

peter&basti
Moderator
Posts: 6570
Joined: 09.01.2012, 22:09
Location: Vienna, Austria

Re: XML Editor/Viewer

Post by peter&basti » 25.05.2019, 16:33

Hi Rob,

die Auflösung passt wieder mit 15.444

- die einfärbigen Icons in der Werkzeugleiste sind nun invers, wie Lothar bereits geschrieben hat.
- die Fenstertitel gehen in der AUI Ansicht nicht mehr weg
rocview15444.PNG

rjversluis
Site Admin
Posts: 41711
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: XML Editor/Viewer

Post by rjversluis » 25.05.2019, 16:35

Hi Peter,

bei ein paar Toolbar Icons scheint es OK zu sein...

Die Titlebars waren bei 3.0 auch da:
download/file.php?id=35505&mode=view
Hast du selbst belegt.

peter&basti
Moderator
Posts: 6570
Joined: 09.01.2012, 22:09
Location: Vienna, Austria

Re: XML Editor/Viewer

Post by peter&basti » 25.05.2019, 16:38

Hi Rob,
rocview15444bunt.PNG
auch die bunten Symbole sind jetzt schwarz hinterlegt

rjversluis
Site Admin
Posts: 41711
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: XML Editor/Viewer

Post by rjversluis » 25.05.2019, 16:44

Ja Peter,

das hat Lothar auch schon berichtet. ;)

Ich konzentriere mich Morgen erst auf die Graue Icons. Anscheinend werden nicht aktive Icons richtig dargestellt.
Oder vielleicht hängt es zusammen mit der dpiAwareness manifest parameter...

rjversluis
Site Admin
Posts: 41711
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: XML Editor/Viewer

Post by rjversluis » 25.05.2019, 16:51

Hallo,

die gleiche Icons sind im Menü OK:
winaware-icons.png
-o -o -o

https://forums.wxwidgets.org/viewtopic.php?f=23&t=45916

RainerK
Moderator
Posts: 3997
Joined: 29.04.2009, 09:31
Location: Sprockhövel (zwischen BO u. W)
Contact:

Re: XML Editor/Viewer

Post by RainerK » 25.05.2019, 18:41

Hi Rob,

könnte es sein das die Transparenz der Icons auf dem Toolbar-Hintergrund falsch verarbeitet wird?
Vielleicht hilft es, wenn ein Dummy-Objekt als Hintergrund zwischen Toolbar und Icons gelegt ist.

LDG
Site Admin
Posts: 2689
Joined: 18.10.2010, 00:03
Location: near Karlsruhe/Germany

Re: XML Editor/Viewer

Post by LDG » 25.05.2019, 19:34

Hallo Rob,
rjversluis wrote:
25.05.2019, 16:32
@Lothar: Kannst du mal versuchen wie es aussieht wenn man dpiAwareness weglässt? Weil die meiste andere Anwendungen zeigen nur Aware an.
Mit "dpiAware" auf "false" und "dpiAwareness" auf "unaware" in rocview.manifest ist die Auflösung und die Schärfe wieder weg und die Darstellung zu groß. Das Problem mit den Icons der Werkzeugleiste bleibt. Das scheint also irgendwie allgemein an wx3.1 zu liegen.

Unter "Rocrail Eigenschaften..." werden im Reiter "Zentrale" (und nur dort) einige größere, "unbenutze"/leere Bereiche in der Zentralenliste nicht mit der Hintergrundfarbe (grau) überschrieben. Sie zeigen die Inhalte des zuletzt aufgerufenen Tabellenreiters als Hintergrund.
Gleiches unter "Tabellen"/"Fahrstraßen..." nur für die Tabs "Befehle" und "Rückmelder".
Andere Menüs/Tabellen habe ich nicht probiert.

Sieht aus als ob da für "irgendein Hintergrundflag" (Farbe/Transparenz/Refresh/?) seit wx3.1 ein anderer (Default-)Wert gilt.

Das (der "andere" Hintergrund) könnte eventuell auch bei den Icons ein Teil die Ursache sein.

Gruß,
Lothar

rjversluis
Site Admin
Posts: 41711
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: XML Editor/Viewer

Post by rjversluis » 26.05.2019, 06:46

Hallo Lothar,

es gibt in der Doku ein Hinweis:
https://docs.wxwidgets.org/3.0/classwx_tool_bar.html wrote:wxMSW note: Note that under wxMSW toolbar paints tools to reflect system-wide colours. If you use more than 16 colours in your tool bitmaps, you may wish to suppress this behaviour, otherwise system colours in your bitmaps will inadvertently be mapped to system colours. To do this, set the msw.remap system option before creating the toolbar:

wxSystemOptions::SetOption("msw.remap", 0);
Diese probiere ich mal aus.

Post Reply

Return to “Erweiterungsvorschläge (DE)”