[erl.] Grosses ? bei WLANmaus mit Rocrail verbinden (VM)

[erl.] Grosses ? bei WLANmaus mit Rocrail verbinden (VM)

Postby Gartenbahner91 » 10.06.2017, 17:47

Hallo zusammen

Ich wollte meine Roco Wlan Maus mit dem Rocrail verbinden, ich habe dazu schon hier im Forum und im Wiki gelesen. Ich bin aber daraus nicht schlau geworden wie ich die "WMZ21 Zentrale" konfigurieren muss. Kann mir da vielleicht jemand auf die Sprünge helfen?

Meine Zimo MX10 Zentrale ist mit Rocrail verbunden, ein Gleisplan existiert auch, Weichen können gestellt und Züge gefahren werden. Die Wlan Maus kann ich nicht direkt mit dem MX10 verbinden da das MX10 noch keine "langen" IP Adressen unterstützt und deshalb keine Rückmeldung ausgibt. Dem Rocrail ist das egal aber die Wlan Maus läuft nicht.

Gruss Stefan
Gartenbahner91
 

Re: Grosses ? bei Wlan Maus mit Rocrail verbinden

Postby peter&basti » 10.06.2017, 19:52

Hallo Stefan,

Rocrail emuliert für die Wlanmaus die Z21, es gibt keine direkte Verbindung zwischen Deiner MX10 und der WLM.
Einfach eine zusätzliche Zentrale Typ WLANmaus nach Anleitung anlegen.
Liebe Grüße / best regards
Peter


System: DCC 2-Leiter H0, Rocrail 64bit auf Win10 Pro 64
Traktion: OpenDCC GBM
Fahrweg: RocNetNode & GCA PI01/2/3, GCA41/Arduino RFID, GCA145 Drehscheibe, etc.
Decoder: 99% Zimo
Experimentell: MQTT & Node-Red
peter&basti
 

Re: Grosses ? bei Wlan Maus mit Rocrail verbinden

Postby Gartenbahner91 » 10.06.2017, 20:59

Hoi Peter

Eben diese Anleitung verstehe ich nicht.

Doch, man kann die Wlan Maus mit der MX10 verbinden, hab ich extra bei Zimo nachgefragt, aber eben das MX10 kann noch keine langen IPs.

Übrigens, die Roco App kann man ebenfalls mit der MX10 verbinden, da die MX10 sich als Z21 ausgibt.
Gartenbahner91
 

Re: Grosses ? bei Wlan Maus mit Rocrail verbinden

Postby Pirat-Kapitan » 10.06.2017, 21:32

Moin Stefan,
für die direkte Verbindung der WLM mit der MX10 mußt Du bitte bei Zimo Dir Rat und Hilfe holen, nicht hier im Rocrailforum.
Wir können nur Rocrail, nicht MX10.
Die Anbindung der WLM wie im Wiki beschrieben an Rocrail klappt dann auch mit deiner MX10.
Für nicht bzw. noch nicht vorhandene Zentralenfähigkeiten kann Rocrail nichts !

Hinweise auf die Fähigkeiten anderer Apps als Rocrail sind hier im Forum zwar interessant zu wissen, nützen aber nichts für den Umgang mit Rocrail.

Schöne Grüße
johannes
Clearasilfahrer auf Spur G&H0m, Lenz LZV (3.6), ORD-20, Manhart-Funki und WLM, RS-Bus Rückmelder (Reedkontakte/GBM),
Rocrail auf RasPi mit mobilen Geräten (andRoc). Details auf http://wiki.rocrail.net/doku.php?id=use ... at-kapitan.
Pirat-Kapitan
 

Re: Grosses ? bei Wlan Maus mit Rocrail verbinden

Postby Gartenbahner91 » 10.06.2017, 22:09

Hoi Johannes

Ich wollte auch nicht wissen wie ich die WM mit der MX10 verbinde sondern wie ich sie mit Rocrail verbinden kann.

Wie komme ich zu z.B. diesem Fenster?
http://wiki.rocrail.net/lib/exe/detail.php?id=roco%3Aroco-wmz21-en&cache=cache&media=roco:wmz21-setup-en.png

"Add the library wmz21 to the end of the Controller list, or set the Target accordantly to the wanted Interface ID."

Hab ich gemacht, aber ich habe dort dieses Fenster:

Bildschirmfoto vom 2017-06-10 23-02-58.png


Ist das richtig / falsch? falls ja was muss ich einstellen? IP PC / Maus, Port, UDP, Benutzerkennung? Falls nein wo finde ich das andere Fenster das im Wiki gezeigt wird?
You do not have the required permissions to view the files attached to this post.
Gartenbahner91
 

Re: Grosses ? bei Wlan Maus mit Rocrail verbinden

Postby Pirat-Kapitan » 10.06.2017, 23:01

moin Stefan,

Vermutlich benötigst Du Version 12343+, um das Menue aus dem englischen Wiki zu sehen.
12343 2017-06-09 17:05:27 +0200 control: if no switch is found by ID try to find a route with this ID

Ansonsten empfehle ich einen Blick in das deutsche Wiki.

Schöne Grüße
Johannes
Clearasilfahrer auf Spur G&H0m, Lenz LZV (3.6), ORD-20, Manhart-Funki und WLM, RS-Bus Rückmelder (Reedkontakte/GBM),
Rocrail auf RasPi mit mobilen Geräten (andRoc). Details auf http://wiki.rocrail.net/doku.php?id=use ... at-kapitan.
Pirat-Kapitan
 

Re: Grosses ? bei Wlan Maus mit Rocrail verbinden

Postby Gartenbahner91 » 10.06.2017, 23:42

Hoi Johannes

Hab meinen Beitrag vielleicht etwas blöd formuliert, sorry.

Genau sowas hab ich gesucht. Habe nun mein Rocrail genau nach dem Wiki konfiguriert, nur leider funktioniert's nicht.

Bildschirmfoto vom 2017-06-11 00-36-07.png


Den Hacken bei Lokomotiven wird bei jedem Neustart wieder gesetzt.

Die Ports 21105 und 8051 (für Mobile Clients) hab ich in der Virtuellen Maschine durchgeschlauft, sollte also nicht das Problem sein.

Gehe jetzt ins Bett, probiere dann morgen wieder.
You do not have the required permissions to view the files attached to this post.
Gartenbahner91
 

Re: Grosses ? bei Wlan Maus mit Rocrail verbinden

Postby RainerK » 10.06.2017, 23:43

Hallo Stefan und Johannes,
Pirat-Kapitan wrote:...Vermutlich benötigst Du Version 12343+, um das Menue aus dem englischen Wiki zu sehen...

das ist nicht ganz richtig.
Für den neuen Dialog aus dem en-Wiki (seit heute 00:28 Uhr auch im de-Wiki) wird Version 12345+ benötigt.
Die gibt es erst ab ca. 05:20 Uhr.
Best Regards, es grüßt RainerK

DCC++ with Arduino Uno / Motor shield and LocoNet GCA85, 50, 93 and 136. Special interests: DIY electronic assemblies. http://www.rainermoba.blogspot.com
Planning replace the coincidence by the mistake
RainerK
 

Re: Grosses ? bei Wlan Maus mit Rocrail verbinden

Postby rjversluis » 11.06.2017, 06:44

Moin Stefan,
Gartenbahner91 wrote:Genau sowas hab ich gesucht. Habe nun mein Rocrail genau nach dem Wiki konfiguriert, nur leider funktioniert's nicht.

hast du dann auch der WLANmaus mit dein Heimnetz verbunden, und die IP Adresse von der Rocrail Server in der Maus gesetzt.
http://wiki.rocrail.net/doku.php?id=roc ... e#wlanmaus
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Grosses ? bei Wlan Maus mit Rocrail verbinden

Postby Gartenbahner91 » 11.06.2017, 08:54

Hoi Rob

Ja hab ich gemacht, die IP sollte stimmen, den die Rocrail App kann sich mit dieser IP verbinden.
Gartenbahner91
 

Re: Grosses ? bei Wlan Maus mit Rocrail verbinden

Postby rjversluis » 11.06.2017, 08:59

Hi Stefan,

das WLANmaus display zeigt ob es verbunden ist mit ein Z21 oder Rocrail Emulation in dem nichts mehr blinkt.
Lade mal dein rocrail.ini hoch und ein Server Trace nachdem der Maus verbunden ist.

Wenn das Zeichen <||> blinkt gibt es keine Verbindung zwischen Maus und Rocrail.
Wenn das Antennensymbol blinkt gibt es kein Netzverbindung.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Grosses ? bei Wlan Maus mit Rocrail verbinden

Postby Gartenbahner91 » 11.06.2017, 09:11

Hoi Rob

Die Maus hat keine verbindung zum Server, Wlan verbindung hat sie.

Das hier wolltest du?

Code: Select all
<?xml version="1.0" encoding="UTF-8"?>
<rocrail planfile="C:\Dokumente und Einstellungen\Administrator\Eigene Dateien\Rocrail\G15.xml" analyseplan="true" occupancy="occ.xml" locs="" backup="true" maxbackup="100" backuppath="backup" keypath="lic.dat" libpath="." imgpath="images" iconpath="icons" issuepath="issues" soundpath="sounds" soundplayer="" soundplayerlocation="false" xmlscriptpath="." decpath="decspecs" ptiid="" lciid="" dpiid="" sviid="" sciid="" fsutf8="true" scsensor="" createmodplan="false" resetspfx="false" aboxhome="abox" poweroffonexit="true" poweronatinit="false" shutdownonexit="false" nodevcheck="true" donkey="" doneml="">
  <ctrl sgevents="false" swtimeout="250" minbklc="20" ignevt="5" initfieldpause="500" savepostime="10" secondnextblock="false" initfieldpower="true" enableswfb="true" eventtimeout="0" signalreset="0" routeswtime="0" disablerouteVreduce="false" greenaspect="false" semaphorewait="1" signalwait="0" locostartgap="0" blockinitpause="0" stopnonecommuter="false" syncroutes="false" syncroutetimeout="2500" timedsensors="false" enableanalyzer="true" ebreakforceunlock="false" defaspect="red" skipsetsw="false" skipsetsg="false" usebicom="true" useident="true" poweroffonidentmismatch="false" poweroffatghost="true" autooffatghost="false" ebreakatghost="false" keepghost="false" disablesteal="false" poweroffatreset="true" allowzerothrottleid="false" releaseonidle="false" closeonghost="false" closenoevents="false" selectshortestblock="false" restoreschedule="true" actiontimer60="true" createguestonbidi="false" usebididir="false" disableblockwait4gomanual="false" stopatin4gomanual="true" v0atpoweron="false" useonlyfirstident="true" userandomrate="false" virtualtimer="2" redirecttomaster="true" weather="true" v0onebreak="false" timerevents="false" modeevents="true" signalevents="false" checkdecoders="false" swapdest="false" resetscheduleonstop="true" usefinder="false" traceactions="false" enablebkpower="true"/>
  <trace rfile="rocrail" protpath="" nr="10" size="100" info="true" calc="true" find="true" byte="false" automatic="false" monitor="true"/>
  <anaopt setRouteId="true" cleanRouteId="true" setBlockId="true" resetBlockId="true" addSignalBlockAssignment="false" resetSignalBlockAssignment="false" addFeedbackBlockAssignment="false" resetFeedbackBlockAssignment="false" basicCheck="true" basicClean="false" blockCheck="true" blockClean="false" routeCheck="true" routeClean="false" actionCheck="true" actionClean="false"/>
  <clock hour="0" minute="29" divider="1" update="1" stopclockatpoweroff="true"/>
  <tcp port="8051" maxcon="10" controlcode="" slavecode="" slavecode_power="true" slavecode_switches="false" slavecode_signals="false" slavecode_outputs="false" slavecode_routes="false" slavecode_locos="false" onlyfirstmaster="false" mqtthost="" mqttport="0" mqttgrouping="false"/>
  <devices serial=""/>
  <srcpcon port="4303" active="false" device=""/>
  <SnmpService port="161" active="false" traphost="localhost" trapport="0"/>
  <r2rnet id="G15" addr="10.0.2.15" port="8051" routes="C:\Dokumente und Einstellungen\Administrator\Eigene Dateien\Rocrail\G15.xml" enable="false"/>
  <finder usepath="0" findalt="true" maxpaths="10" regularstops="true" tempschedules="true" checkperm="true" checkpermdest="false" avoidoccblocks="true" uselocations="false" avoidtermblocks="false" updateschedules="true" reservetoblock="false" dirchange4commuter="false" startonlywithschedule="false" setblockexitside="true"/>
  <cmdmaplist/>
  <http port="0" refresh="0">
    <webclient port="0" webpath="C:\Dokumente und Einstellungen\Administrator\Eigene Dateien\Rocrail" svgpath1="C:\Dokumente und Einstellungen\Administrator\Eigene Dateien\Rocrail\stylesheets" svgpath2="." svgpath3="." svgpath4="." svgpath5="."/>
  </http>
  <digint iid="MX10" lib="zimocan" desc="" ignorepowercmds="false" ignorepoweroffonghost="false" device="com1" host="192.168.168.161" userid="" port="0" udpportTX="14520" udpportRX="14521" fbmod="0" protver="0" sublib="default" systeminfo="true" locolist="false" flow="cts" asciiprotocol="false" bps="9600" swtime="250" reportstate="true" v0onebreak="false" restricted="false" stress="false" libpath="C:\Programme\Rocrail"/>
  <digint iid="wlanmaus" lib="wmz21" device="com1" host="" userid="MX10" port="21105" udpportTX="0" udpportRX="0" fbmod="0" protver="0" sublib="default" systeminfo="true" locolist="true" flow="cts" asciiprotocol="false" bps="9600" swtime="250" reportstate="true" v0onebreak="false" desc="" ignorepowercmds="false" ignorepoweroffonghost="false" restricted="false" stress="false" libpath="C:\Programme\Rocrail" switchlist="true"/>
</rocrail>
Gartenbahner91
 

Re: Grosses ? bei Wlan Maus mit Rocrail verbinden

Postby rjversluis » 11.06.2017, 09:19

Hallo Stefan,

das sieht iO aus.
Bist du sicher das du im Maus der richtige IP-Adresse eingegeben hast?
Es könnte eventuell auch ein Firewall Problem sein wenn du unter Windows arbeitest, aber bis jetzt ist da noch nichts gemeldet worden.

Bitte noch der passende Server Trace hier anhängen.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Grosses ? bei Wlan Maus mit Rocrail verbinden

Postby Gartenbahner91 » 11.06.2017, 09:21

Die Maus antwortet auch wenn ich sie anpinge aus der Virtuellen Maschine.

Bildschirmfoto vom 2017-06-11 10-15-55.png


Wo finde ich den den Server Trace?
You do not have the required permissions to view the files attached to this post.
Gartenbahner91
 

Re: Grosses ? bei Wlan Maus mit Rocrail verbinden

Postby rjversluis » 11.06.2017, 09:24

Mache es am beste so mit diese Funktion.
Dann hat man gleich alles.
Nicht vergessen um vorher der Maus ein zu schalten.

Anstatt Ping mal ipconf eingeben sodas ma sieht welche IP-Adresse dein Rocrail Rechner hat welche beim Maus eingetragen werden muss.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Next

Return to WLANmaus (DE)