WLANmaus -Licht schaltet sich in manchen Sitzungen immer ein

WLANmaus -Licht schaltet sich in manchen Sitzungen immer ein

Postby peter.b » 31.12.2017, 01:34

Da das Christkind eine WLANmaus angekündigt hatte, wurde vor Weihanchten noch schnell auf Version 13258 hochgerüstet.

Mittlerweile kann ich mit der WLANmaus steuern und kann auch, wie GuenTTer, berichten, dass sich manchmal das Licht bei allen Loks automatisch einschaltet. Es ist nicht immer, das Verhalten scheint aber für eine Sitzung durchgängig zu sein. Ein anderes Mal ist das Verhalten vollkommen normal. Ich habe noch nicht herausgefunden welche Bedingungen auftreten müssen. Hat es einen Einfluss in welcher Reihenfolge ich die Komponenten (Zentrale, Router, PC) einschalte? Ich weiß es nicht.

Ich werde versuchen herauszufinden, wie sich beide Fälle reproduzierbar nachstellen lassen.

Merkwürdigkeiten beim Funktionsaufruf (>F0) kann ich, genau wie Pirat-Kapitän, ebenfalls bestätigen, habe aber noch nicht so genau drauf geachtet.

Hat sonstwer dieses Verhalten nach der Version 12410 noch beobachtet?

Gruß Peter
peter.b
 

Re: WLANmaus -Licht schaltet sich in manchen Sitzungen immer

Postby peter.b » 02.01.2018, 20:51

issue.zip
Jetzt ist es mir gelungen, einen Fall zu erzeugen, bei dem das Fahrlicht an ist. Dabei bin ich wie folgt vorgegangen.
1. Router einschalten
2. PC hochfahren
3. Intellibox einschalten
4. Rocrail starten, neuen Arbeitsbereich anlegen, Intellibox als erste Zentrale einrichten, wmz21 als zweite Zentrale einrichten, Rocrail benden
5. Rocrail starten, entsprechenden Arbeitsbereich laden
6. WLANmaus einschalten
7. Loknummer eingeben und losfahren - Licht ist an (Maus zeigt kein Licht an) -> issue.zip erstellen

Ich hoffe, dass die Profis was damit anfangen können.

Viele Grüße
Peter
You do not have the required permissions to view the files attached to this post.
peter.b
 

Re: WLANmaus -Licht schaltet sich in manchen Sitzungen immer

Postby rjversluis » 03.01.2018, 07:53

Moin Peter,

wenn man ein Lok neu anliegt ist immer das Licht an.
Vielleicht sollte ich das ändern.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: WLANmaus -Licht schaltet sich in manchen Sitzungen immer

Postby peter.b » 04.01.2018, 00:45

Danke für die Erklärung, das mit dem Standard Licht-an war mir so nicht bewusst. Aber es gibt trotzdem (für mich) ein mekwürdiges Verhalten.

In meinem Beispiel wird die WLANmaus nur als Fahrregler genutzt, es gibt keinen Gleisplan, keine Loktabelle. In diesem Fall kann man das Licht NICHT über die WLANmaus ausschalten. Es hat den Anschein als wäre der Licht-Knopf der WLANmaus tot. Wenn ich die Lokadresse in der IB eingebe, kann ich das Licht ausschalten. Fahre ich mit der IB bleibt das Licht aus. Drehe ich dann den Regler der WLANmaus (gleiche Lokadresse) geht das Licht wieder an.

Gruß Peter
peter.b
 


Return to WLANmaus (DE)