[erl.] FiFo: Probleme Enter und In Aktion

Re: FiFo: Probleme Enter und In Aktion

Postby peter&basti » 31.12.2017, 18:44

Hi Rob,

-J2 geht bei mir auch nicht...bleibt hängen.
Ganz ohne -J läuft durch.

Kein Problem, die 20 Minuten sind OK.
Besser als ein Tag bis zum nächsten nightly Build :wink:
Liebe Grüße / best regards
Peter


System: DCC 2-Leiter H0, Rocrail 64bit auf Win10 Pro 64
Traktion: OpenDCC GBM
Fahrweg: RocNetNode & GCA PI01/2/3, GCA41/Arduino RFID, GCA145 Drehscheibe, etc.
Decoder: 99% Zimo
Experimentell: MQTT & Node-Red
peter&basti
 

Re: FiFo: Probleme Enter und In Aktion

Postby lordbrummi » 01.01.2018, 12:37

Prosit Neujahr,

peter&basti wrote:-J2 geht bei mir auch nicht...bleibt hängen...Kein Problem, die 20 Minuten sind OK.


Bei mir auch, die 20-30 mins sind kein Problem :wink:

rjversluis wrote:sobald Auto1 der Enter erreicht von b2 ist Auto2 schon unterwegs und das Signal kommt dann zu spät.


Rob, vielleicht wäre folgendes machbar, wenn Signal b1 auf rot geht und Auto2 hat bereits die FS nach b2 (da Auto1 schon am Enter von b2 war), Auto2 war aber selbst noch nicht am IN von b1:
- Die FS von Auto2 wieder wegnehmen, auf VMid gehen und am IN auf V0
(Bisher: Auto2 fährt über das rote Signal aus, da FS bereits gestellt)

-Auto3 (Follower) geht auf VMid und erst auf V0, wenn es selbst am IN von b1 ist
(Bisher: Auto3 geht mitten im Block 1 auf V0 bei rotem Signal und Auto2 am Enter von b2)

Grüße Dieter
TamsMC, Servodecoder und Magnetartikeldecoder, S88 Rückmeldung, OpenCar und 3-Leiter Bahn, Win10 64bit, RR 64bit
lordbrummi
 

Re: FiFo: Probleme Enter und In Aktion

Postby lordbrummi » 04.01.2018, 10:50

Moin Rob,

ich weiß nicht wie gerade deine To-Do ist, aber du hast mich und Claus (viewtopic.php?f=46&t=15031&start=45) schon noch im Hinterkopf? :wink:
*Duck und wech* :lol:

Grüße Dieter
TamsMC, Servodecoder und Magnetartikeldecoder, S88 Rückmeldung, OpenCar und 3-Leiter Bahn, Win10 64bit, RR 64bit
lordbrummi
 

Re: FiFo: Probleme Enter und In Aktion

Postby rjversluis » 04.01.2018, 11:02

Moin Dieter,

was hat das Thema von Claus mit dieses Thema am Hut?
Aber der ToDo Liste ist leer.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: FiFo: Probleme Enter und In Aktion

Postby lordbrummi » 04.01.2018, 11:10

rjversluis wrote:Moin Dieter,

was hat das Thema von Claus mit dieses Thema am Hut?
Aber der ToDo Liste ist leer.


Moin Rob,

nichts, ich habe nur gleich für Claus mitgefragt wenn ich schon am fragen bin : :oops: :wink:

Grüße Dieter
TamsMC, Servodecoder und Magnetartikeldecoder, S88 Rückmeldung, OpenCar und 3-Leiter Bahn, Win10 64bit, RR 64bit
lordbrummi
 

Re: FiFo: Probleme Enter und In Aktion

Postby rjversluis » 04.01.2018, 11:26

Hi Dieter,
Rob, vielleicht wäre folgendes machbar, wenn Signal b1 auf rot geht und Auto2 hat bereits die FS nach b2 (da Auto1 schon am Enter von b2 war), Auto2 war aber selbst noch nicht am IN von b1:
- Die FS von Auto2 wieder wegnehmen, auf VMid gehen und am IN auf V0
(Bisher: Auto2 fährt über das rote Signal aus, da FS bereits gestellt)

nein, das ist nicht möglich weil Auto2 hat schon logisch IN und fährt zum nächste Ziel.
Der Ampel muss erst eine weile Orange zeigen anstatt sofort Rot. ;)
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: FiFo: Probleme Enter und In Aktion

Postby lordbrummi » 04.01.2018, 11:40

rjversluis wrote:Der Ampel muss erst eine weile Orange zeigen anstatt sofort Rot. ;)


Ok, da es sich bei den Fifos vor Ampeln eh um kürzere Blöcke handelt, darf Auto2 noch bei Orange drüber :)

Bliebe nur noch:
Auto3 geht bei rotem Signal auf V0 wenn Auto2 Enter vom b2 erreicht.
Kannst du das noch ändern, daß Auto3 dann erst am IN von b1 auf V0 geht?

Dann ist der Thread m.E. erledigt.

Grüße Dieter
TamsMC, Servodecoder und Magnetartikeldecoder, S88 Rückmeldung, OpenCar und 3-Leiter Bahn, Win10 64bit, RR 64bit
lordbrummi
 

Re: FiFo: Probleme Enter und In Aktion

Postby rjversluis » 04.01.2018, 11:43

Moin,

kannst du dein aktuelles Beispiel hier anhängen?
Oder gibt es hier im Thema noch eine welche gültig ist?
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: FiFo: Probleme Enter und In Aktion

Postby lordbrummi » 04.01.2018, 11:47

Hi Rob,

du kannst dein Beispiel nehmen, siehe Seite 7.

Ablauf:
Wenn Auto1 in b2 dann schaltest du das b1 Signal auf rot.
Auto2 fährt aus b1 noch aus und wenn Auto2 am Enter von b2 ist geht Auto3 auf V0.
Auto3 sollte erst am IN von b1 auf V0 gehen.

Grüße Dieter
TamsMC, Servodecoder und Magnetartikeldecoder, S88 Rückmeldung, OpenCar und 3-Leiter Bahn, Win10 64bit, RR 64bit
lordbrummi
 

Re: FiFo: Probleme Enter und In Aktion

Postby rjversluis » 04.01.2018, 14:07

Hi Dieter,

du kannst es mal testen ob es jetzt OK ist.
Nicht vergessen noch andere Abläufe zu testen.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: FiFo: Probleme Enter und In Aktion

Postby lordbrummi » 04.01.2018, 15:30

rjversluis wrote:Hi Dieter,

du kannst es mal testen ob es jetzt OK ist.
Nicht vergessen noch andere Abläufe zu testen.


Hi Rob,

Blocklängen und Autolängen (Fifo-Größe und Abstand) sowie enterlcid und fifoin habe ich schon getestet und auf Seite 8 berichtet, funktioniert alles :thumb_up:

Zu den Signalen:
Unser aktueller Fall war: Signal geht auf Rot nachdem Auto1 b1 verlassen hat:
Auto2 fährt noch aus (Orange Phase der Ampel), Auto3 V0 mitten im Block ist beseitigt, geht jetzt erst am IN auf V0 -> ok :thumb_up:

2 Abläufe bei den Signale sollten wir aber noch verbessern:

Ablaufbeschreibung:
Ablauf1:
Signal von b1 ist grün, alle starten von den Startblöcken nach b1, Auto1 war aber noch nicht am IN von b1!
Signal von b1 geht jetzt auf Rot (alle 3 bleiben auf VBlock/FS - besser wäre, siehe folgendes:)
- Auto1 kommt an den IN von b1 und geht direkt von VBlock/FS auf 0
(sollte aber eigentlich noch ausfahren, da Ziel b2 und FS schon gestellt . Falls nicht möglich, sollte es in dem Moment wenn Signal auf Rot geht auf Vmid gehen und am IN auf V0)
- Auto2 bleibt nach diesem Signal Rot auf VReise/VBlock (sollte auf Vmid gehen)
- Auto3 geht auf VMid -> ok

Ablauf2:
Signal von b1 ist rot, alle starten von den Startblöcken nach b1 und alle gehen am Enter von b1 auf Vmid -> ok!
Auto1 erreicht Enter von b1 und geht auf V0, die anderen beiden bleiben auf Vmid -> ok!
Signal von b1 geht jetzt auf grün, Auto1 geht auf VBlock/FS -> ok
Die Follower bleiben auf Vmid, könnten aber jetzt auch auf VBlock/FS gehen, da Signal jetzt grün (die Follower gehen erst auf VBlock/FS wenn der Vordermann am Enter von b2 ist)

Falls was unklar ist, einfach fragen :wink:

Grüße Dieter
TamsMC, Servodecoder und Magnetartikeldecoder, S88 Rückmeldung, OpenCar und 3-Leiter Bahn, Win10 64bit, RR 64bit
lordbrummi
 

Re: FiFo: Probleme Enter und In Aktion

Postby lordbrummi » 05.01.2018, 11:45

Moin Rob,

so noch weiter getestet.
Also bis auf die beiden oben erwähnten Ablaufverbesserungen siehts echt gut aus : :thumb_up:
Aber das dürfte jetzt nur noch ne Kleinigkeit sein.

Grüße Dieter
TamsMC, Servodecoder und Magnetartikeldecoder, S88 Rückmeldung, OpenCar und 3-Leiter Bahn, Win10 64bit, RR 64bit
lordbrummi
 

Re: FiFo: Probleme Enter und In Aktion

Postby lordbrummi » 06.01.2018, 10:51

Moin Rob,

also die 2 beschriebenen Abläufe solltest du noch nachbessern, dann haben wir es, alles andere sieht super aus.

Grüße Dieter
TamsMC, Servodecoder und Magnetartikeldecoder, S88 Rückmeldung, OpenCar und 3-Leiter Bahn, Win10 64bit, RR 64bit
lordbrummi
 

Re: FiFo: Probleme Enter und In Aktion

Postby rjversluis » 06.01.2018, 10:53

ping...
ping...

Es steht auf der liste, und ich sollte nichts. ;)
Jetzt ist es gleich wieder herunter gerutscht.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: FiFo: Probleme Enter und In Aktion

Postby lordbrummi » 06.01.2018, 11:02

rjversluis wrote:Es steht auf der liste, und ich sollte nichts. ;)

Ok, wusste ich nicht, neulich habe ich vorsichtig angefragt und du hattest zu der Zeit nichts auf der To-Do.
Du sollst auch nicht, du darfst :wink: :wink:

Grüße Dieter

PS: Ich gelobe Besserung
TamsMC, Servodecoder und Magnetartikeldecoder, S88 Rückmeldung, OpenCar und 3-Leiter Bahn, Win10 64bit, RR 64bit
lordbrummi
 

PreviousNext

Return to CarSystem, FiFO (DE)