Page 2 of 5

Posted: 20.09.2010, 14:57
by andre0604
Hi Rob,

no Problem. If there is something to test I will do it ASAP.

Best regards
Andre

Posted: 20.09.2010, 16:17
by rjversluis
Hi Andre,

revision 1855 has a new command station in the list of controllers: tamsmc.

Just give it a try.

Posted: 21.09.2010, 06:50
by Peter Mueller
andre0604 wrote:good offer. So all TAMS users please cry here I am...
Here I am!

And I have changed my vote. But I still have to update the program and change the settings to test it.

Posted: 21.09.2010, 07:14
by rjversluis
Hi,

do not forget to read this:
http://wiki.rocrail.net/doku.php?id=p50 ... ming_track

Its kind of stupid, but I cannot do better with the p50xa protocol used by Tams for the programming track.
It just returns a number which must be catch synchrony.

Posted: 21.09.2010, 09:54
by andre0604
Hi Rob,

today morning I did test the new TAMS Library and it is working fine. I did not test the programming track because I thought the P50Xa protocoll is not implemented yet. If I understood the Wiki correct the P50Xa is implemented already. Unbelievable :rr_for_ever:

Best regards
Andre

Posted: 21.09.2010, 10:09
by rjversluis
Hi Andre,

CV read, CV write and POM write are implemented.
Did you test the CV read/write?

Posted: 21.09.2010, 10:26
by andre0604
Hi Rob,

I did not test CV read/write until now. I hope I can do it this evening.

Best regards
Andre

Posted: 21.09.2010, 22:36
by andre0604
Hi Rob,

just tested to read CV from a loco on the programming track but it was not successful. Reading direct with Easy Control is working. Attached is the trace file for your info.

Best regards
Andre

Posted: 22.09.2010, 06:58
by norbert
Hi

I have also get the same error, if reading the CV of PT.
I have tested with usb and serial Interface.

OSerial 0396 Timeout on serial read[com1] 0 of 1 read.[rc=0] tries=3
OP50x 0207 unable to read in end byte [0x0D]
OP50x 0227 ERROR in transact!!! rc=0 state=RCVERR
OControl 0762 Read error.

best regards Norbert

Posted: 22.09.2010, 07:00
by rjversluis
Hi Andre,

there is no response coming within the read timeout you specified in the rocrail.ini, just set the timeout to 30000 ms.

The PT response can take long depending of the value of the CV.

Posted: 22.09.2010, 07:14
by rjversluis
Hi Andre,

use this setup:

http://launchpad.net/rocrail/snapshot/s ... nicode.exe

and switch byte trace level on.

Posted: 22.09.2010, 23:00
by andre0604
Hi Rob,

no success. Time out extended to 30000 and using your latest snapshot. Trace level set to byte and attached.

Best regards
Andre

Posted: 23.09.2010, 06:11
by rjversluis
Hi Andre,

well, I have no clue why it does not respond.
Maybe you should test this command using a terminal window directly connected to the Tams MC.

After the connection is established you must write following command to read CV3:

PTRP 3

You must end this command with the enter key.

All programming instructions are listed in this dokument:
http://www.tams-online.de/htmls/downloa ... erface.txt
Just search for "Programmiergleisbefehle".

Posted: 23.09.2010, 06:19
by rjversluis
Hi Andre,

how is the setting for the serial port?

P50X-only or P50X-mixed mode?

In case of mixed mode you must prefix the character 'x' before all commands.

Posted: 23.09.2010, 06:39
by rjversluis
Hi Andre,

I added the 'X' prefix in the tamsmc library:

https://launchpad.net/rocrail/+download