Raspberry Roco 10764 Programmiergleis

Re: Raspberry Roco 10764 Programmiergleis

Postby StefanF. » 28.04.2018, 19:57

Hallo,
weißes Kabel ist für vorne. Steht so in der Bedienungsanleitung. Licht wird ganz normal über F0 ein- und ausgeschaltet. Die vordere Beleuchtung wird wohl schon an Masse angeschlossen sein, dann ist nicht mehr zu tun. Das Thema hat jetzt aber nichts mehr mit rocrail zu tun. Bitte den Beitrag schließen.
Beste Grüße
Stefan
=========================
Zentrale: OpenDCC Z1 und 2 Booster: OpenDCC - Booster2
Loconet MGV85, 50, 93,76,77,136
Rechner: Kubuntu14.04 auf 2*Core i3 (3Monitore) 6GBRAM
=========================
StefanF.
 

Re: Raspberry Roco 10764 Programmiergleis

Postby Besra » 28.04.2018, 22:52

Auslesen [geht nur], wenn auch ein Motor am Decoder ist, das hat gedauert. Auch die Quittierung über die LED/Summer geht nur, wenn der Motor dran ist. Wisst ihr den Grund dafür?


Hi,
auch das hat nichts mit Rocrail zu tun - aber ja, der Grund ist einfach, dass der Dekoder für die Quittierung einen kleinen Strom fließen lässt, den die Zentrale wiederum als Quittungssignal erkennt. Strom fließt aber nur, wenn ein Stromkreis (über einen Verbraucher / eine Last) geschlossen wird. Diese Last ist bei Lokdekodern zumindest im Regelfall der Motor. Ist er "nicht da" bzw. nicht angeschlossen oder wurde schlicht vergessen, die Kohlebürsten wieder einzubauen, kann keine Quittierung erfolgen.

Grüße
Bernd
Maerklin H0, DCC and MM, Intellibox (I) via ULNI, Booster Tams B4, Throttle Digitrax UT4, LocoNet.
Loco decoders: Zimo, Uhlenbrock, Maerklin & ESU.
Rocweb, Win10 32bit & 64bit
Besra
 

Re: Raspberry Roco 10764 Programmiergleis

Postby raspberry » 10.05.2018, 16:27

Hallo zusammen,
leider muss ich mich erneut melden. Habe nun ein Raspberry Pi 3 Model B+ auf das ich die Konfiguration meines Raspberry Pi 2 übertragen habe (Rocrail und ddx als Zentrale zur Programmierung, über Digitus DA-70156). Steuerung der Lok geht mit Pi 3 über DDX. Schreiben geht mit beiden Raspberrys (inklusive Quittierung über LED und Summer bei Pi 2 und 3). Nur das Auslesen der CV Werte klappt nicht mit dem Pi 3 und leider auch nur unzuverlässig und ohne Regel mit dem Pi 2. Beim Pi 2 erhalte ich beim Auslesen immer eine Quittierung, aber manchmal als Ergebnis -1, beim Pi 3 nie eine Quittierung beim Auslesen und immer -1. Auch beim Schreiben erhalte ich mit dem Pi 3 nicht immer eine Quittierung, Programmierung kommt aber an.
Wenn ich beim Pi 3 Get CV aktiviere, erhalte ich folgenden Log:
Code: Select all
16:31:16 PT: disable booster output
16:31:16 PT: ack = 0
16:31:16 PT: sending 204 bytes checking value 250...
16:31:14 PT: sending 210 bytes checking value 240...
16:31:13 PT: sending 210 bytes checking value 230...
16:31:12 PT: sending 210 bytes checking value 220...
16:31:11 PT: sending 210 bytes checking value 210...
16:31:10 PT: sending 204 bytes checking value 200...
16:31:09 PT: sending 204 bytes checking value 190...
16:31:08 PT: sending 216 bytes checking value 180...
16:31:06 PT: sending 204 bytes checking value 170...
16:31:05 PT: sending 210 bytes checking value 160...
16:31:04 PT: sending 210 bytes checking value 150...
16:31:03 PT: sending 210 bytes checking value 140...
16:31:02 PT: sending 204 bytes checking value 130...
16:31:01 PT: sending 210 bytes checking value 120...
16:31:00 PT: sending 210 bytes checking value 110...
16:30:58 PT: sending 216 bytes checking value 100...
16:30:57 PT: sending 204 bytes checking value 90...
16:30:56 PT: sending 210 bytes checking value 80...
16:30:55 PT: sending 210 bytes checking value 70...
16:30:54 PT: sending 210 bytes checking value 60...
16:30:53 PT: sending 210 bytes checking value 50...
16:30:51 PT: sending 210 bytes checking value 40...
16:30:50 PT: sending 210 bytes checking value 30...
16:30:49 PT: sending 216 bytes checking value 20...
16:30:48 PT: sending 210 bytes checking value 10...
16:30:46 PT: sending 667 bytes checking value 0...
16:30:46 PT: start polling...
16:30:46 PT: power on cycle
16:30:46 PT: enable booster output
16:30:46 PT: cvget for 0

Es scheint vom Decoder nichts zurückzukommen. Beim Pi 2 hört es nach
Code: Select all
16:30:48 PT: sending 210 bytes checking value 0...

auf und ich habe den CV.
Habt ihr Idee, woran es liegen könnte? Was könnte ich probieren? Zum Beispiel Alternative zum Digitus DA-70156, oder hilft das nichts?

Besten Dank schon einmal für die Rückmeldung und viele Grüße!
raspberry
 

Re: Raspberry Roco 10764 Programmiergleis

Postby raspberry » 12.05.2018, 11:11

Hallo,

raspberry wrote:das Auslesen der CV Werte klappt nicht mit dem Pi 3

Habe nun das Netzteil des Pi 2 (Netzteil 1) an das Pi 3 geschaltet, und siehe da, auch das Auslesen klappt. Beim neuen Netzteil (Netzteil 2), das ich für das Pi 3 gekauft habe, ist das Kabel fest mit dem Netzteil verbunden. Netzteil 1 läuft per USB. Beide Netzteil haben 5 V und 2,1 A.
Habe dann noch an Netzteil 1 ein zweites Micro USB Kabel (Kabel 2) getestet, damit ging es auch nicht. Habe die Leitungen des Kabels durchgemessen, bei diesem Kabel (Kabel 2) sind D+ und D- nicht angeschlossen/verbunden. Bei Kabel 1 mit dem das Auslesen geht sind D+ und D - verbunden. Werde mir nun noch ein neues Micro USB Kabel kaufen und damit testen.
Mit dem Netzteil des iPad und Kabel 1 geht es auch.
Habt ihr eine Erklärung dafür? Sind die Data Pins bei Netzteilen normalerweise belegt?

Melde mich, sobald ich Neuigkeiten habe.

Beste Grüße!
raspberry
 

Previous

Return to BastelEcke (DE)