[Solved} srcp switches and outputs

Moderator: Moderators

[Solved} srcp switches and outputs

Postby Richard-TX » 10.06.2013, 01:44


I am seeing something I have not seen before.

Switch [s-sw1] will be set to [turnout,1,0]
command written: SET 1 GA 40 1 1 -1#

Everything seems to have a trailing "#"

command written: SET 2 POWER OFF#

Is the "#" supposed to be there?
Last edited by Richard-TX on 07.08.2013, 10:53, edited 2 times in total.

Postby Richard-TX » 10.06.2013, 01:49

here is the trace
You do not have the required permissions to view the files attached to this post.

Postby rjversluis » 10.06.2013, 06:11

Its just the trace line; I replaced the "\n" with "#" and forgot it to remove it after testing.
The "\n" is send to SRCPD.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
Site Admin

Postby Richard-TX » 10.06.2013, 06:34

I am not sure it would affect anything even it it was sent. srpcd seems to ignore extra parameters depending on what device is being set.

Return to srcp