[Solved] rocpro/rocview crashes

Moderator: Moderators

[Solved] rocpro/rocview crashes

Postby Richard-TX » 17.07.2013, 17:04

I am not sure where to put this issue.

Anyway, when I define srcp as an accessory decoder, Rocview crashes when I start Rocpro and select the controller and the decoder definition file.

here are all the pertinent files.
You do not have the required permissions to view the files attached to this post.
Last edited by Richard-TX on 07.08.2013, 10:50, edited 1 time in total.
Richard-TX
 

Postby Richard-TX » 17.07.2013, 17:05

here are some more files
You do not have the required permissions to view the files attached to this post.
Richard-TX
 

Postby rjversluis » 17.07.2013, 17:18

please provide a step by step guide to get it crashing.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Postby rjversluis » 17.07.2013, 17:21

You are trying to load an image; attach it also.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Postby Richard-TX » 17.07.2013, 17:32

here is the image
You do not have the required permissions to view the files attached to this post.
Richard-TX
 

Postby Richard-TX » 17.07.2013, 17:40

Rob,

Rocview crashes as soon as I select RPI-16.xml as the decoder definition file.

I have two Rocrail installations and it does not crash on my development PC. I made sure that the xml definition file is the same on both computers.
Richard-TX
 

Postby Richard-TX » 17.07.2013, 17:45

I decided to back out the srcp installation out and do it again but it still crashes at the same spot.

So I defined a srcp controller with a name of srcp
I added a stationary decoder with the name of rocpi and an address of 40.

I opened Rocpro and selected the rocpi deconder. I then selected the Rpi16.xml definition file and then rocview crashes.

.
Richard-TX
 

Postby Richard-TX » 17.07.2013, 17:49

If you are having problems duplicating the issue, let me know what I can do to aid in debugging. If there is a debugger than needs to be run, just let me know.
Richard-TX
 

Postby rjversluis » 17.07.2013, 17:57

your xml file is not well formed.
Just check it :
http://wiki.rocrail.net/doku.php?id=and ... l_not_load
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Postby rjversluis » 17.07.2013, 19:03

Yer evil. ;-)
You do not have the required permissions to view the files attached to this post.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Postby rjversluis » 18.07.2013, 12:50

I repaired your xml and it can now be viewed with Firefox to test it.
You do not have the required permissions to view the files attached to this post.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Postby Richard-TX » 18.07.2013, 15:12

Thanks so much Rob.....

That is above and beyond the call of duty.

Thanks for the xml checking links. They are now in my bookmarks.


Richard
Richard-TX
 


Return to srcp