Digitrax PR3 comms problem.(Cancelled)

Post Reply
mcnaugg
Posts: 83
Joined: 10.11.2013, 22:16
Location: Durban, South Africa

Digitrax PR3 comms problem.(Cancelled)

Post by mcnaugg » 10.02.2019, 09:53

I seeking some help on what I think is a communication problem between my PC and Loconet Controls. I am using a Digitrax DS100, DT402 throttle, UP5 patch panel and a DS52 output accessory decoder. I have also installed a number of GCA modules (6 x GCA50’s although 2 are not connected at the moment). These are in turn connected to a number of GCA 76 & 77 output modules plus GCA93 Input modules. I am using Rocrail software for control. Everything was working until a couple of months ago but when I tried recently I things didn't work 100%.
When using the hand throttle everything seems to work. I can switch the two Hornby point motors connected to the DS52 and I can also switch the other points(switches) via the GCA module/s via the hand held. In all cases when I switch a point with the hand held the respective yellow point bar on the Rocrail screen indicates the switching. Also the Led on the PR3 flickers when a throttle command is sent and the Leds on the GCA50 also flicker.
From the PC Keyboard I can switch the track power on/off but that is all I can do. I get all indications of say point motor/switch etc on the screen. In the PR3 setup panel I have unchecked the CTS option. I have tried earlier versions of Rocrail and current versions with the same result.

Below are the screen displays when using the PC keyboard and when using the Digitrax Hand Held trying to operate switch no 1
From Keyboard.

20:18:45 turnout [sw01] 0001 1 turnout fada=0000 pada=0001 bus=0 addr=1 port=1 gate=0 dir=0 action=1 delay=0
20:18:45 Switch [sw01] will be set to [turnout,0,0]
20:18:43 turnout [sw01] 0001 1 straight fada=0000 pada=0001 bus=0 addr=1 port=1 gate=0 dir=1 action=1 delay=0
20:18:43 Switch [sw01] will be set to [straight,0,0]
Although the above is displayed on the screen the respective point motors DO NOT operate.

From Throttle

20:20:48 TODO: Fast Clock slot read
20:20:34 sw addr=0 port=0 value=0
20:20:34 sw addr=0 port=0 value=1
20:20:30 sw addr=0 port=1 value=0
20:20:30 sw addr=0 port=1 value=1
When switched via the Hand Held the point motors DO operate.

Regards
Gareth
You do not have the required permissions to view the files attached to this post.

Post Reply

Return to “Loconet”