[SOLVED] V-curve cannot write

Moderator: Moderators

[SOLVED] V-curve cannot write

Postby hclaassens » 14.07.2011, 21:26

I am using a ib-com and ord-1 in Xubuntu 11.04.
The locos use the ib-com in ulni mode and i'm trying to program the v-curve of a Lenz LE103XF decoder.
First I select the loco, switch to programming mode,
choose PT on and click the curve button.
Then I choose to not read the cv's from the decoder,
select 153 in the highest step and lineair to fill the other steps.
Then after cliclking OK I expect it will start writing cv's 67 until 94. But it is READING!!!!
After completing I've tried to manual read cv 68, which gives a value of 13 and reprogrammed it to 6 and verifying it again. It was Ok.

What is wrong?
You do not have the required permissions to view the files attached to this post.
hclaassens
 

Re: V-curve cannot write

Postby hclaassens » 18.07.2011, 21:32

Nobody has seen this?

hclaassens wrote:I am using a ib-com and ord-1 in Xubuntu 11.04.
The locos use the ib-com in ulni mode and i'm trying to program the v-curve of a Lenz LE103XF decoder.
First I select the loco, switch to programming mode,
choose PT on and click the curve button.
Then I choose to not read the cv's from the decoder,
select 153 in the highest step and lineair to fill the other steps.
Then after cliclking OK I expect it will start writing cv's 67 until 94. But it is READING!!!!
After completing I've tried to manual read cv 68, which gives a value of 13 and reprogrammed it to 6 and verifying it again. It was Ok.

What is wrong?
hclaassens
 

Re: V-curve cannot write

Postby Pirat-Kapitan » 19.07.2011, 14:46

hclaassens wrote:Nobody has seen this?


Seen yes,
but I do not use an IB with Rocrail.

best Regards
Johannes
Clearasilfahrer auf Spur G&H0m, Lenz LZV (3.6), ORD-20, Manhart-Funki und WLM, RS-Bus Rückmelder (Reedkontakte/GBM),
Rocrail auf RasPi mit mobilen Geräten (andRoc). Details auf http://wiki.rocrail.net/doku.php?id=use ... at-kapitan.
Pirat-Kapitan
 

Postby ron&bram » 19.07.2011, 15:52

I had the same behaviour when I used the Hornby Elite as command station (Xpressnet), cv 67 was programmed, the other cv's read. It is soo long ago that I can not remember what the problem was.
Best regards, Viele Grüsse, vriendelijke groeten, Ronald :rr_cap:
GCA85/50/93/145/146/153 Loconet, Twincenter+booster for locs, seperate booster for accessory decoders, dedicated laptop with XP and Ubuntu for Rocrail, AndRoc, LGB indoor OTF layout
ron&bram
 

Postby M_C_nl » 19.07.2011, 18:15

Hi hclaassens,

for reading and writing CVs I use an external program, because I had some problems with rocrail on this feature, too.

Regards,
Maxel :-)

P.S. Sorry for mentioning an external program by name and link. :cry:
Last edited by M_C_nl on 19.07.2011, 20:10, edited 1 time in total.
H0 2-Leiter DCC; Steuern, Melden: Selectrix (Rauthenhaus, P. Stärz); Fahren: DCC (Tams); PC: Windows 7 (64bit)
M_C_nl
 

Postby Besra » 19.07.2011, 18:28

Hi,

no promoting third party products, Maxel. Shame on you :lol: Henning Voosen's programmer is a very handy dandy tool, though. Of course I never ever used it :lol:

As far as I know, it does not support those fancy new LocoNet-driven IB's in any case.

Best regards
Besra
Maerklin H0, DCC and MM, Intellibox (I) via ULNI, Booster Tams B4, Throttle Digitrax UT4, LocoNet.
Loco decoders: Zimo, Uhlenbrock, Maerklin & ESU.
Rocweb, Win10 32bit & 64bit
Besra
 

Postby rjversluis » 19.07.2011, 18:38

Besra has right: This is nor fair. ;)

Pushing the OK button in the V-Curve dialog will send CV SET commands to the connected command station.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Postby hclaassens » 19.07.2011, 20:42

Rob,

That is what I've understood that the CV set commands are send to the command station. I
wonder if this intended behaviour is in the trace file? Could you please take a look at it?

Best regards,
Hans



rjversluis wrote:Besra has right: This is nor fair. ;)

Pushing the OK button in the V-Curve dialog will send CV SET commands to the connected command station.
hclaassens
 

Postby Besra » 19.07.2011, 20:50

Hi Maxel!

I wrote:no promoting third party products

This was meant as a joke, Sir! No harm meant!

Henning's proggie is a one-trick-tool (actually it knows more than just one trick ;)) - ain't no model railroad control system, no competitor at all!

My apologies and best regards
Besra
Maerklin H0, DCC and MM, Intellibox (I) via ULNI, Booster Tams B4, Throttle Digitrax UT4, LocoNet.
Loco decoders: Zimo, Uhlenbrock, Maerklin & ESU.
Rocweb, Win10 32bit & 64bit
Besra
 

Postby Besra » 19.07.2011, 20:58

Hi Rob,

to me it looks like there is some misunderstanding between Rocrail and the IB-Com:

Code: Select all
20110714.221139.997 r9999c lnreader OLocoNet 1210 LNCV response
20110714.221139.997 r9999I lnreader OControl 0807 Program event...value=0
20110714.221140.962 r9999c lnreader lnmon    1277 Read Programming Track: Read Unknown mode; Could be IB-Com Setting CV1 to 0 (0x00)


Best regards
Besra
Maerklin H0, DCC and MM, Intellibox (I) via ULNI, Booster Tams B4, Throttle Digitrax UT4, LocoNet.
Loco decoders: Zimo, Uhlenbrock, Maerklin & ESU.
Rocweb, Win10 32bit & 64bit
Besra
 

Postby rjversluis » 20.07.2011, 06:44

Hi Besra,

you can ignore the lnmon line because the loconet monitor does not know all of the IB stuff.

The V-Curve send exactly the same commands as the rest of the programming tab, so if you can get/set another CV value it should work.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Postby rjversluis » 20.07.2011, 06:54

I think we have a problem:

Code: Select all
20110720.075242.069 r9999I cmdrB730 OVirtual 0339 program command: 1
20110720.075242.069 r9999I cmdrB730 OVirtual 0370 set CV67 to 0...
20110720.075242.069 r9999I cmdrB730 OControl 0183 Program event...value=0
20110720.075242.338 r9999I cmdrB730 OVirtual 0339 program command: 0
20110720.075242.338 r9999I cmdrB730 OVirtual 0344 get CV68...
20110720.075242.338 r9999I cmdrB730 OControl 0183 Program event...value=0
20110720.075242.394 r9999I cmdrB730 OVirtual 0339 program command: 0
20110720.075242.394 r9999I cmdrB730 OVirtual 0344 get CV69...
20110720.075242.394 r9999I cmdrB730 OControl 0183 Program event...value=0


It seems that only the first command is a set...
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Postby rjversluis » 20.07.2011, 07:03

Hi,

I have fixed this problem in revision 2736.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Postby hclaassens » 20.07.2011, 07:28

Hi,

I'll update and test tonight.
Thanks for the fast response. :D

Hans


rjversluis wrote:Hi,

I have fixed this problem in revision 2736.
hclaassens
 

V-curve cannot write

Postby hclaassens » 20.07.2011, 17:57

Hi Rob,

I've tested it and saw 2 things:

1. It is indeed writing the v-curve!

2. When trying to read a single cv with an address within the v-curve (67-94) range, the screen is NOT updated. The trace file shows the value though.
I've tried other cv's like 1, 29 and 50, then it is OK.

I've attached thetrace, ini, and plan files

Best regards,
Hans
You do not have the required permissions to view the files attached to this post.
hclaassens
 

Next

Return to Loconet