[Solved]ECos working fine with Rocrail till Rocrail crashed

Moderator: Moderators

[Solved]ECos working fine with Rocrail till Rocrail crashed

Postby dntower85 » 21.12.2011, 00:45

I have a ECoS 5200 and have been using it with RocRail for about 6 months now.

It was working fine this moring and I was even using andRoc with it.
But I was updating the track plan and tried to save it as a different name and when I tried to restart RocRail it instantly crashed. I tried replacing the ini files and xmlfiles with the .bak files but they seemed corruppted too.

Did the reboot thing several times. still crashed as soon as the program was lanched.

I then uninstalled rocrail and got the latest version after that and Rocrail would start and I was able to get the previous plan to load, but after I configured the Ecos IP addrest and port, I could connect the the ECoS and turn it off and on but I can no longer get it to communicate with any locomotives or switches.

Im including all the files in my documents\Rocrail folder in this zip file.

I have been looking at these files for several hours and just cant figure out why RocRail can turn the power on and off but is not talking to the locomotives and switches.

I did try a demo version of itrain just to test the communication with the Ecos to make sure it the ECos didn't have a problem and it worked ok.

Best regards
Darrin Towers
You do not have the required permissions to view the files attached to this post.
Last edited by dntower85 on 21.12.2011, 14:44, edited 1 time in total.

Postby rjversluis » 21.12.2011, 08:25

Hi Darren,

because you have defined two command stations the first will be used by default for all objects including locomotives if no other IID is specified.
The first CS in your rocrail.ini is the virtual CS, not the ecos.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
Site Admin

Postby dntower85 » 21.12.2011, 14:43

Thanks Rob that was it.

I when I re installed the software and rebuilt the file I forgot that I had to remove it.
Sometimes the simplest mistakes are the hardest to find.


Return to ECoS - Marklin CS1